Default Rewrite rules for nginx / 403 offline.html and robots.txt


This is my last try to get this problem solved. I got stuck for a few days now.

I setup Oxid eShop on a system with nginx (1.0.14), php-fpm and mysql.

My vhost configuration has been inspired by Nginx Rewrite Regeln für OXID eShop. (german)

Most things are working as expected, nothing to complain about, but when I call robots.txt or offline.html I get a 403 Forbidden with this configuration.

When I comment out the following part, I can call robots.txt and offline.html with status 200 Found. So, there is nothing else that blocks access to those files.

    # SEO URLs auf die oxseo.php leiten.
    location / {
        if (!-e $request_filename) {
            set $script_name /oxseo.php;
        include fastcgi_params.oxid;
Does anyone had this problem too or can help to solve the problem? To turn off SEO urls wouldn't be a solution.
Reply With Quote