OXID Community Forum

> German forum > Newbies > Produktliste und iframe verschwunden
Login
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Thread: Produktliste und iframe verschwunden


Reply
 
Thread Tools Display Modes
#Top   #11  
Old 03-31-2012, 10:01 AM
gremlins gremlins is offline
Junior Member
Join Date: Mar 2012
Posts: 12
gremlins is on a distinguished road
Default Re: Produktliste und iframe verschwunden

Hat denn keiner eine Idee, was die Fehlermeldungen bedeuten?

Anscheinend geht es doch nur um die 2 oberen Zeilen :

Quote:
EoxObjectException-oxException (time: 2012-03-30 17:37:32): [0]: not set
in dieser Datei?

Quote:
Stack Trace: #0 /pages/eb/4d/d0007323/home/htdocs/poolroboter24/core/oxutilsobject.php(125):
In der php-datei steht von Zeile 125-131 Folgendes:

Quote:
$oActionObject = $this->_getObject( $sActionClassName, $iArgCnt, $aArgs );
if ( $blCacheObj && $oActionObject instanceof oxBase ) {
self::$_aInstanceCache[$sCacheKey] = clone $oActionObject;
}

return $oActionObject;
}
Sind wir dem Problem auf der Spur?

Last edited by gremlins; 03-31-2012 at 10:22 AM.
Reply With Quote
#Top   #12  
Old 03-31-2012, 02:44 PM
Marco Steinhaeuser's Avatar
Marco Steinhaeuser Marco Steinhaeuser is online now
Community Guide @ OXID
Join Date: Oct 2008
Posts: 11,090
Marco Steinhaeuser is on a distinguished road
Default Re: Produktliste und iframe verschwunden

Hallo,

versuch bitte folgendes:
- Installiere parallel zum bestehenden Shop noch eine frische Installation, lade die Dateien explizit binär auf den Server. Besteht das Problem auch dort?
- Prüfe mit einer oxchkversion die Konsistenz Deiner Dateien in beiden Installationen. Mit welchem Ergebnis?
- Entferne alle Module aus der Installation. Besteht das Problem weiter?
- Verbinde die Parallelinstallation mit der alten Datenbank. Besteht das Problem weiter?

Gruß
__________________
Marco
http://about.me/marco.steinhaeuser

Will ignore unsolicited support requests via PM, email or IM.
Reply With Quote
#Top   #13  
Old 04-01-2012, 02:48 PM
gremlins gremlins is offline
Junior Member
Join Date: Mar 2012
Posts: 12
gremlins is on a distinguished road
Default Re: Produktliste und iframe verschwunden

Hallo,

also ich habe nun folgendes getan:

1. shopsoftware neu installiert mit leerer db.
Ergebnis : allos ok, keine fehler

2. neuen shop mit bestehender db vom originalshop verbunden
Ergebnis: gleicher fehler im admin-bereich Produktliste

Also scheint es ganz offensichtlich ein db- fehler zu sein, aber welcher?

Und Module, habe ich keine installiert auf dem originalen Shop.

Was kann ich nun tun?

Die neue DB mit den Daten der alten updaten bringt ja dann sicher auch nichts mehr.

Last edited by gremlins; 04-01-2012 at 02:52 PM.
Reply With Quote
#Top   #14  
Old 04-01-2012, 05:42 PM
Marco Steinhaeuser's Avatar
Marco Steinhaeuser Marco Steinhaeuser is online now
Community Guide @ OXID
Join Date: Oct 2008
Posts: 11,090
Marco Steinhaeuser is on a distinguished road
Default Re: Produktliste und iframe verschwunden

Hi,

bitte leere die oxlogs und die oxseologs (natürlich zuerst in einer gespiegelten Testumgebung!). Danach generier die Views bitte noch einmal neu.

Wenn das nicht hilft, scheint es sich um einen Fehler in einem der zuletzt eingetragenen Artikel zu handeln, wahrscheinlich irgendein Sonderzeichen o.ä. Benutzt Du einen WYSIWYG-Editor?

Gruß
__________________
Marco
http://about.me/marco.steinhaeuser

Will ignore unsolicited support requests via PM, email or IM.
Reply With Quote
#Top   #15  
Old 04-01-2012, 10:16 PM
gremlins gremlins is offline
Junior Member
Join Date: Mar 2012
Posts: 12
gremlins is on a distinguished road
Default Re: Produktliste und iframe verschwunden

Gerade habe ich (mal wieder) einen testshop installiert, und zwar in den root einer von mit nicht genutzten Domain.

Danach via Backend die DB vom Original-Shop hochgeladen.

Dabei hat es mir zwar die Formatierung der Produktbeschreibungen zerhackt, aber der Fehler in der Produktliste ist verschwunden.

Sollte doch etwas mit der Formatierung der Beschreibung des letzten Produkts gewesen sein?

Wo in der DB finde ich eigentlich die "long descr." ? Und kann ich einfach ein Produkt aus der DB Tabelle oxarticles löschen?

Achja einen WYSIWYG benutze ich nicht.
Reply With Quote
#Top   #16  
Old 04-01-2012, 10:49 PM
vanilla thunder's Avatar
vanilla thunder vanilla thunder is online now
Senior Member
Join Date: Nov 2010
Posts: 3,223
vanilla thunder is on a distinguished road
Default Re: Produktliste und iframe verschwunden

die longdesc ist in oxartextends.

Die Produkte kannst du zwar löschen, aber es bleiben ja die Kategorienzuordnungen und die Sachen in oxartextends übrig. Ich würde eher die einzelnen Spalten/Zellen leeren.
Reply With Quote
#Top   #17  
Old 04-02-2012, 09:53 AM
gremlins gremlins is offline
Junior Member
Join Date: Mar 2012
Posts: 12
gremlins is on a distinguished road
Default Re: Produktliste und iframe verschwunden

In der oxartextends sind die Spalten für Decr alle leer. Das finde ich doch seltsam. Irgendwo muss doch der Beschreibungstext meiner Artikel zu finden sein!?
Reply With Quote
#Top   #18  
Old 04-02-2012, 12:02 PM
vanilla thunder's Avatar
vanilla thunder vanilla thunder is online now
Senior Member
Join Date: Nov 2010
Posts: 3,223
vanilla thunder is on a distinguished road
Default Re: Produktliste und iframe verschwunden

bist du auch wirklich in oxartexttends und nicht in oxv_oxartextends? (unter gewissen umständen kann eine View leer sein obwohl die "echte" Tabelle doch Inhalte hat)
Reply With Quote
#Top   #19  
Old 04-02-2012, 03:31 PM
gremlins gremlins is offline
Junior Member
Join Date: Mar 2012
Posts: 12
gremlins is on a distinguished road
Default Re: Produktliste und iframe verschwunden

Also ich habe die Sache jetzt so gelöst:

Den Testshop mit der neuen Datenbank verbunden, welche den Update der alten enthielt.

Alle Produktbeschreibungen neu formatiert und überflüssige Buchstabenfolgen gelöscht.

Den Inhalt aller CMS- Seiten neu gefüllt, alle SEO-Angaben bzw. metas waren noch da.

Auch alle Aktionen mussten neu eingestellt aktiviert werden.

Auch bei den Ländern, Versandkostenregeln usw. war einiges durcheinander.

Als Letztes den Originalshop mit der neuen Datenbank verbunden, Fertig!

Was bleibt ist ein ungutes Gefühl, da die Ursache des Fehlers unbekannt blieb.

Allerdings werde ich in Zukunft einen anderen Browser als FF nutzen, wenn ich im Admin-Bereich Veränderungen durchführe.
Vielleicht war mein Browser der Spinner, welcher mich in meiner Arbeit volle 4 Tage zurückwarf.

Trotzdem Danke für Hilfe und Inspirationen.

Beste Grüße
Reply With Quote
Reply

Bookmarks

Tags
artikelliste, backend, iframe, produktliste, verschwunden

« Previous Thread | Next Thread »
Thread Tools
Display Modes

Nicht Sichtbar
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
facebook iframe integration - tutorial und erfahrungen? scuba303 Entwickler 1 03-23-2012 11:27 PM
Launch iFrame in Lightbox possible using the oxzoompictures.js ? breezemaster Templates and Design 0 02-06-2012 11:07 AM
Bestellungen verwalten - iFrame Fehler BenBen Administration 0 08-28-2011 11:21 PM
cms in iframe einbinden mn Entwickler 4 05-10-2011 04:55 PM
Shop mittels IFrame dynamisch einbinden freelicer Newbies 7 04-26-2010 03:36 AM

All times are GMT +1. The time now is 01:33 AM.