OXID Community Forum

> International Forums > Templates and Design > Image source missing for slider, and different image being used in the cart.
Login
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Thread: Image source missing for slider, and different image being used in the cart.


Reply
 
Thread Tools Search this Thread Display Modes
#Top   #1  
Old 09-19-2017, 12:59 PM
[email protected] ab@troja.al is offline
Junior Member
Join Date: Mar 2017
Posts: 18
ab@troja.al is on a distinguished road
Default Image source missing for slider, and different image being used in the cart.

CE 4.10.4
Hi, i've had this issue for a while, when adding multiple images to products, the slider thumbnails don't get a source at all (img src is empty). Slider works, clicking between thumbnails works (as shown in attachments). Manually adding the picture path to the image source in Inspect Element works (obviously just for me and until next refresh), "Generate Icons automatically from Thumbnails (might slow down your server)" is selected, but in the product's Pictures settings (screenshot attached), the icon isn't present, same happens when adding products to the cart...in the img src, there's path to a "spinner.gif" instead of the icon of the product, (same happens with product invoice). What could be causing this? cause I've setup a shop in my localhost and this issue doesn't occur, personally i'm suspecting the server since a while ago even the slider didn't work, but i enabled "PHP-allow_url_fopen" and that fixed it.
Attached Images
File Type: jpg morepic1.jpg (36.5 KB, 10 views)
File Type: jpg morepic2.jpg (43.6 KB, 8 views)
File Type: jpg morepic3.jpg (44.5 KB, 8 views)
File Type: jpg picturesettings.jpg (23.6 KB, 9 views)
File Type: jpg testcart.jpg (13.5 KB, 6 views)
Reply With Quote
#Top   #2  
Old 09-19-2017, 01:45 PM
patchwork.de patchwork.de is offline
Senior Member
Join Date: Jul 2012
Location: im Taunus
Posts: 1,053
patchwork.de is on a distinguished road
Default AW: Image source missing for slider, and different image being used in the cart.

the picture spinner.gif will be replaced by the picture given in data-src (see source)
-> check if this picture exists and the directory is writeable

PS loading a thumbnail responsive doesn´t really make sense and you can change the template
__________________
viele Grüße aus dem Taunus

www.patchwork.de
Version 4.10.5 - Flow mit child-theme

kostenloses WaWi:
wawi.patchwork.de

Last edited by patchwork.de; 09-19-2017 at 01:48 PM.
Reply With Quote
#Top   #3  
Old 09-19-2017, 02:23 PM
[email protected] ab@troja.al is offline
Junior Member
Join Date: Mar 2017
Posts: 18
ab@troja.al is on a distinguished road
Default AW: Image source missing for slider, and different image being used in the cart.

The picture does exist, as i explained in the thread, problem is, the icon isn't being generated from those pictures, and because of it, the cart icon is that .gif and the img src of the slider is empty. (check an attached jpg, you'll see that in the Pictures menu of the product, the "Icon" section is empty.
Reply With Quote
#Top   #4  
Old 09-19-2017, 02:47 PM
patchwork.de patchwork.de is offline
Senior Member
Join Date: Jul 2012
Location: im Taunus
Posts: 1,053
patchwork.de is on a distinguished road
Default AW: Image source missing for slider, and different image being used in the cart.

check the permissions of /out/pictures/generated/product/1/ .../2 ... and subdirectories (see my last post)
__________________
viele Grüße aus dem Taunus

www.patchwork.de
Version 4.10.5 - Flow mit child-theme

kostenloses WaWi:
wawi.patchwork.de
Reply With Quote
#Top   #5  
Old 09-19-2017, 03:02 PM
[email protected] ab@troja.al is offline
Junior Member
Join Date: Mar 2017
Posts: 18
ab@troja.al is on a distinguished road
Default AW: Image source missing for slider, and different image being used in the cart.

/out/pictures/generated/product/....every file and folder is set to 777...and oddly enough, folders "icon", "thumb" have 1 and 2 subfolders (respectively), that are empty.
Reply With Quote
Reply

Bookmarks

Tags
cart, image, missing, slider, source

« Previous Thread | Next Thread »
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Nicht Sichtbar
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Background Image Neo_000 Templates und Design 21 09-26-2014 07:55 PM
Problem mit background-image Kilic88 Templates und Design 4 04-01-2014 03:36 PM
Second Thumbnail Image mattow Developers 5 05-21-2013 04:14 AM
Image map bechado Newbies 3 01-16-2011 01:01 PM
not added to the image of the goods! vasiliy Feature requests 1 04-05-2010 08:22 PM

All times are GMT +1. The time now is 06:33 AM.