OXID Community Forum

> German forum > Bug-Verdacht > Externe URLs werden mit ? am Ende ausgegeben
Login
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Thread: Externe URLs werden mit ? am Ende ausgegeben


Reply
 
Thread Tools Search this Thread Display Modes
#Top   #1  
Old 01-06-2014, 09:11 AM
udel udel is offline
Member
Join Date: Apr 2012
Posts: 45
udel is on a distinguished road
Default Externe URLs werden mit ? am Ende ausgegeben

Ich hatte das hier schon mal angesprochen, da der Beitrag aber schon ein paar Tage älter ist, habe ich dort nicht wirklich Response bekommen: http://forum.oxid-esales.com/showthread.php?t=12884.

Und zwar wird an externen URLs, die im Backend für Kategorien eingetragen werden ein "?" angehangen. Das bringt unseren SEO ziemlich auf die Palme und ganz richtig kann das so ja auch nicht sein, oder?

Hier mal mein aktueller Recherchestand. Von außen kann ich also nicht beeinflussen, ob processUrl mit true oder false als zweitem Parameter übergeben wird.

oxcategory->getLink() verweist auf oxcategory->getStdLink() da folgende Bedingung erfüllt ist: $this->oxcategories__oxextlink && $this->oxcategories__oxextlink->value. In getStdLink greift auch direkt die erste (gleiche) Bedingung und es wird oxUtilsUrl->processUrl( $this->oxcategories__oxextlink->value, false) aufgerufen.

Der zweite Parameter steht für $blFinalUrl. Ist er true, werden überflüssige Endzeichen wie unser "?" hier abgeschnitten. Er steht aber auf false!? Jetzt Frage ich mich warum? Ist das ein Bug? Ich lande nur auf diesem Pfad, wenn ich eine externe URL für die Kategorie eingetragen habe. In dem Fall macht es doch eigentlich keinen Sinn, das Fragezeichen nicht abzuschneiden, oder?
Reply With Quote
#Top   #2  
Old 01-07-2014, 09:08 AM
Marco Steinhaeuser's Avatar
Marco Steinhaeuser Marco Steinhaeuser is online now
Community Manager @OXID
Join Date: Oct 2008
Posts: 12,669
Marco Steinhaeuser is on a distinguished road
Default AW: Externe URLs werden mit ? am Ende ausgegeben

Hallo,

sieht für mich wie ein Bug aus. Machst Du einen Eintrag? Beschreib bitte möglichst genau, wie man das reproduzieren kann.

Danke und Gruß
__________________
Marco
http://oxidforge.org
http://about.me/marco.steinhaeuser

Will ignore unsolicited support requests via PM, email or IM.
Reply With Quote
#Top   #3  
Old 08-30-2017, 07:18 PM
karnowski karnowski is offline
Junior Member
Join Date: Jun 2012
Posts: 13
karnowski is on a distinguished road
Default Re: Externe URLs werden mit ? am Ende ausgegeben

gabs da ne lösung ? hab das problem auch mit der version 4.10 sogar
Reply With Quote
#Top   #4  
Old 08-31-2017, 10:06 AM
Marco Steinhaeuser's Avatar
Marco Steinhaeuser Marco Steinhaeuser is online now
Community Manager @OXID
Join Date: Oct 2008
Posts: 12,669
Marco Steinhaeuser is on a distinguished road
Default AW: Externe URLs werden mit ? am Ende ausgegeben

Wenn nicht mal jemand einen Bug aufmacht, kann's auch keine Lösung geben.

Gruß
__________________
Marco
http://oxidforge.org
http://about.me/marco.steinhaeuser

Will ignore unsolicited support requests via PM, email or IM.
Reply With Quote
#Top   #5  
Old 08-31-2017, 03:02 PM
karnowski karnowski is offline
Junior Member
Join Date: Jun 2012
Posts: 13
karnowski is on a distinguished road
Default Re: Externe URLs werden mit ? am Ende ausgegeben

ciao marco ... hab das hier mal erfasst ... hoffe hab alles richtig gemacht .
https://bugs.oxid-esales.com/view.php?id=6686
Reply With Quote
#Top   #6  
Old 08-31-2017, 03:30 PM
Marco Steinhaeuser's Avatar
Marco Steinhaeuser Marco Steinhaeuser is online now
Community Manager @OXID
Join Date: Oct 2008
Posts: 12,669
Marco Steinhaeuser is on a distinguished road
Default AW: Externe URLs werden mit ? am Ende ausgegeben

Hi,

sieht gut aus. Ich weiss jetzt auch, was gemeint ist ^^
Wie stellt sich das denn in Google Webmaster Tools dar, hast Du irgendwelche Crawling Errors, ggf. soft404er?

Gruß
__________________
Marco
http://oxidforge.org
http://about.me/marco.steinhaeuser

Will ignore unsolicited support requests via PM, email or IM.
Reply With Quote
Reply

Bookmarks

Tags
ausgegeben, ende, externe, urls

« Previous Thread | Next Thread »
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Nicht Sichtbar
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Artikelseiten werden nicht mehr ausgegeben pata1438 Installation und Konfiguration 12 09-25-2013 12:25 PM
SEO URLs werden nicht automatisch angelegt mygardenhome Administration 1 04-03-2013 12:28 PM
urls ohne Slash ("/") am Ende jason_kx Entwickler 8 01-01-2013 04:16 PM
Google Produktsuche - Product URLs werden ncith aktualisiert aminkwitz OXID eFire 1 08-23-2012 12:35 PM
Eigenes Theme darf nicht mit 0 am Ende benannt werden shoop Templates und Design 3 12-21-2009 04:18 PM

All times are GMT +1. The time now is 09:01 AM.