OXID Community Forum

> International Forums > Installation and configuration > Picture upload is not working (php upload error 3)
Login
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Thread: Picture upload is not working (php upload error 3)


Reply
 
Thread Tools Search this Thread Display Modes
#Top   #1  
Old 05-03-2016, 11:11 PM
s-l-l s-l-l is offline
Junior Member
Join Date: May 2016
Posts: 3
s-l-l is on a distinguished road
Default Picture upload is not working (php upload error 3)

Hi!

I'm trying to solve this since three hours and I'm giving up:

Picture upload fails with: 'The uploaded file was only partially uploaded', but demo pictures can be deleted via admin interface.

client: ff 46.0
shop ver: CE 4.9.8
os: fbsd
server: apache 2.4.17 running as www
php56: uploads on, 20M allowed, uploads to: /tmp/
permissions: www:www chmod 777

PHP & oxid does not log any error...

Any suggestions?

SLL
Reply With Quote
#Top   #2  
Old 05-04-2016, 06:41 AM
vanilla thunder's Avatar
vanilla thunder vanilla thunder is offline
Marco's Sidekick
Join Date: Nov 2010
Posts: 6,435
vanilla thunder is on a distinguished road
Default AW: Picture upload is not working (php upload error 3)

Did you try different pictures and different browsers?
Reply With Quote
#Top   #3  
Old 05-04-2016, 07:19 AM
s-l-l s-l-l is offline
Junior Member
Join Date: May 2016
Posts: 3
s-l-l is on a distinguished road
Default Re: AW: Picture upload is not working (php upload error 3)

Tried it with FF on my Win machine and on my smartphone with different pictures; both fail, but uploading to the oxid demos shop works.

Just tried it with chrome and IE and both fail even more - after clicking 'save' you end up on the admin login screen. :/
Reply With Quote
#Top   #4  
Old 05-04-2016, 09:48 AM
s-l-l s-l-l is offline
Junior Member
Join Date: May 2016
Posts: 3
s-l-l is on a distinguished road
Default Re: Picture upload is not working (php upload error 3)

By chance I discovered that files below 10Kb size could be uploaded and from there I managed to find the cure. Unfortunately without really knowing what is going wrong:

Check if you have port option OPTIONS_FILE_SET+=AP2FILTER (Apache 2 Filter) on for mod_php56, but PHP configured the usual way as a handler ( AddType application/x-httpd-php .php ).
Disable AP2FILTER, recompile, deinstall and reinstall -> WORKS.

Maybe only FreeBSD specific though
Reply With Quote
Reply

Bookmarks

Tags
error, php, picture, upload, working

« Previous Thread | Next Thread »
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Nicht Sichtbar
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
wysiwigpro Editor Error bei Bild upload block8 Administration 0 12-26-2011 10:03 AM
Automatische Logout bei Picture-Upload über Backend tommytomsen Administration 11 11-09-2011 02:24 PM
Upload über FTP [email protected] Installation und Konfiguration 10 06-05-2010 04:25 PM
Bild-Upload smonkey Administration 8 01-30-2010 10:28 PM
Upload Modul Koushirou Module 0 07-30-2009 09:18 AM

All times are GMT +1. The time now is 06:23 AM.