OXID Community Forum

> German forum > Installation und Konfiguration > ArtikelBildAnzeige, Netzwerkzugang, Emaillogo Probleme
Login
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Thread: ArtikelBildAnzeige, Netzwerkzugang, Emaillogo Probleme


Reply
 
Thread Tools Search this Thread Display Modes
#Top   #1  
Old 06-23-2016, 01:13 PM
Matthias2016 Matthias2016 is offline
Junior Member
Join Date: Jun 2016
Posts: 4
Matthias2016 is on a distinguished road
Default ArtikelBildAnzeige, Netzwerkzugang, Emaillogo Probleme

Hallo Leute,

ich komme mit diesem Shop leider nicht weiter. Daher hoffe ich hier einen kleinen Tipp zu bekommen.

- Artikelbilder werden online nicht richtig angezeigt gerade bei dem 2. Bild wenn man es anklickt lädt er ohne Ende und zurück zum 1. Bild geht auch nicht mehr.

- Das Emaillogo wird Local übermittelt aber Online nicht.

- Zugang zum Shop über (config.php) Domain und Admin über IP 192 xxxxx nicht möglich.
Er sollte über Internet durch die Domain erreichbar sein und auch local zum Adminbereich erreichbar sein. Aber es geht nur entweder oder

Es wurde schon alles mögliche versucht. aber ohne Erfolg.
Was eben seltsam ist das local alles ohne Probleme funktioniert und sobald der Server online geht kommen die Probleme. Der Server steht hier im Haus. Linux, Apache2 usw alle erforderliche Module sind da. Ein anderes Shopsystem läuft zur Zeit ohne Probleme.

Wäre dankbar für kleine Anregungen.
Reply With Quote
#Top   #2  
Old 06-23-2016, 01:33 PM
vanilla thunder's Avatar
vanilla thunder vanilla thunder is offline
Marco's Sidekick
Join Date: Nov 2010
Posts: 6,435
vanilla thunder is on a distinguished road
Default Re: ArtikelBildAnzeige, Netzwerkzugang, Emaillogo Probleme

Ihr müsst schon die public IP eintragen, wie soll denn sonst der Shopbesucher aus dem Internet darauf zugreifen?
Reply With Quote
#Top   #3  
Old 06-23-2016, 01:42 PM
Matthias2016 Matthias2016 is offline
Junior Member
Join Date: Jun 2016
Posts: 4
Matthias2016 is on a distinguished road
Default AW: ArtikelBildAnzeige, Netzwerkzugang, Emaillogo Probleme

Hallo

Das ist ja schon klar.
Nur ist es eben so, das der existierende Shop nur per IP des Servers intern auf die Domain verweist und somit ist es auch möglich per IP des Servers (servername) intern direkt auf den Server zuzugreifen um in den Admin bereich zu kommen. was hier bei Oxid nicht geht.
Reply With Quote
#Top   #4  
Old 06-23-2016, 02:33 PM
leofonic's Avatar
leofonic leofonic is offline
Moderator
Join Date: Oct 2009
Posts: 3,796
leofonic is on a distinguished road
Default AW: ArtikelBildAnzeige, Netzwerkzugang, Emaillogo Probleme

in der config.inc.php
PHP Code:
 $this->sShopURL 'http://' $_SERVER['SERVER_NAME']; 
oder HTTP_HOST
dann sollte das gehen.
__________________
Frank

www.zunderweb.de - Zunderweb IT Beratung - Templates und Module für Oxid eShop
Theme "EXP TWO" für 4.9.x - 2-spaltiges OXID 4.9 Theme mit 8 Farbschemata
Ajax Multifilter XL - Turbo für den Attributfilter
Reply With Quote
#Top   #5  
Old 06-23-2016, 02:37 PM
Matthias2016 Matthias2016 is offline
Junior Member
Join Date: Jun 2016
Posts: 4
Matthias2016 is on a distinguished road
Default AW: ArtikelBildAnzeige, Netzwerkzugang, Emaillogo Probleme

Hallo

OK so hatten wir das noch nicht, aber so ähnlich, da ging es nicht.
Gebe bescheid ob es erfolg hatte
Reply With Quote
#Top   #6  
Old 06-23-2016, 02:41 PM
vanilla thunder's Avatar
vanilla thunder vanilla thunder is offline
Marco's Sidekick
Join Date: Nov 2010
Posts: 6,435
vanilla thunder is on a distinguished road
Default Re: ArtikelBildAnzeige, Netzwerkzugang, Emaillogo Probleme

Es ist wirklich nicht böse gemeint und es tut mir Leid, dass es so böse klingt,
aber so wie du die Begriffe verwendest, entsteht der Eindruck als wäre da gar nichts klar.

Ein Server hat einen Namen, auch "Hostname" genannt, und mehrere IP Adressen.
Die "private" IP Adresse ist die Adresse der Servers im lokalen Netzwerk, eine "public" oder auch "öffentliche" IP ist dagegen die Adresse fürs Internet.
IP Adressen verweisen auf keine Domains.
Eine Domain wird auf einem DNS Server hinterlegt und verweist auf eine IP Adresse.
Wenn ihr Active Directory im Firmennetzwerk benutzt, dann steht irgendwo ein DNS Server, der die DNS halbwegs automatisch/dynamisch verwaltet und allen PCs im Netzwerk eine Domain a la *Hostname.Domäne.com" vergibt. Windows und Samba Server können sich im Netzwerk auch mit dem Hostnamen ohne der Domäne erkennbar machen: http://server-x/

Wenn du also die private IP Adresse des Servers im Browser eingibst, landet deine HTTP-Anfrage direkt beim Server. Wohin es dort geht, hängt von der Konfiguration ab.
Gibst du die öffentliche ein, landest du wahrscheinlich zuerst beim Router oder in der Firewall und wirst danach zum Server durchgeschickt.
Gibst du den Hostnamen ein, landest du beim DNS Server und er löst den Hostname auf die IP Adresse auf und schickt dich weiter.
Gibst du eine Domain ein, wird sie vom externen DNS Server auf die public IP aufgelöst und ins Firmennetzwerk geschickt.

mehr Infos zu eurer Infrastruktur erhälst du vom Sysadmin der Firma.


Und nun zum Shop.
Wenn du die private IP Adresse in der config eingibst und diese IP über Browser aufmachst, findet der Browser den Server, weil sie im selben Netzwerk sind.
Gibt jemand im China die public IP des Server ein, landet er dann zwar auf dem Server allerdings sagt ihm der Shop, dass der Browser die Bilder und alle anderen Dateien über die im Config hinterlegt IP abfragen soll. Und dann fragt der Browser die IP ab, landet in seinem eigenen lokalen Netzwerk, weil du eine private IP angegeben hast, und findet natürlich nichts.
Wenn der Shop also auch übers Internet erreichbar sein soll, muss definitiv die public IP hinterlegt werden. Oder wenn es eine Domain für diese IP gibt, dann geht auch diese Domain.
Reply With Quote
#Top   #7  
Old 06-23-2016, 03:04 PM
Matthias2016 Matthias2016 is offline
Junior Member
Join Date: Jun 2016
Posts: 4
Matthias2016 is on a distinguished road
Default AW: ArtikelBildAnzeige, Netzwerkzugang, Emaillogo Probleme

Hallo

@ Vanilla Thunder

:-)
Was meinst du warum wir diese Probleme haben, weil der Sysadmin auch nicht mehr weiterkommt und neben mir sitzt.
Gut stimmt schon das die Domain auf eine IP verweist. Sorry das ich es falsch herum geschrieben habe.

Aber es ist eben nunmal so das der laufende Shop einwandfrei im Netzwerk funktioniert. Domain-DNS-Shopserver(local IP)
Und das sollte auch so beibehalten werden.
Hintergrund dieses Problems ist das die Internetleitung nur "in eine Richtung" geht. Sprich man kann nicht "zurücktelefonieren". OK über China geht das.
Daran lässt sich erst nächstes Jahr etwas ändern.

Nunja aber für das Bilderproblem kennt anscheinend keiner etwas.
(Es wurde die Domain in der config eingegeben).
Mittlerweile haben wir ca 150 verschiendene Dinge versucht.
Reply With Quote
#Top   #8  
Old 06-23-2016, 08:05 PM
ChristophH ChristophH is offline
Senior Member
Join Date: Apr 2009
Posts: 2,619
ChristophH is on a distinguished road
Default AW: ArtikelBildAnzeige, Netzwerkzugang, Emaillogo Probleme

Quote:
Originally Posted by Matthias2016 View Post
Hintergrund dieses Problems ist das die Internetleitung nur "in eine Richtung" geht. Sprich man kann nicht "zurücktelefonieren". OK über China geht das. Daran lässt sich erst nächstes Jahr etwas ändern.
Kannst du das verständlich erklären?
Das ergibt leider keinen Sinn.

Quote:
Originally Posted by Matthias2016 View Post
Nunja aber für das Bilderproblem kennt anscheinend keiner etwas.
(Es wurde die Domain in der config eingegeben).
Mittlerweile haben wir ca 150 verschiendene Dinge versucht.
Hast du in Firebug mal die Web-Konsole befragt, was in dem Moment genau passiert?
Reply With Quote
Reply

Bookmarks

Tags
artikelbildanzeige, emaillogo, netzwerkzugang, probleme

« Previous Thread | Next Thread »
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Nicht Sichtbar
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Probleme mit PHP Happy-Chris Entwickler 3 07-03-2014 08:23 AM
Paypal Oxid eFire Probleme - Probleme mit der Anleitung "Template anpassen" MichiruKaio Module 9 08-02-2013 05:39 PM
Probleme mit IE8 @byte Templates und Design 7 11-12-2011 11:08 AM
Probleme mit IE 8 itnic Bug-Verdacht 6 12-16-2010 03:14 PM

All times are GMT +1. The time now is 06:20 AM.