4.9.2. Logo oder Bild im Footer einbauen

Hallo ich möchte ein Bild oder Logo im Footer oder darunter einbauen.
Leider funktioniert es nicht so gut.

das Bild wird z.B. bei der Kontaktseite angezeigt,
aber auf der Startseite nicht. wisst ihr woran das liegen könnte?

<div class="tp-footer">
  <img src="../out/tp-nordic/img/footer_bg_tp_1.png" alt="Nordic" />
        </div>

[QUOTE=Stickmaus;154811]Hallo ich möchte ein Bild oder Logo im Footer oder darunter einbauen.
Leider funktioniert es nicht so gut.

das Bild wird z.B. bei der Kontaktseite angezeigt,
aber auf der Startseite nicht. wisst ihr woran das liegen könnte?

<div class="tp-footer">
  <img src="../out/tp-nordic/img/footer_bg_tp_1.png" alt="Nordic" />
        </div>

[/QUOTE]

von der Startseite wäre der Pfad korrekt src="out/tp-nordic/…"
Schau mal im Forum, wie man Bilder korrekt einbaut, oder verwende absolute Pfade, also src=“http://www.domain.tld/out/tp-nordic/…”

Danke Meister Yoda,
ich habe das jetzt geändert

<div class="tp-footer">
  <img src="out/tp-nordic/img/footer_bg_tp_1.png" alt="Nordic" />
        </div>

aber jetzt ist das Bild nur auf der Startseite und nicht auf den anderen Seiten.

Mit dem absoluten Pfad:

        <div class="tp-footer">
  <img src="http://localhost/oxid_nordic_492/out/tp-nordic/img/footer_bg_tp_1.png" />
        </div>

geht es auf allen Seiten,
aber da muss ich wohl beim Live setzen des Shops die Pfadangaben anpassen?

wenn Du src=“out/…” nimmst stimmt es nur für die Startseite :slight_smile:

Wenn Du, wie ich gesagt habe, im Forum gesucht hättest wärst Du auf dieses gestoßen

<img src=“[{$oViewConf->getImageUrl()}]Bildname.png” alt=“” />

Edit: Der Vollständigkeit halber http://forum.oxid-esales.com/showthread.php?t=14540&page=2#post90316

Danke für die Hilfe,
irgendwie schaffe ich das nicht so richtig mit der Suche, entweder verwende ich immer die falschen Suchbegriffe oder???
Nochmals Danke für eure Geduld mit mir.

So das Problem mit der Grafik ist gelöst.

http://lmgtfy.com/?q=oxid+bild+einfügen die Lösung steht gleich im ersten Link. So kompliziert ist das nun auch nicht, oder? :slight_smile:

Ok, für mich ist das zu schwierig oder zu einfach???
ich gebe immer die falschen komplizierten Begriffe ein,
hier z.B. oxid Footer bild usw.

Jetzt möchte ich auf der Startseite einen Willkommenstext mit Bildern usw einfügen.
Habe bei Google:
oxid startseite gestalten
eingegeben
und da waren nur alte Berichte mit "basic"Template.

CMS-Seiten und dann auf Seite 2 steht start.tpl Begrüßungstext. Dort kannst Du Deinen text eingeben und gestalten, auch mit Bildern.

Leider komme ich eben einfach nicht weiter,
wie bekomme ich das ganze dann auf die Startseite und den Promobanner?

und dann nimm das better start modul und bau da deine bilder im cms ein. du bist schon etwas über ein jahr registriert, da solltest du solche dinge aber wissen/kennen.

http://ecomstyle.de/GitHub-Projekte/

edit: zu spät. wasn nu mit banner?

[QUOTE=Stickmaus;154822]Leider komme ich eben einfach nicht weiter,
wie bekomme ich das ganze dann auf die Startseite und den Promobanner?[/QUOTE]

wo ist das Problem einen Text in ein Feld zu schreiben?

Promobanner sind Aktionen. Wenn Du keinen Shop mit Demo-Content hast schau in den Demoshop http://demoshop.oxid-esales.com/professional-edition/ Schau Dich einfach im backend etwas um, dann klären sich manche Dinge ganz von alleine.

Hallo Domino,
danke für den Tipp,
ich meinte [I][B]unter [/B][/I]dem Banner.
Ja, ich habe mich schon lange mit dem Shop beschäftigt, fand das ganze aber zu kompliziert (teilweise immer noch). Dann bin ich zu XTC4 übergegangen und habe meinen Shop erstmal damit gemacht, da ich mich davor schon mit xtc3 beschäftigt hatte. Aber der XTC4 ist teilweise sehr aufwändig zu bedienen, z.B. die Varianten, keine pdf für Rechnungen dabei, und dann gab es Probleme mit dem e-Mailversand, Bestellungen wurden einfach nicht an mich weitergeschickt.
Nun bin beim Oxid angelangt und versuche damit zurechtzukommen.

ich werde morgen mal das Modul testen

Hallo Meister Yoda,
den Text einfügen ist kein Problem, aber das Ganze auf die Titelseite zu bekommen.

Moin,
so ich habe das Modul getestet, geht ganz einfach. Super.
Dann hatte ich noch das TinyMCE installiert und den ResponsiveFilemanager, so konnte ich einfach ein Bild dazu hochladen.
Nur kommt beim Öffnen des Filemanager eine Fehlermeldung:

oxid Notice: Undefined variable: _SESSION in C:\xampp\htdocs\oxid_nordic_492\modules\bla\bla-rfm\ResponsiveFilemanager\filemanager\config\config.php on line 9

wisst ihr wie ich das abstellen kann,
dennoch ist das Bild hochgeladen.