--> 6.2.1 aktualisiert, Module nicht mehr da

Evtl. ist das Verzeichnis var nicht beschreibbar.

Das Verzeichnis /var hat bei mir 775.
Nun habe ich auf php 7.3.x umgestellt.

interessant wäre wie Deine 1.yaml Datei aussieht, sind dort die vermissten Module enthalten? Kamen Fehlermeldungen beim Update mit Composer?

in der 1.yaml sind die vermissten Module nicht zu finden. Fehlermeldungen nur rote Hinterlegungen beim Modul update.

Also mir fehlen zum aktivieren folgende Module. dwa, ecs, sit_import_manager, sit_module_framework.
Wie bekomme diese Aktiviert, sind leider nicht in der Liste (Backend) der Module aufgeführt, das wäre ja zu einfach.

Außerdem habe ich da noch den Konflikt

Dies wird die Ursache sein, wahrscheinlich sind die Module nicht kompatibel mit der neusten Shopversion 6.2.1 - daher bitte an Modulhersteller wenden.

ok, danke. Ich schreibe die drei Modulhersteller an, bin mal gespannt wie es weiter geht.

fast vergessen was ist mit der DB Kollationen?

Die unterschiedlichen Kollationen in den ID-Felder dürften keine Rolle spielen, weil da nur Hexadezimalzahlen als String drin stehen, und die enthalten keine Sonderzeichen, sondern nur Ziffern 0…9 und a…f und deren Codierung ist in latin und utf gleich.

hast du mal probiert manuell ein modul zu installieren?

@m431342, ok Danke. Dachte halt das dies evtl. mit dem seltsamen Verhalten in Win 10 und Firefox zusammenhängen könnte, nur da habe ich das Problem dass, der Login (Backend) sich immer wiederholt, und ich auf den Explorer ausweichen muss um ins Backend zu kommen. sobald ich jedoch Malewarebyte darüber laufen lasse, mit anschließenden Neustart, geht es zumindest genau einmal.

@tabsl, ja habe ich auch schon versucht z.B. bei dwa hier habe ich auch für den Moment nicht’s anderes

$ vendor/bin/oe-console oe:module:install source/modules/dwa/dwa_invoicemail
An error occurred while installing module configuration.

dann musst du wohl mal debuggen … InstallModuleConfigurationCommand::execute()

Was m.E. nicht unbedingt heißt das es vom Webserver beschreibbar ist.

@corel ich würde mal ganz doof fragen hat das Modul eine composer.json?

@tabsl, setzte ich vor ‘InstallModuleConfigurationCommand::execute()’ ein composer? Sorry so fit bin ich noch nicht.

@indianer3c, du hast recht, in allen drei Modulen von dwa, gibt es keine composer.joson, bzw *.joson

jetzt habe ich es geschafft, statt Backend Login große weise leere Seite. :partying_face:

Nachtrag: nach composer update läuft das Backend wieder

Composer.json ist nicht notwendig bei Metadata 1.x. Die Metadata-Version muss jetzt allerdings immer in metadata.php stehen.

ok alle drei habe jeweils eine metadata.php. Wie bekomme ich nun jene soweit zu laufen das sie aktiviert werden können?

Ich glaube dies führt hier im Thread zu nichts, dies Endlosschleife. Am besten schließt Dich direkt mit dwa kurz und beauftragst diese sich dies anzugucken. Sollte sich herausstellen, dass die Module für die Version 6.2.1 angepasst werden müssen kann der Modulhersteller dies sicherlich am besten bewerkstelligen.

2 Likes

ok hast bestimmt recht, dann heißt es warten…