Amazon Pay & Login 4 OXID by BESTIT Integration: kein Login-Button

Guten Morgen,

ich teste gerade o.g. Modul (Version 3.3.0 laut Changelog).
Kurioserweise erscheint der Button aber erst, wenn man sich als Oxid-Nutzer eingeloggt hat.
Sinnvoll wäre es natürlich, wenn bereits zuvor der Login über einen Amazon-Button möglich wäre.

Kennt jemand das Problem?

Die von der BESTIT-Website und der entsprechenden Datei im Modul selbst verlinkte Dokumentation ist leider nicht erreichbar (403 forbidden), daher wurstel ich mich etwas durch. (Ich habe zwar bei BESTIT angefragt, aber bisher keine Antwort. Trage das hier nach, wenn ich weiß, wie man aktuell an die Doku kommt.)

was im Modul verlinkt ist, weiß ich nicht, aber auf der bestit seite wird das hier als Doku verlinkt:
https://bestit.atlassian.net/servicedesk/customer/portal/7/article/619118852

Hast du ggf irgendwo eine Benutzergruppe oder Land zugewiesen?
Ohne eingeloggt zu sein, weiß OXID weder aus welchem Land du kommst, noch in welchen Benutzergruppen du wärst.

1 Like

Oh, super - der Link funktioniert. (Wurde - von Amazon aus glaube ich - auf diese Seite von Bestit verwiesen https://bestitcon.zendesk.com/hc/de/articles/115001478125-Dokumentation-AmazonPay4OXID
Entspricht auch der Angabe im Modul, führt allerdings ins Leere)
Vielen Dank!

Und was die Nutzergruppen angeht: Ich hab der Zahlmethode jetzt alle Nutzergruppen zugewiesen, und siehe da: Ich sehe an diversen Stellen jetzt Buttons, wo vorher keine waren! :slight_smile: Danke auch dafür!

Nach Logik frage ich jetzt nicht, denn die anderen Zahlmethoden funktionieren ja auch klaglos, wenn ihnen keine explizite Nutzergruppen zugewiesen wurden

Warte, du musst alle Gruppen entfernen. Die anderen haben wahrscheinlich keine Gruppen zugewiesen

Jetzt schon - ich habe jetzt allen Zahlmethoden alle Gruppen zugewiesen. Die gingen vorher und jetzt immer noch (also zumindest erscheinen die entsprechenden Optionen, kompletten Checkout habe ich noch nicht getestet).
Wie gesagt, die Logik erschliesst mich mir nicht so ganz, aber ich bin glücklich, wenn ein Setup funktioniert :slight_smile:

wie gesagt, du musst alle Zuordnungen entfernen, denn eine Gruppen-Zuordnung ist eine Einschränkung auf eine Gruppe.
Eine Einschränkung auf alle Gruppen ist zwar im Endeffekt keine Einschränkung, aber der Shop prüft trotzdem ob der Besucher in einer der Gruppen drin ist, weil die Zuweisung ja da ist. Daher ist es besser gar keine Zuordnungen. Stell es dir wie einen Türschloss vor, der mit jedem Schlüssel geöffnet werden kann. Es hält niemanden auf, aber verlangsamt den Durchgang. So ist es auch im Shop, daher ist es besser, den Schloss gleich wegzulassen.

Hihi… :laughing:
Danke Ich finde deine Erklärung verständlich und einleuchtend.
Lustigerweise habe ich jetzt testweise die Gruppenzuordnungen bei allen Zahlmethoden inklusive Amazon Pay entfernt, tmp gelöscht - und alles funktioniert.
Das sind also exakt wieder die Einstellungen, die ich hatte, als ich um Hilfe gebeten hatte. Nur dass jetzt der Amazon-Button angezeigt wird. Sehr verwirrend - aber gut, es läuft :sweat_smile: