Artikelbilder können nach hochladen nicht von Oxid gefunden werden

Liebe Community.

Hatte vor wenigen Tagen ein update vorgenommen auf die 4.5.3 von der 4.5.1
Nun bekomme ich keine Bilder mehr hochgeladen wenn ich einen Artikel hinzufüge.

Klicke ich dann auf Vorschau, nachdem ich Sie versucht habe, hochzuladen, komme ich auf folgenden Link:
http://wolfer-systems.ch/out/pictures/generated/product/1/380_340_95/mtj87q8j.jpg
Dann habe ich das Bild manuell in diesen Ordner geladen, musste die aber erst erstellen.
Hat auch nichts gebracht.

Wenn ich das Bild dann lösche, steht folgendes über der Bildupload Sektion:

Invalid argument supplied for foreach() in /home/www/web336/html/core/oxutilspic.php on line 144

Irgendjemand ne Idee???

Vielen Dank für eure Hilfe…

Hi,
welche Ordnerstruktur gibt es bei dir unter out/pictures/generated/?
Welche Ordner hast du dort dann manuell erstellt um das Bild reinzukopieren?
Nur diesen 380_340_95 oder auch die Ordner darüber?

Das hört sich fast so an als ob die Berechtiungen nicht stimmen und die Auflösungs Ordner im generated Ordner nicht angelegt werden können. Allerdings hätte es in der 4.5.1 dann auch nicht funktnionieren dürfen.

Beim Löschen will er das Bild dann vom Dateisystem löschen, aber da ist es ja nicht vorhanden, deshalb der Fehler.

Grüße
Fabian

War das eine neue Installation von 4.5.1 oder war das auch schon ein Update?

Neuinstallation.
Bis zu dem update lief auch alles gut. Beim updaten hatte ich vorher noch ein backup gemacht, daher kann ich alles auch wieder zurücksetzen, aber mir wäre eine Fehleranalyse bzw. Lösung viel lieber als ein workaround…

@Alpha

Berechtigungen sind auf 775 gewesen, aber die Ordner wurden garnicht erstellt…
Werd jetzt dann nochmal Backup Laden und von vorn beginnen. Mal schauen.
Dumm ist auch, man kann ja beim Update wählen, ob ein neuer Ordner für Bilder erstellt wird, wenn man das dann aber macht, dann sind alle bisherigen Bilder verschwunden.

Hmmm… habe den Ordnern jetzt nochmals Rechte 777 gegeben, aber irgendwie bleiben Sie immer auf 755. Wo kann man diese Beschränkung beheben? Habe es mehrmals unter generated/product/380_340_95/ getestet… immer das selbe Phänomen…

EDIT: Zumindest kann ich nun die Bilder manuell auf den FTP laden…

Hast du ssh Zugriff? Wenn ja, dann setz die Rechte darüber:
chmod -R 777 /home/www/web336/html/out/pictures/
Ohne Schreibrechte können auch keine Ordner erstellt werden, folglich werden auch keine Bilder erstellt.

Habe endlich eine Lösung gefunden, für alle, die das gleiche Problem haben… 24h Arbeit und Suche, aber es hat funktioniert!

Ich habe folgende vier Zeilen in die .htaccess Datei im Verzeichnis /html eingefügt:
RewriteCond %{REQUEST_URI} (/out/pictures/)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule (.jpg|.gif|.png)$ core/utils/getimg.php

Zuvor Sah die Datei wie folgt aus:
<IfModule mod_rewrite.c>

Options +FollowSymLinks
RewriteEngine On
RewriteBase /

RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
RewriteRule .* - [F]

RewriteCond %{REQUEST_URI} oxseo.php$
RewriteCond %{QUERY_STRING} mod_rewrite_module_is=off
RewriteRule oxseo.php$ oxseo.php?mod_rewrite_module_is=on [L]

RewriteCond %{REQUEST_URI} !(/admin/|/core/|/export/|/modules/|/out/|/setup/|/tmp/|/views/)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule !(.html|/|.jpg|.css|.pdf|.doc|.gif|.png|.js|.htc)$ %{REQUEST_URI}/ [R=301,L]

RewriteCond %{REQUEST_URI} !(/admin/|/core/|/export/|/modules/|/out/|/setup/|/tmp/|/views/)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule (.html|/)$ oxseo.php

</IfModule>

disabling log file access from outside

<FilesMatch “(EXCEPTION_LOG.txt|.log$|.tpl$|pkg.rev)”>
order allow,deny
deny from all
</FilesMatch>

Options -Indexes
DirectoryIndex index.php index.html

Deswegen doch meine Frage, ob die 4.5.1 eine Neuinstallation war, oder ein Update.

http://wiki.oxidforge.org/index.php?title=Tutorials/image_handling_changes#After_the_update_you_see_no_or_broken_images_in_your_shop