Backend Bestellungen Verwalten - Startseite statt Bestellübersicht

Im Admin Login unter Bestellungen Verwalten - Bestellungen erscheint seit neuestem statt der Bestellungen die Startseite geframed. Also das Backend Menü bleibt stehen, rechts davon baut sich die Startseite des Shops auf.

Die anderen Menüpunkte funktionieren soweit.

Module deaktivieren, Theme wechseln und tmp leeren brachte keinen Erfolg.

Was ist da schief gegangen?

Oxid CE 4.10.4

Schau mal ins Log (log/EXCEPTION_LOG.txt). Dort sollte der Fehler stehen.

Ich werde aus dem Log leider nicht schlau. Hat das damit zu tun, dass beim Upgrade das neue Paypal Modul installiert wurde?


oxSystemComponentException-oxException (time: 2017-08-07 19:30:56): [0]: Function ‘getPayPalPaymentStatus’ does not exist or is not accessible! (InvoicepdfOxOrder)

Stack Trace: #0 /www/htdocs/…/oxid/tmp/smarty/369acf8a4544aa7bec4a8d04f0baad6e^%%E4^E47^E47AF47E%%order_list.tpl.php(237): oxSuperCfg->__call(‘getPayPalPaymen…’, Array)
#1 /www/htdocs/…/oxid/tmp/smarty/369acf8a4544aa7bec4a8d04f0baad6e^%%E4^E47^E47AF47E%%order_list.tpl.php(237): InvoicepdfOxOrder->getPayPalPaymentStatus()
#2 /www/htdocs/…/oxid/core/smarty/Smarty.class.php(1264): include(‘/www/htdocs/…’)
#3 /www/htdocs/…/oxid/core/oxshopcontrol.php(516): Smarty->fetch(‘order_list.tpl’, ‘mxdisplayorders’)
#4 /www/htdocs/…/oxid/core/oxshopcontrol.php(361): oxShopControl->_render(Object(Order_List))
#5 /www/htdocs/…/oxid/core/oxshopcontrol.php(126): oxShopControl->_process(‘order_list’, NULL, NULL, NULL)
#6 /www/htdocs/…/oxid/core/oxid.php(40): oxShopControl->start()
#7 /www/htdocs/…/oxid/index.php(26): OXID::run()
#8 /www/htdocs/…/oxid/admin/index.php(27): require_once(‘/www/htdocs/…’)
#9 {main}

Faulty component –>

Als alle Erweiterungen deaktiviert wurden, gab es folgenden Eintrag:


oxException (time: 2017-08-07 19:18:11): [0]: Template block file (/www/htdocs/…/oxid//modules/oe/oepaypal//views/blocks/oepaypalorder_list_colgroup_actions.tpl) not found for ‘oepaypal’ module.
Stack Trace: #0 /www/htdocs/…/oxid/core/oxutilsobject.php(188): oxUtilsObject->_getObject(‘oxexception’, 1, Array)
#1 [internal function]: oxUtilsObject->oxNew(‘oxException’, ‘Template block …’)
#2 /www/htdocs/…/oxid/core/oxfunctions.php(368): call_user_func_array(Array, Array)
#3 /www/htdocs/…/oxid/core/oxutilsview.php(456): oxNew(‘oxException’, ‘Template block …’)
#4 /www/htdocs/…/oxid/core/oxutilsview.php(511): oxUtilsView->_getTemplateBlock(‘oepaypal’, ‘/views/blocks/o…’)
#5 /www/htdocs/…/oxid/core/smarty/plugins/prefilter.oxblock.php(42): oxUtilsView->getTemplateBlocks(‘order_list.tpl’)
#6 [internal function]: smarty_prefilter_oxblock(‘[{include file=…’, Object(Smarty_Compiler))
#7 /www/htdocs/…/oxid/core/smarty/Smarty_Compiler.class.php(249): call_user_func_array(‘smarty_prefilte…’, Array)
#8 /www/htdocs/…/oxid/core/smarty/Smarty.class.php(1490): Smarty_Compiler->_compile_file(‘order_list.tpl’, ‘[{include file=…’, NULL)
#9 /www/htdocs/…/oxid/core/smarty/Smarty.class.php(1423): Smarty->_compile_source(‘order_list.tpl’, ‘[{include file=…’, NULL, ‘/www/htdocs/…’)
#10 /www/htdocs/…/oxid/core/smarty/Smarty.class.php(1262): Smarty->_compile_resource(‘order_list.tpl’, ‘/www/htdocs/…’)
#11 /www/htdocs/…/oxid/core/oxshopcontrol.php(516): Smarty->fetch(‘order_list.tpl’, ‘mxdisplayorders’)
#12 /www/htdocs/…/oxid/core/oxshopcontrol.php(361): oxShopControl->_render(Object(Order_List))
#13 /www/htdocs/…/oxid/core/oxshopcontrol.php(126): oxShopControl->_process(‘order_list’, NULL, NULL, NULL)
#14 /www/htdocs/…/oxid/core/oxid.php(40): oxShopControl->start()
#15 /www/htdocs/…/oxid/index.php(26): OXID::run()
#16 /www/htdocs/…/oxid/admin/index.php(27): require_once(‘/www/htdocs/…’)
#17 {main}


ja, das hängt wahrscheinlich damit zusammen.
ist das schon Version 3.3 oder noch 3.2?

Das ist Version 3.2.4

Bedeutet die Meldung, der Fehler liegt beim Paypal Modul oder bei Invoicepdf?

Das Paypal Modul ist das aktuelle, das ich im Exchange für 4.10.4 gefunden habe:
http://exchange.oxid-esales.com/OXID-Products/OXID-eFire-Extensions/OXID-eFire-Extension-PayPal-3-2-3-for-4-9-x-Stable-CE-4-4-x-4-9-x.html?listtype=search&searchparam=paypal#versionTab

Beim Update auch an den Ordner “changed_full” gedacht?

Für das Update auf 4.7.0 musste ja das Full Package verwendet werden, also sollte da alles Up-to-date sein. Gleich darauf folgte dann das Update auf die aktuelle Version.

In der Erweiterungsliste habe ich jetzt allerdings einige installierte Module, die rot und durchgestrichen erscheinen. Das sollten ja eigentlich nur die veralteten Module sein, die vorher installiert waren, oder?

Ich sehe aber gerade, dass da auch Module dabei sind, deren Pfade aktuell sind.:confused:

[QUOTE=dreifachonline;188754]Für das Update auf 4.7.0 musste ja das Full Package verwendet werden, also sollte da alles Up-to-date sein:[/QUOTE]

Das ist die Frage.

Wegen der Einträge: Lösche alle Moduleintragungen und starte die Module neu:

delete from oxconfig where oxvarname in (
'aDisabledModules',
'aLegacyModules',
'aModuleFiles',
'aModulePaths',
'aModules',
'aModuleTemplates'
);

Das hat das Problem gelöst, und die hässlichen Einträge sind jetzt auch weg.

Herzlichen Dank für die Hilfe.