Community Edition 4.6.6_54646 und PHP Version von 5.2 auf 5.5 updaten

Hallo,

ich habe die Oxid Version Community Edition 4.6.6_54646 unter PHP 5.2 laufen.
Nun wird diese PHP Version von meinem Hoster bald abgeschalten.

Ein erster Versuch die Version auf 5.4. umzustellen endete mit der Meldung, dass Zend nicht installiert ist. Ich habe daraufhin wieder auf 5.2 zurückgestellt.

Jetzt meine Frage: Wenn man Zend neu installiert läuft der Shop dann unter 5.4 oder 5.5?

Zur Info: folgende Module sind noch installiert:

  • ag_slideshow
  • Aggrosoft Flex Search Module
  • OXID-BugFix oxmodule/-list
  • Invoice PDF
  • PayPal
  • tc_fckeditor

Vielen Dank im voraus
joe

Zend Guard, früher als Zend Loader bekannt, ist ein Modul für PHP um mit Zend verschlüsselte OXID Module zu benutzen.
Der Haken ist, dass Zend Guard an bestimmte PHP Versionen gebunden ist, z.B. wenn du PHP 5.4 hast, brauchst du Zend Guard für PHP 5.4 und die Version des Moduls, die entsprechend für Zend Guard für PHP 5.4 verschlüsselt wurde.

Du musst also Zend Guard für PHP 5.4 besorgen, für PHP 5.5 gibts da noch keins. dazu die Module und dann kannst du auf PHP 5.4 umschalten

super - danke für die schnelle Antwort
Joe