DRINGEND HILFE BENÖTIGT bzlg. Domain-Einstellungen

Hi,
ich brauche dringend Hilfe, da morgen unser Shop im Elle-Magazin erwähnt wird und die Domain-Zuordnungen nicht funktionieren.

Erwähnt wird www.meine website.com

Den Shop habe ich bei hosteurope im Ordner www.meinewebsite.com/onlineshop
installiert.

nach etlichen htaccess einträgen, etc…funktioniert nun garnichts mehr.

Morgen soll alles online sein.

Danke Sandra

Der tag is ja noch lang :wink:

Möchtest Du ne Weiterleitung anlegen oder den root folder der Domain auf den unterordner legen ?

ok, jetzt habe ich ne erfolgreiche Weiterleitung drin.
Inhalt der .htaccess im Root-Verzeichnis:

RewriteEngine On
RewriteCond %{REQUEST_URI} !^/onlineshop/.$
RewriteRule ^(.
)$ /onlineshop/$1 [L]

Doch nach x anderen Änderungen, ist es nun so, dass die Seiten im Shop nicht mehr gefunden werden.
Ich kann nicht mehr navigieren.

Im Backend des Shops: Grundeinstellungen/Stamm/URL steht :—rausgenommen

ist das falsch?

ganz einfach

  • mach den neuen Eintrag in der .htaccess wieder raus
  • lege die Domain in den Einstellungen beim Webhoster direkt auf das Unterverzeichnis /onlineshop
  • nimm den Eintrag /onlineshop bei RewriteBase in der .htaccess raus (-> RewriteBase /)
  • passe die URL-Angaben in der config.inc.php an (Achtung, nur die URL-Angaben, nicht die Pfadangaben!)
  • /tmp leeren und VIEWS neu erstellen
  • SEO URLs neu berechnen

fertig

also, folgendes:
der Shop ist ja über nallik.de erreichbar,
das “onlineshop”-Zeug musst du aus der .htaccess wieder entfernen.

hier ist die Original .htaccess:


<IfModule mod_rewrite.c>
Options +FollowSymLinks
RewriteEngine On
RewriteBase /

RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
RewriteRule .* - [F]

RewriteCond %{REQUEST_URI} oxseo\.php$
RewriteCond %{QUERY_STRING} mod_rewrite_module_is=off
RewriteRule oxseo\.php$ oxseo.php?mod_rewrite_module_is=on [L]

RewriteCond %{REQUEST_URI} !(\/admin\/|\/core\/|\/export\/|\/modules\/|\/out\/|\/setup\/|\/tmp\/|\/views\/)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule !(\.html|\/|\.jpg|\.css|\.pdf|\.doc|\.gif|\.png|\.js|\.htc)$ %{REQUEST_URI}/ [R=301,L]

RewriteCond %{REQUEST_URI} !(\/admin\/|\/core\/|\/export\/|\/modules\/|\/out\/|\/setup\/|\/tmp\/|\/views\/)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule (\.html|\/)$ oxseo.php


RewriteCond %{REQUEST_URI} (\/out\/pictures\/)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule (\.jpe?g|\.gif|\.png)$ core/utils/getimg.php

</IfModule>

# disabling log file access from outside
<FilesMatch "(EXCEPTION_LOG\.txt|\.log$|\.tpl$|pkg\.rev)">
order allow,deny
deny from all
</FilesMatch>

Options -Indexes
DirectoryIndex index.php index.html

/tmp entleeren und die Seite neuladen

melde dich wenn das getan is

Hi Vanilla,
niemand kennt die meinshop.de Adresse. in den Zeitungen wird meinshop.com veröffentlicht.
die von mir genannte .htacesss liegt im Root-Verzeichnis, nicht im Installations-Verzeichnis.
Im Installations-Verzeichnis liegt nach wie vor die Original Oxid-htaccess.

Es läuft so: meinshop.com liegt bei nem Provider in USA. Dort wurde ein nameserver eintrag vorgenommen, der auf meinshop.de verweist.
Wenn nallik.de aufgerufen wird, soll auf den Shop im Unterordner /onlineshop/ verwiesen werden.
Das tut es momentan mit der aktuellen .htaccess im root-verzeichnis meinshop.de

Aber möchte ich durch den shop navigieren, findet er die seiten nicht.

Ah so - warum machst Du dann nicht einfach eine Weiterleitung von der .com auf .de/onlineshop anstatt auf .de und versetzt den Shop und sämtliche Pfadangaben inklusive .htaccess wieder zum Ausgangszustand zurück?

oder kannst du nicht den Domain Eintrag so umlegen, dass der Shop Verzeichnis als standard Verzeichnis der Domain durchgeht?
Und dann musst du beim Shop http://dein-shop.de als Shop URL eintragen, den Ordner auf dem Server aber gleich lassen.

vanilla, kannst du bitte den aktiven link und die webadresse aus deinem thread rausnehmen. danke.

Dank Tobi23 und skype läuft nun alles wieder.
Tausend Dank