Encoding Fehler in deutscher Setup Sprachdatei CE 4.9.6

Habe heute zum ersten mal den oxid Shop installiert und wurde direkt mit Encoding Fehler auf der Setup Seite begrüsst. Das macht natürlich keinen guten Erst-Eindruck.

Eine Änderung in de/lang.php die in utf-8 ausgeliefert wird behebt das Problem.

Folgende Änderung muss gemacht werden:
‘charset’ => ‘ISO-8859-15’ in
’charset’ => ‘UTF-8’ ändern.

Vll. sollte ich doch wieder zu M*enta wechseln?

Heute zum ersten mal im Forum geschrieben und direkt im falschen Forum.
Das macht natürlich keinen guten Erst-Eindruck.

Wenn deine Analyse sich nur auf den Erst-Eindruck beschränkt, dann viel Erfolg mit magneto.
Ich würde die Shop Systeme aber unter anderen Aspekten untersuchen und genauer vergleichen, als die Installation.

[QUOTE=m.reinerth;177050]de/lang.php die in utf-8 ausgeliefert wird[/QUOTE]
Hm glaub ich nicht.

So kritisch und negativ wollte ich gar nicht rüberkommen.

Das ich vll doch lieber bei Ma*enta bleiben soll war scherzhaft gemeint.
Ich werde weiterhin oxid ausprobieren.

Ja ich habe ins falsche Forum geschrieben, ist mir leider passiert.Tut mir leid.

Kann jemand bestätigen, das die Sprachdatei nicht als utf-8 vorliegt?
Ich habe nur lokal entpackt und vor dem setup keine Datei enditiert oder transferiert.
Warum hat bei mir die Datei utf-8 encoding?

Hi,
habe bei mir die Datei setup/de/lang.php aus dem Installationspaket geöffnet und die hat ISO als Zeichensatz. Also so wie es auch in der Sprachdatei angegeben ist.

Lade mal das Installationspaket nochmal runter und teste es dann nochmal, ob die Datei ISO-codiert ist. Vielleicht macht dein Editor hier auch Schabernack.

Grüße
Fabian

Hallo,

[QUOTE=m.reinerth;177050]
Folgende Änderung muss gemacht werden:
‘charset’ => ‘ISO-8859-15’ in
’charset’ => ‘UTF-8’ ändern.
[/QUOTE]

Reicht das denn wirklich?


http://bugs.oxid-esales.com/view.php?id=6134

Gruß

Betrifft das nur das Setup als solches oder auch bestehende Shops?

Hintergrund der Frage: ich will in den nächsten Tagen den Server auf die 5.6 hochziehen und hätte aus dieser Richtung ungerne Überraschungen :slight_smile:

Danke euch :slight_smile:

Nur das Setup.

Ich denke es passiert folgendes:
Datei ist ISO. Im Header ist ISO angegeben. Setup ist auch ISO. Alles bestens.

Aber: Setup setzt das Charset nur mit Metatag. Http-Header hat Vorrang, wenn da “Utf-8” als default von PHP geliefert wird (>= PHP 5.6), dann passt es nicht.

Warum hat bei mir die Datei utf-8 encoding?

Denke du hast die Datei als UFT8 gespeichert als du die Änderung durchgeführt hast. Sonst würde es nämlich mit der Änderung auch nicht funktionieren.

Man müsste das Encoding im Setup per http-header setzen:

header("Content-Type: text/html; charset=" . $this->getText( 'charset' , false));

in _header.php

Ich habe den Shop kürzlich auf einem aktuellen Apache installiert und da scheint der Server beim Setup UTF-8 erzwingen zu wollen und schickt UTF-8 Header mit. Da die Dateien aber nicht UTF-8 sind, sieht es komisch aus.
Auf einem älteren Server sieht es aber gut aus.
Nach dem Setup ist alles wieder in gewohnter Oxid-Qualität :wink:

Ja hatte auch damals die Änderungen als utf-8 abgespeichert.

Habe nochmal komplett neu ausprobiert und header und encoding überprüft. Scheint wirklich so zu sein das meine Apache Einstellungen Utf-8 header erzwingen.

Habe im komplett neu entzippten Oxid Shop

header("Content-Type: text/html; charset=ISO-8859-15");

in die setup/de/lang.php geschreiben und löst das Problem auch.

Hab diesmal drauf geachtet die datei auch als ISO-8859-15 wieder abzuspeichern :slight_smile:

Vll könnte man das in die nächsten shop versionen ergänzen, da ich denke das ich nicht der einzig bin dessen Apache Settings utf-8 im header erzwingen.

Liebe Grüsse an die Oxid -esales Community.

PS : Ich wollte wirklich nicht negativ rüberkommen und den Shop schlecht machen. Ich habe mit dem Beweggrund euch dies mitzuteilen und den Shop zu verbessern ins Forum geschrieben.