Fehler bei der Installation Html 500


#4

https://docs.oxid-esales.com/eshop/de/6.1/installation/neu-installation/neu-installation.html

Einfach die Anleitung für Neu-Installation Schritt für Schritt durchführen und bei einem konkreten Fehler hier diesen beschreiben, dann sehen wir weiter.


#5

Wie schon beschrieben alles Lokal : fehler in der Console

Script if [ -f ./vendor/bin/oe-eshop-ide_helper ]; then oe-eshop-ide_helper; fi handling the oe:ide-helper:generate event returned with error code 1
Script @oe:ide-helper:generate was called via post-install-cmd


#6

Bei welchem Schritt in der Anleitung? Oder: Welcher Konsolenbefehl wurde denn eingegeben?


#7

#8

Also habe windows Shell aufgrufen
in der Shell dann
" composer install " eingegeben
dann hat die shell einige Befehle abgearbeitet

verlangte darauf den Pfad zum Shop den Internet Pfad gab ich ein
daselbe bei Modul und Test pfad

danach bekam ich die Meldung


#9

Unter Windows bekommt man diese Meldung. Kann man ignorieren, die Installation ist OK. Du kannst weitermachen, also das Setup im Browser aufrufen.


#10

Und genau das will ich ja
Geht nicht


#11

“Geht nicht” kann ja alles heißen. Eine etwas genauere Beschreibung bitte.


#12

Gehe danach auf meinen Browser ( fire Fox oder Opera oder Windows edge oder was auch immer )
und gebe in der Adress leiste die Internet Adress http://www.xxxxx.yyyyy.de/shop/1 ein
und der Bildschirm bleibt weiß

egal ob ich die dateen Hochgeladen habe das verzeichniss wechsle oder was auch immer !
weiß

Zum Upload
habe das komplatte Verzeichniss nach composer , Hochgeladen
oder auch nur die Yml datei

macht keinen Unterschied


#13

Warum /shop/1? Wenn du das komplette Verzeichnis hochgeladen hast (source und vendor) müsstest du doch /shop/source aufrufen.


#14

Auch dieses habe ich schon getestet

/shop/ ist die Supdomain
im Verzeichniss 1 liegt die Installation von euch
im Verzeichniss 2 liegt Gambio
im Verzeichniss 3 liegt eine Wordpress installation mit Woo comerce

da ich für mich testen will welche mir besser liegt und mit welcher ich besser zurecht kommen
Teste ich alle drei ( bin auch noch offen für andere :wink: )

DIe Domain wir nachher auf die Version zeigen
und der Umgang mit Sub domains sollte ja eigendlich kein Prob Sein


#15

Ürigends kommen alle anderen da,mit Klar
auch das verzeichniss shop/1/source geht nicht
genause wie 1/ Vendor oder was auch immer


#16

Das ist nicht die Installation “von uns”, wir sind hier auch nur Anwender.
Du musst shop/1/source aufrufen und nicht irgendwas anderes.
Wenn du einen Fehler 500 bekommst, kannst du in den Log-Dateien nachschauen woran das liegt. Wenn du keinen Zugriff auf die Log-Dateien hast, kannst du nur schauen ob es direkt an der htacess liegt, indem du die Datei htacess mal in ein eigenes Verzeichnis legst. Könnte z.B. an “Options +FollowSymLinks” liegen, das mögen manche Server nicht.
Wenn du sowieso nur testest, warum machst du das nicht lokal?


#17

Oki dann habe ich mich vieleicht falsch ausgedrückt
im Verzeichniss 1 liegen die dateien von Oxid Software :wink:

Also noch mal zum Nach vollziehen :

Softwarepaket Downloaden
Entpacken
und über composer aufrufen

danach alle Dateein die in dem Verzeichniss sind auf den Server hochladen
und dann den Pfad zB. http://www.shop.de/source aufrufen
und ann müsste das gehen sehe ich das Richtig ?

In den Log dateien habe ich nachgeschaut
dort sind drei Dateien

einmal die httacess
einaml die Index.html
einmal die oxdebugdb_skipped.sql

Da ich die shops auch Online Testen will und auch freunden zeigen will und da ist Online die beste Methode


#18

Den Unterschied zwischen einer Datei und einem Ordner kennst Du nicht?
Wenn V6 zu kompliziert ist, wäre OXID V4.10 vielleicht eine Option?


#19

Ne das ist so falsch. Du musst nichts downloaden, das macht composer. Lösch alles, vergiss das Downloadpaket und installiere über composer:
https://docs.oxid-esales.com/developer/en/6.1/getting_started/installation/eshop_installation.html

Nachdem composer die Dateien geholt hat fährst du hier fort um den Shop auf deinen Webspace zu kopieren:
https://docs.oxid-esales.com/developer/en/6.1/getting_started/installation/eshop_installation_without_composer.html

Den Fehler 500 wirst du so wahrscheinlich auch bekommen, und wenn das der Fall ist brauchst du Zugriff auf die Logdateien des SERVERS, nicht auf die von Oxid. Oder du schaust eben was dem Server nicht passt, z.B. evtl. eben Options +FollowSymLinks in htaccess.

Und ich stimme Vanilla zu, nur um zu schauen ob du lieber Gambio oder Oxid nehmen sollst, kannst du auch mal die 4.10 installieren.


#20

Nun der Unterschied ist mir sehr wohl bewusst , wusste nur nicht das das im Moment Wichtig ist
werde mich bessern :wink:

Zu Kompliziert ?! da könntest du recht haben ! Aber wenn ich eine Software verkaufen möchte und will das man diese Testen kann , würde ich die Instalation einfach machen , Ohne irgendwelchen …
damit der Test mir Kunden bringt und nicht diese abschreckt das auch so als Anmerkung :slight_smile:

Produktiv sein ist der bessere Weg !


#21

'leofonic

Oki das werde ich machen
mal alles löschen und deinen Ansatz neu beginnen , hier haeb ich wohl den Denkfehler mit dem Download Paket

werde das ganze noch mal testen und mich melden
Danke Dir für deine Geduld


#22

Jups , das war es Denkfehler ausräumen , einen auf die Richtige Spur bringen und es funkt *freu * Danke alle die Geholfen haben , manchmal braucht es halt einen Klaps in die richtige Richtung :slight_smile:

Hier mal mein kleines Work Around, damit Ihr was zum verweisen habt, bitte berichtigen wenn Falsch :

Als erstes habe ich Xamp auf meinem Win 10 Rechner Installiert und gestartet,
findet man unter Bitnami oder Xamp geht recht einfach

  • Downloaden Installieren fertig - dann habe ich Composer Installiert , hier passiert erst mal merklich auf dem Rechner nichts nach Installation, Ich habe dies nach dieser Anleitung gemacht :

https://php-de.github.io/jumpto/composer/

Danach habe ich mir ein Verzeichniss erstellt , bin in das Verzeichniss gewechselt,
habe dort über Rechtsklick an der Maus " git bash Klick here " gestartet .
Dann startet dort ein Fenster, das an die guten alten MS-Dos Zeiten erinnert,
wo man an der Comandozeile etwas eintragen kann :wink:
dort habe ich am Cursor:

composer create-project --no-dev oxid-esales/oxideshop-project your_project_name dev-b-6.1-ce
eingetippt (Danke#Leofonic )

dann startet der Composer und läd allerhand dateien herunter , geht ein kleine Weile,
danach habe ich dieses erzeugte Verzeichniss mitsamt seinem Inhalt auf mein Web Space
in mein Verzeichniss dort hochgeladen und über
http://www.deinVerzeichniss.de/source
aufgerufen und das gemacht was dort am Bildschirm steht :smile:

Nicht vergessen ihr Benötigt die Zugangsdaten einer MySQL Datenbank die sollte leer sein
und schwups es geht
ICh Danke allen super
Grüße Richy

PS da ich meine Maximale Anzahl an Beiträgen erreicht habe über diesen Weg :slight_smile:


Fehler bei Oxid 6.1.0 Installation unter Xampp
Vertsändnisfrage zur 6.x Installation
Vertsändnisfrage zur 6.x Installation
#23

Danke für das kleine Tutorial, müsstest schon wieder posten können mittlerweile.