Fehler nach Update 4.4.8. auf 4.5.11

Hallo an die Forums Mitglieder,

nach meinem Shopupdate von 4.4.8. auf 4.5.11 bekomme ich beim Aufruf der “updateApp” folgende Fehlermeldung:

[B]Error: script did not finish successfully.
Please check oxupdatetrack database table for executed actions.[/B]

Datenbankversion: MySQL5.0

Wenn ich meinen Shop aufrufen möchte, kommt 404 Fehler und in der Linkleiste steht der Link: http://meine Seite/oxid/setup/index.php

Werde leider nicht schlau aus den Threads, die bei Suche nach der Fehlermeldung erscheinen.

Würd mich freuen wenn jemand eine Hilfe für mich hat.

Danke und Gruß

Torsten

Kannst Du mal mit Deinem Hoster abklären, ob Dein Datenbankuser das Recht “CREATE VIEW” hat? Seit der Version 4.5.0 benötigt man das nämlich und vielfach haben die Hoster das nicht im Standard aktiviert.

Hallo Hebsacker,

hab heute endlich mal eine Nachricht von 1&1 erhalten.

Die schreiben folgendes:


vielen Dank für Ihre Nachricht.

Wir haben Ihr Anliegen geprüft, “Create View” ist durch den Datenbank-Owner möglich.

Muss ich jetzt etwas unternehmen? Wie kann ich mit dem Update fortfahren?

Danke und Gruß

Torsten

Please check oxupdatetrack database table for executed actions.

Schon mal da reingeschaut?

Fehlerlogs überprüft?

Alle Dateien aus dem Updatepaket hochgeladen?

Ich glaub da fehlen die DB-Einträge in der config.inc.php.

[QUOTE=leofonic;104869]Ich glaub da fehlen die DB-Einträge in der config.inc.php.[/QUOTE]

In der config.inc.php steht <dbHost_ce> an der Stelle wo die Datenbankzugänge rein gehören.

Gruß
Torsten

Da müssen dann die DB-Einträge eingetragen werden, dann nochmal UpdateApp laufen lassen.

:mad: Update durchgelaufen und nun das hier:

[I](Hab allerdings gleich von 4.4.8 auf 4.6.5 geupdatet …)[/I]

Warning: file_put_contents() [function.file-put-contents]: Filename cannot be empty in /homepages/13/d420340800/htdocs/oxid/core/oxutils.php on line 1424

Warning: fopen(<sShopDir_ce>/log/EXCEPTION_LOG.txt) [function.fopen]: failed to open stream: No such file or directory in /homepages/13/d420340800/htdocs/oxid/core/oxutils.php on line 1457

Warning: Cannot modify header information - headers already sent by (output started at /homepages/13/d420340800/htdocs/oxid/core/oxutils.php:1424) in /homepages/13/d420340800/htdocs/oxid/core/oxutils.php on line 1205

Warning: Smarty error: unable to read resource: “message/exception.tpl” in /homepages/13/d420340800/htdocs/oxid/core/smarty/Smarty.class.php on line 1093

Was hat er denn jetzt wieder falsch gemacht :slight_smile:

Gruß

Torsten

<sShopDir_ce> stimmt auch nicht in config.inc.php.

:rolleyes: Sorry der Nachfrage … aber was mus da rein? Da steh momentan [B]$this->sShopDir = ‘<sShopDir_ce>’;[/B] …

Hier mal die komplette Abteilung:

/** @name database information */
$this->dbHost = ‘XXX’; // database host name
$this->dbName = ‘XXX’; // database name
$this->dbUser = ‘XXX’; // database user name
$this->dbPwd = ‘XXX’; // database user password
$this->dbType = ‘mysql’;
$this->sShopURL = ‘www.meineSeite.de/oxid’; // eShop base url, required
$this->sSSLShopURL = null; // eShop SSL url, optional
$this->sAdminSSLURL = null; // eShop Admin SSL url, optional
$this->sShopDir = ‘/oxid’;
$this->sCompileDir = ‘/oxid/tmp’;

// UTF-8 mode in shop 0 - off, 1 - on
$this-&gt;iUtfMode  = '1';

Danke und Gruß

Torsten

Du hast doch sicher ein Backup wo du nachschauen kannst :wink:

[QUOTE=leofonic;104934]Du hast doch sicher ein Backup wo du nachschauen kannst ;)[/QUOTE]

Darf ich dazu einen :mad: roten Kopf machen? Hab ich leider nicht, aber aus fehlern lernt man ja …

Wenn du noch eine DB frei hast kannst du eine frische Installation in ein Unterverzeichnis machen, dann hast du alle Einträge, musst halt das Unterverzeichnis wieder rausnehmen.

Ansonsten leg dir eine Datei “phpinfo.php” mit dem Inhalt:

<?php phpinfo(); ?>

im Shopverzeichnis an, die rufst du im Browser auf und schaust bei _SERVER[“SCRIPT_FILENAME”], dann denk dir davon “/phpinfo.php” weg und du hast den lokalen Pfad.

sShopURL: die Url des Shops z.B. "http://deinshop.de/shop"
sShopDir: der lokale Pfad (siehe oben)
sCompileDir: der lokale Pfad und “/tmp” hintendran
iUtfMode: wenn bei der Installation “UTF-8 verwenden” angeklickt war dann 1 ansonsten 0. Wenn da was falsches steht werden die Umlaute nicht richtig angezeigt.

SO … VIELEN VIELEN DANK für die Geduld und die schnelle Hilfe.

Klappt alles was diesen Thread angeht -> DANKE!!!

also -> Thema gelöst!