.htaccess

Hallo

nachdem ich bei der installation 4.4.1 an den Dateizugriffrechten gescheitert bin habe ich nun die 4.4.2 hochgeladen da habe ich die Datei rechte in den Griff bekommen nur die htaccess macht noch Probleme.
Der Shorp läuft unter fivonet.de/shop mit Version 4.2.0 ohne Probleme nun wollten wir langsam auf 4.4.2 wechseln haben aber das htacces Problem. Der Shop läuft unter fivonet.de/shop2

Sie siht momentan so aus:

RewriteEngine On
RewriteBase /shop2
RewriteRule ^index.php$ - [L]

uploaded files

RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

add a trailing slash to /wp-admin

RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).) $2 [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(.
.php)$ $2 [L]
RewriteRule . index.php [L]

kann mir da jemand helfen auch die Lampe von rot auf grün zu bekommen??

MfG

Mal ne Frage, aber was für eine htaccess ist das? Kann es sein, das da spezielle Regeln für Wordpress drin sind? Schon mal mit der Orginal htacess aus dem Install-Paket versucht?

ja jetzt wo du es sagst fällt mir das auch auf. Aber ich habe das System frisch hochgeladen und da war die Datei dabei glaube ich? Schick mir doch bitte mal eine richtige oder kann ich die von shop1 nehmen?

ich habe mal die von shop eins probiert geht leider nicht.:mad:

die aktuelle sieht nun so aus:

<IfModule mod_rewrite.c>

Options +FollowSymLinks
RewriteEngine On
RewriteBase /shop2
RewriteCond %{REQUEST_URI} !(/core/|/export/|/modules/|/out/|/setup/|/tmp/|/views/)
RewriteRule admin/test.php$ admin/test.php?mod_rewrite=1

RewriteCond %{REQUEST_URI} !(/admin/|/core/|/export/|/modules/|/out/|/setup/|/tmp/|/views/)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule !(.html|/|.jpg|.css|.pdf|.doc|.gif|.png|.js)$ %{REQUEST_URI}/ [R=301,L]

RewriteCond %{REQUEST_URI} !(/admin/|/core/|/export/|/modules/|/out/|/setup/|/tmp/|/views/)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule (.html|/)$ oxseo.php

</IfModule>

disabling log file access from outside

<FilesMatch “(EXCEPTION_LOG.txt|.log$|.tpl$)”>
order allow,deny
deny from all
</FilesMatch>

Options -Indexes

geht aber trotzdem nicht immer noch rot.

<IfModule mod_rewrite.c>

Options +FollowSymLinks
RewriteEngine On
RewriteBase /

RewriteCond %{REQUEST_URI} oxseo.php$
RewriteCond %{QUERY_STRING} mod_rewrite_module_is=off
RewriteRule oxseo.php$ oxseo.php?mod_rewrite_module_is=on [L]

RewriteCond %{REQUEST_URI} !(/admin/|/core/|/export/|/modules/|/out/|/setup/|/tmp/|/views/)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule !(.html|/|.jpg|.css|.pdf|.doc|.gif|.png|.js)$ %{REQUEST_URI}/ [R=301,L]

RewriteCond %{REQUEST_URI} !(/admin/|/core/|/export/|/modules/|/out/|/setup/|/tmp/|/views/)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule (.html|/)$ oxseo.php

</IfModule>

disabling log file access from outside

<FilesMatch “(EXCEPTION_LOG.txt|.log$|.tpl$)”>
order allow,deny
deny from all
</FilesMatch>

Options -Indexes
DirectoryIndex index.php index.html

Das ist die der 4.4.1, sieht etwas anders aus…

Hallo

vielen Dank jetzt ist alles grün und ich kann mein Glück versuchen.

Danke.