Http wird auf https weitergeleitet

Hallo zusammen
vor ein paar Minuten konnte ich meinen shop noch ohne probleme anschauen.
jetzt kommt anstatt ein http vor der URL ein https. Dieses lässt sich nicht übersteuern, das heisst ich bleibe immer auf https mit der entsprechenden “schlechten” ansicht, d.h. design. auf http war das design tip top, auf https ist es komplett ohne styling. auch kann ich mich nicht mehr im backend einloggen.

URL ist “www.bottsa.ch/shop”… mit http vorne ist es wie normal, mit https fehlt das styling.

ich habe keine änderungen gemacht und frage micht deshalb, warum es alles auf https umstellt. wenn ich den cache lösche und dann die url neu eingebe, sehe ich wieder die “richtige” ansicht… sobald ich nach etwas suchen möchte, stellt es wieder auf https um und die ansicht ist wieder falsch.

gibt es eine erklärung für dieses problem?
meine config.inc hat keine angabe beim feld “ssslshopurl”… aber wie gesagt, vor ein paar stunden war das problem noch nicht da und geändert hab ich an den einstellungen nichts. Aber ein redirect auf https findet offensichtlich statt. nur weiss ich nicht woher das kommt…

für jede hilfe bin ich sehr dankbar.
lg
charly_brown

Hallo Charly,

schwierig zu sagen, was diese Umleitung ausgelöst hat. Aber prinzipiell ist es in der heutigen Zeit sowieso ratsam, seinen Shop mit HTTPS zu betreiben. Ein gültiges Zertifikat hast Du ja bereits installiert.

Um den Shop komplett auf HTTPS umzustellen schreib in deiner config.inc.php in die Option sShopURL deine Shop-URL mit https rein. sSSLShopURL und sAdminSSLURL kannst Du dann auf null lassen oder nach gleichem Schema entsprechend anpassen.

Viele Grüße,
Thorsten

1 Like

Ja, genau ändere die Werte sShopURL und sSSLShopURL in der config.inc.php zu https://www.bottsa.ch/shop/ dann sollte Deine CSS Datei auch wieder korrekt eingeladen werden. Und an Rechteverwaltung denken, config.inc.php kurz auf Rechte 666 setzen um zu bearbeiten und dann wieder auf 444 ändern.

Hi Thorsten, Hi Indianer3c

es scheint bereits wieder behoben zu sein… warum weiss ich auch hier wieder nicht… (ich weiss auch gar nichts, gelle ^^)… scheint , als ob da ein schluckauf der grund war…

wir sind halt ein bastelladen… lol

du hast ja so recht, man müsste es machen… (aber ich bin sowas von “in der zensur”, dass ich es schon länger vor mir herschiebe… )
du meinst also es reicht, wenn ich die config.inc anpasse so wie beschrieben und dann läuft der shop auf https…? .ich habe da mal was gelesen, das es auch im htacces etwas gemacht werden müsste… alsdann hab ich die finger davon gelassen… never touch a running system… aber ich kanns ja mal probieren mit der config.inc… viel versauen kann ich nicht, mache mir vorher eine kopie und geb der originaldatei einen anderen namen… wenns nicht funkt, kehrtwende…

aber ich hab ab morgen messe, da möchte ich heute noch nichts versemmeln… spar ich mir für den montag auf… ^^

danke euch vieeeeeelmals für euren support.
liebe grüsse
charly brown

1 Like

Hey Charly,

ja wenn Du an der htaccess sonst nichts geändert hast, dann sollte die Anpassung in der config.inc.php reichen.

Üblicherweise geht man dann noch hin und leitet über die htaccess alles was unverschlüsselt zugreift auf https um, aber das ist eine kleine Anpassung für die Du im Netz viele Beispiele findest, wie z.B. diese hier: https://pixelbar.be/blog/htaccess-schnippsel-https-erzwingen/

Viele Grüße,
Thorsten