Installation läuft nicht durch


#21

Das ist eine etwas andere Problematik, @Earlybird: Hier muss der Profihost-Support manuell den expliziten collation-Eintrag in der my.cnf auskommentieren, dann läuft’s. Warum das so ist, wissen wir noch nicht. Aktuell warte ich noch auf Rückmeldung, wie es mit MySQL 5.7 aussieht.


#22

Danke Marco, habe die info an Profihost weitgegeben.
Andererseits könnte das Problem doch generell vermieden werden, wenn bei der Installation die Tabelle oxmigrations_ce statt “uft8_unicode_ci” mit “utf8_general_ci” erstellt würde - was spricht dagegen?


#23

Hier dann noch der Workaround bis zum nächsten Patch, wer nicht mit Profihost reden sondern das lieber allein machen möchte:

Ausserdem gäbe es wohl in der Datei /source/migration/data/versionxxxxx650.php eine fehlerhafte SQL-Syntax sowie eine fehlende Default-Collation “utf8_general_ci” in der Datenbanktabelle “oxmigrations_ce” (da bin ich jetzt noch nicht ganz dahinter gestiegen).


#24

Habe das vermutlich das gleiche Problem mit CE 6.1. Shop soll unter 1und1 Account laufen. Habe den Shop zuerst auf Windows erzeugt (ohne Datenbank) und dann hochgeladen. Dort eine DB erstellt (MySQL 5.7) und die Daten in die Maske (Schritt 5) eingegeben. Es heißt dann nach dem Speichern: “Kontrolle und Schreiben der Dateien erfolgreich!
Bitte warten … " und es folgt der " Error 500 - Internal server error”.
Habe die Utilities.php wie oben geändert, Views kann ich anlegen, und auch die Kollation wird als utf8_general_ci gemeldet (stichprobenartig geprüft).
Nach ich-weiß-nicht-wievielen Versuchen bin ich mit meinem Latein am Ende.
Hat jemand eine Idee, was ich noch tun kann?
Vielen Dank.


#25

Im vendor-Verzeichnis?


#26

Nein, im source/Setup-Verzeichnis. Im source/Vendor-Verzeichnis gibt bzw. gab es kein Utilities.php (nur autoload.php).


#27

Ich hab doch oben extra dazugeschrieben: “Achtung nicht in source/Setup!” :wink:
Da steht auch der Pfad:


#28

Ja, wie immer: In der Hektik liest man die wichtigen Dinge nicht. Tschuldigung. Hab’s korrigiert. Und jetzt kann ich den Shop und die Administration starten.
Vielen Dank für die schnelle Hilfe.