Installation Oxid unter MySQL 5.1.58

Hallo zusammen,

[B]leider ist der Bereich MySQL Client Connector für MySQL 5 im Installationsassistenten rot.[/B]
Wenn man darauf klickt, dann erfährt man den Hintergrund - super gemacht, aber…

MySQL client connector for MySQL 5

MySQL client is connector used by PHP to connect to MySQL server. eShop requires MySQL client to be at at least version 5.0.33, although higher than 4.0 is still supported.

Due to a bug in MySQL 5.0.36 and 5.0.37 and a bug in MySQL 5.0.41, the OXID eShop does not run properly with these versions. If you are using MySQL 5.0.36 or 5.0.37 or 5.0.41, update MySQL to a other version.

[B]Bei meinem Provider goneo ist jedoch MySQL 5.1.58 eingerichtet.
Woran kann es liegen, dass diese Meldung erscheint?
Was ist zu ändern, damit ich die Installation von Oxid fertigstellen kann?
Es handelt sich um OXID-ESHOP 4.5.6.[/B]

Ich bitte um Hilfe.

Mit freundlichem Gruß

http://www.oxid-esales.com/forum/showthread.php?t=12729
https://bugs.oxid-esales.com/view.php?id=2666

    public function checkMysqlConnect()
    {
        // MySQL module for MySQL5
        $iModStat = ( extension_loaded( 'mysql' ) || extension_loaded( 'mysqli' ) || extension_loaded( 'pdo_mysql' ) || extension_loaded( 'mysqlnd' ) ) ? 2 : 0;
        // client version must be >=5
        if ( $iModStat ) {
            $sClientVersion = mysql_get_client_info();
            if (version_compare( $sClientVersion, '5', '<' )) {
                $iModStat = 1;
                if (version_compare( $sClientVersion, '4', '<' )) {
                    $iModStat = 0;
                }
            } elseif (version_compare($sClientVersion, '5.0.36', '>=') && version_compare($sClientVersion, '5.0.38', '<')) {
                // mantis#0001003: Problems with MySQL version 5.0.37
                $iModStat = 0;
            } elseif (version_compare($sClientVersion, '5.0.40', '>') && version_compare($sClientVersion, '5.0.42', '<')) {
                // mantis#0001877: Exclude MySQL 5.0.41 from system requirements as not fitting
                $iModStat = 0;
[B]            }
			if (strpos($sClientVersion, 'mysqlnd') !== false) {
			// PHP 5.3 includes new mysqlnd extension
			$iModStat = 2;[/B]
}

einfach Markierten Code in core/oxsysrequirements.php ersetzen.

Danke und Herzliche Grüße