Installation von Oxid 6.0 und 6.1 in oxvm nicht möglich

Hallo Community,

Ich versuche eine lokale Testumgebung mit oxvm https://github.com/OXID-eSales/oxvm_eshop aufzubauen.

Leider scheitere ich aber bei der Installation von Oxid CE oder auch Oxid PE

Die Shop-Installation bricht ab, weil das folgende Plugin nicht installiert werden kann:

Installing ocramius/package-versions (1.2.0): Loading from cache
Plugin installation failed, rolling back

Ich habe es erst mit
Vagrant Version 2.0.2 und VirtualBox 5.2.8 versucht und auch mit den aktuellsten Versionen
Vagrant Version 2.2.6 und VirtualBox 6.0.14
auf einem Windows PC

Kann mir jemand helfen? Wo liegt das Problem?

Bin für jeden Tipp dankbar.

Beste Grüsse Claudia

Hi @claro :slight_smile:

das gleiche Problem hatte am 19. November 2019 jemand im OXID Devs Slack Workspace unter dem Channel #dev-general_german beschrieben.

Der dortige Workaround für Windows lautete:

Workaround for Windows env:

  1. Create new project in terminal as administrator on WIndows OS
  2. Finish OXID installation on Windows side but you will have wrong bin files. To fix this go to the next step.
  3. Login into VM via vagrant ssh
  4. Execute in /var/www/{PROJECT_NAME}:
    composer clear-cache
    rm composer.lock
    rm -r vendor
    composer update --no-scripts --no-plugins
    composer update
  5. Execute:
    vendor/bin/oe-eshop-unified_namespace_generator
    (without this you will have “ConfigFile” error)

Hoffe dies hilft.

Viele liebe Grüße,
Tim

Hallo Tim
Wow - tausend Dank!!! :+1: Hat geklappt und ich konnte einen Oxid 6.1.5 Shop ohne weitere Probleme fertig aufsetzen.

Herzliche Grüsse
Claudia

1 Like