Installationsroutine startet nicht

es ist noch gar nicht so lange her da habe ich Oxid erfolgreich installiert, nun habe ich es nochmals mit der neuen Version probiert und die Installationsroutine beginnt nicht.

Ich erhalte lediglich eine Internal Server Error Fehlermeldung. Habe beim Provider nachgefragt und der meinte das die Systemvoraussetzungen für Oxid erfüllt sind aber irgendwie versucht extern weiterzuverbinden was mein Provider aber blockiert hat - er könnte vereinzelt eine Blockierung aufheben, was muss er also aufheben?

Wenn ich die htaccess lösche dan startet die Routine erhalte aber einen roten Status für mod_rewrite (dieser ist aber sicher eingeschaltet) und fehlende Zugriffsrechte (habe zum Test alles auf 777 gesetzt, bringt aber nichts)

ich glaube es hat was mit der htaccess bzw mit dem Provider hier mal der Inhalt:

<IfModule mod_rewrite.c>

Options +FollowSymLinks
RewriteEngine On
RewriteBase /oxid/

RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
RewriteRule .* - [F]

RewriteCond %{REQUEST_URI} oxseo\.php$
RewriteCond %{QUERY_STRING} mod_rewrite_module_is=off
RewriteRule oxseo\.php$ oxseo.php?mod_rewrite_module_is=on [L]

RewriteCond %{REQUEST_URI} !(\/admin\/|\/core\/|\/export\/|\/modules\/|\/out\/|\/setup\/|\/tmp\/|\/views\/)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule !(\.html|\/|\.jpg|\.css|\.pdf|\.doc|\.gif|\.png|\.js|\.htc)$ %{REQUEST_URI}/ [R=301,L]

RewriteCond %{REQUEST_URI} !(\/admin\/|\/core\/|\/export\/|\/modules\/|\/out\/|\/setup\/|\/tmp\/|\/views\/)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule (\.html|\/)$ oxseo.php


RewriteCond %{REQUEST_URI} (\/out\/pictures\/)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule (\.jpg|\.gif|\.png)$ core/utils/getimg.php

</IfModule>

# disabling log file access from outside
<FilesMatch "(EXCEPTION_LOG\.txt|\.log$|\.tpl$|pkg.rev)">
order allow,deny
deny from all
</FilesMatch>

Options -Indexes
DirectoryIndex index.php index.html

habe Rewritebase angepasst, war aber nicht die Lösung, es ist auch egal wie ich die Installation aufrufe - über /oxid - /odix/setup - /oxid/setup/index.php … klappt alles nicht, erst wenn ich die .htaccess lösche wird die Routine aufgerufen erhalte aber bei 2 Punkten einen roten Status wo keiner sein dürfte

erlaubt der Provider eigene htaccess?

muss ich das nachfragen, oder kann ich das selbst testen?

€dit: also lt, dieser Anleitung funktioniert meine htaccess:

mein Provider (World4you), meinte das ich die Options Befehle in der .htaccess deaktivieren sollte, dann müsste es gehen.
Die Installation startet nun ohne Fehlermeldung, jedoch weis ich noch nicht in wie weit sich dieser Eingriff später auswirken wird.

dann aktiviere die doch nach der Installation wieder

Hallo zusammen,

ich habe leider das gleiche Problem.

Unter localhost, lässt sich die Installationsroutine ganz normal starten.

Meine .htaccess müsste also richtig konfiguriert sein.

Sobald ich nun allerdings die Dateien, wie in den Tutorials beschrieben auf meinen FTP hochlade (Domain: www.meinedomain/shopmodul) startet die Installation einfach nicht und ich bekomme nur einen Internal Error.

Ich habe jetzt versucht noch mal einen anderen Pfadnamen zu wählenn. Hat auch nicht geklappt.

Dann habe ich versucht die .htaccess einfach mal zu löschen und gucken ob die Installation dann startet, klappt aber nicht, weil die Datei komischerweise nicht angezeigt wird, in Filezilla.

Hat jemand eine Idee warum? Wenn ich Sie erneut hochlade, wird Sie ganz kurz eingeblendet und ist dann aber sofort verschwunden (nach 0,5 sekunden oder so).

Vielen Dank für eure Hilfe.

Bin leider kein Profi auf dem Gebiet.

Moin mv…,

stell mal bei deinem FTP-Programm versteckte Dateien Anzeige erzwingen ein, dann siehst du auch die .htaccess.

Beste Grüsse

Thomas

Hallo,

Danke für deine schnelle Antwort.

Habe ich aktiviert, (auch nochmal deaktiviert und wieder aktiviert,) wird trotzdem nicht angezeigt.

Wenn ich die Datein noch einmal in das gleiche Verzeichnis hochlade, müsste ja auch im Prinzip gefragt werden, ob ich die vorhandene .htaccess überschreiben möchte. Auch das kommt nicht.
Und viel wichtiger, warum lässt sich das Setup nicht starten?

Im Prinzip würde es ja sogar starten, wenn mein Server die Vorraussetzungen für OXID nicht erfüllen würde (was er eigentlich tut) und mir dies dann anzeigen, oder sehe ich das falsch?

Ich schreibe hier noch mal kurz rein, wie ich bisher vorgegangen bin:

  1. OXIDcommunity heruntergeladen.
  2. Die Datenbank laut Handbuch erstellt
  3. OXID in einen Ordner auf meinem PC entpackt.
  4. .htaccess bearbeitet (RewriteBase /shopmodul und letzte Zeile:" Options -Indexes DirectoryIndex index.php index.html"
  5. Mit Filezilla einen Ordner auf meinem Server erstellt (root/shopmodul)
  6. Alle Dateien des Ordners OXID auf meinem PC in den Ordner shopmodul auf meinem Server mit Filezilla hochgeladen
  7. Im meinem Browser versucht die Installation über (www.meinedomain.de/shopmodul) zu starten.

Leider erscheint dann immer “Internal Server Error The server encountered an internal error or misconfiguration and was unable to complete your request.”

Wie gesagt, unter localhost funktioniert es einwandfrei, aber das hilft mir ja auch nicht weiter.

Über jede Hilfe wäre ich sehr dankbar.

Viele Grüße!

Hallo nochmal,

bin etwas weiter.
Und zwar, wenn ich die .htaccess einfach umbenenne, ohne den “.” vorne also nur als “htaccess”, diese dann auf den Server hochlade und dann erst auf dem Server wieder umbenenne in “.htaccess” dann wird die alte Datei automatisch überschrieben.

Jetzt kann ich die .htaccess sehen, bis ich das Verzeichnis wechsel, bzw. bis sich die Ansicht akutalisiert, dann ist sie wieder versteckt. (d.h. ich sehe sie nicht mehr und kann also auch nicht darauf zugreifen, aber sie ist noch da). Es klappt einfach bei mir bei Filezilla nicht mit der Einstellung, “versteckte Dateien anzeigen.”.

So jetzt kommts aber:
Wenn ich die htaccess (ohne Punkt) ind .htaccess(mit Punkt) umbenenne, damit ich Zugriff auf die richtige .htaccess habe und diese Datei dann einfach vom Server lösche, dann startet die Installation, wirft mir aber die gleichen Fehler raus, wie power87 oben beschrieben hat.

Scheinbar hat es bei power87 ja dann geklappt, in dem er die Options in der .htaccess deaktiviert hat.

Das würde ich auch gerne Probieren, kann mir einer sagen wie ich das mache?
Danke!!

Einfach die Zeile löschen “Options -Indexes” und hochladen.

Ja danke, das hatte ich mir schon gedacht, aber wenn ich nur die Zeile Options-Indexes lösche, kommt immer noch der Internal Error. Sobald die ganze .htaccess gelöscht wird, startet die Installationsroutine…

Leider…

‘Options +FollowSymLinks’ auch rausgelöscht? Als nächstes dann ‘DirectoryIndex index.php index.html’, also mit “Options -Indexes” dann 3 Zeilen.

1000… DANK!

Habe jetzt gelöscht: ‘Options +FollowSymLinks’, “Options -Indexes” und ‘DirectoryIndex index.php index.html’…

Die Installation startet jetzt.

Jetzt leuchtet noch rot:

“register_globals muss ausgeschaltet sein”
“Dateizugriffsrechte”

leofonic, wenn du noch Zeit und Lust hast kurz zu erklären wie ich die beiden Punkte grün bekomme, wäre ich sehr froh, wenn nicht, sag bitte nur kurz bescheid, dann wühle ich mich weiter durchs Forum… (nur dass ich dann nicht auf eine Antwort warte)

Aber vielen Dank schon mal für deine Hilfe, gefühlt bin ich 1000 Schritte weiter …

Habe alles hinbekommen soweit,… Danke!!!

Also bitte keine Mühe mehr machen, werde mich mal durch den Rest durchkämpfen.

Danke für die Hilfe!

[[email protected];93162]Habe alles hinbekommen soweit,… Danke!!!

Also bitte keine Mühe mehr machen, werde mich mal durch den Rest durchkämpfen.

Danke für die Hilfe![/QUOTE]

Und wie hast du es hinbekommen, das würde mich jetzt interessieren …
Denn ich habe zur Zeit das gleiche Problem.
Und obwohl ich die Options-Einträge gelöscht habe, startet die installation nicht.

Wenn ich die ganze .htaccess-Datei lösche, erhalte ich die Fehlermeldung das ich keine Berechtigung habe auf dieses Verzeichnis zuzugreifen.
Und in der Logdatei habe ich dann den folgenden Eintrag:

[Sun Aug 05 10:23:53 2012] [crit] [client xxx.xxx.xxx.xxx] (13)Permission denied: /pfadangabe/oxid/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable

Es sollte doch zu schaffen sein, so einene kleinen OnlineSHop zu installieren.

Grüße
Thomas

Hallo zusammen,

also zunächst mal hatte ich auch das Problem, dass meine Installation nicht starten will. Hab dann das mit dem Test-Ordner und der index.html durchgeführt und ich komm da gar nicht ran auf meine Seite. Es erscheint immer nur die Meldung: "Hier entsteht eine neue Internetpräsenz"
Wie auch immer, wollte nur was zu dem Thema sagen, wegen .htaccess. Beim herumklicken im FileZilla hab ich festgestellt, dass da bei Bearbeiten > Einstellungen > (linke Seite) Übertragungen > Dateitypen unten zwei Häckchen gesetzt waren:

  • Dateien ohne Endung als ASCII-Dateien behandeln
  • ´dotfiles´ als ASCII-Dateien behandeln
    vielleicht liegt es daran, dass die .htaccess gefunzt nachdem man es hochgeladen hat.

Ansonsten, viel Spaß bei der Fehlersuche. Ich hoffe mal, dass mein Provider mal in die Gänge kommt.

Grüße Doorags…

Ok, jetzt bewegt sich doch was aber nicht ins positive.
Wenn ich jetzt meine URL eingebe leitet die Seite mich auf www.meineurl.de/oxseo.php um und ich bekomme die Fehlermeldung:
Fehler: Umleitungsfehler
Die aufgerufene Website leitet die Anfrage so um, dass sie nie beendet werden kann
Dieses Problem kann manchmal auftreten, wenn Cookies deaktiviert oder abgelehnt
werden.

Wenn ich www.meineurl.de/setup eingebe bekomm ich diese Meldung:

Error 404 - Datei nicht gefunden
Die angeforderte URL konnte auf dem Server nicht gefunden werden

Hi,

und wenn Du direkt die index.php aufrufst?
Du kannst Dir den Shop zum testen auch mal direkt bei Profihost aufsetzen. Dort weiss man zumindest, dass es klappt:

Alternativ kannst Du Dir auch eine Testumgebung lokal aufsetzen, das wäre später eh empfehlenswert.

Gruß

[QUOTE=Doorags.eu;111828]Ok, jetzt bewegt sich doch was aber nicht ins positive.[/QUOTE]
Warum bewegt sich was? Hast du was geändert?
Dein ursprünglicher Fehler (“Hier entsteht eine neue Internetpräsenz”) liegt einfach daran, dass noch eine alte index.html im Verzeichnis liegt. Einfach löschen oder eben index.php direkt aufrufen.
“Dotfiles als ASCII” würde ich dekativieren. ASCII Modus braucht man nie.