Internal Server Error

Hallo,
hab wie viele andere hier, das Probleme dass ich nen internal server error bekomme, wenn ich die installation aufrufe…

hier findet ihr die phpinfo:
http://www.pixelfenster.de/info.php

Mod rewrite ist also aktiviert, meine .htaccess sieht folgendermaßen aus und wurde im ASCII modus hochgeladen (Automat. hab ich auch schon probiert), ebenso hab ich auskommentieren von

Options +FollowSymLinks
Options -Indexes

probiert…

<IfModule mod_rewrite.c>

Options +FollowSymLinks
Options -Indexes

RewriteEngine On
RewriteBase /oxid/

RewriteCond %{REQUEST_URI} !/(admin|core|export|modules|out|setup|tmp|views)/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule !(/|\.html|\.jpg|\.css|\.pdf|\.doc|\.gif|\.png|\.js)$ %{REQUEST_URI}/ [R=301,L]

RewriteCond %{REQUEST_URI} !/(admin|core|export|modules|out|setup|tmp|views)/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule (/|\.html)$ oxseo.php


</IfModule>

# disabling log file access from outside
<FilesMatch "(EXCEPTION_LOG\.txt|\.log$|\.tpl$)">
order allow,deny
deny from all
</FilesMatch>

Options -Indexes

Danke schonmal!

Lg,
Robert

Die Dateien liegen im Ordner /oxid/ ?

[QUOTE=roland76;25469]Die Dateien liegen im Ordner /oxid/ ?[/QUOTE]

ja:) also ich hab echt keine ahnung an was es liegt…

Hallo Robert,

wende Dich bitte mal an den Provider. Bei Dir wird die .htaccess-Datei nicht verarbeitet; evtl. ist keine eigene .htaccess-Datei erlaubt.

Gruß

danke für die schnelle antwort.
Mit meinem provider rede ich gerade über skype (ist ein alter arbeitskollege). mod_rewrite ist wie gesagt aktiviert, die htaccess bei joomla funzt auch wunderbar, und eigene htaccess sind auch erlaubt…hm…

Hi,

dass scheitert’s wahrscheinlich an irgendeinem Eintrag in der OXID-htaccess, die beim ehem. Arbeitskollegen nicht erlaubt ist.

Gruß

hm er sieht sichs grad an…

[QUOTE=rkleinert;25476]hm er sieht sichs grad an…[/QUOTE]

Prima. Mach auch erstmal die htaccess raus, diese ist für die Installationsroutine selbst nicht relevant. Wenn Du die Installation problemlos starten kannst, liegt’s definitiv an der htaccess.

Gruß

Ok also der internal server error is jetz weg, lag dran dass option indexes nicht erlaubt war, allerdings kommen jetz noch folgende fehlermeldungen:

Warning: Invalid argument supplied for foreach() in /var/customers/webs/res02cus01/oxid/core/oxbase.php on line 1016

Warning: Invalid argument supplied for foreach() in /var/customers/webs/res02cus01/oxid/core/oxbase.php on line 1016

Warning: Invalid argument supplied for foreach() in /var/customers/webs/res02cus01/oxid/core/oxbase.php on line 1016

Warning: array_keys() [function.array-keys]: The first argument should be an array in /var/customers/webs/res02cus01/oxid/core/oxlang.php on line 365

Warning: array_keys() [function.array-keys]: The first argument should be an array in /var/customers/webs/res02cus01/oxid/core/oxlang.php on line 365

Warning: array_keys() [function.array-keys]: The first argument should be an array in /var/customers/webs/res02cus01/oxid/core/oxlang.php on line 365

Warning: array_keys() [function.array-keys]: The first argument should be an array in /var/customers/webs/res02cus01/oxid/core/oxlang.php on line 365

Warning: array_keys() [function.array-keys]: The first argument should be an array in /var/customers/webs/res02cus01/oxid/core/oxlang.php on line 365

Warning: Cannot modify header information - headers already sent by (output started at /var/customers/webs/res02cus01/oxid/core/oxbase.php:1016) in /var/customers/webs/res02cus01/oxid/core/exception/oxexceptionhandler.php on line 178

Warning: Cannot modify header information - headers already sent by (output started at /var/customers/webs/res02cus01/oxid/core/oxbase.php:1016) in /var/customers/webs/res02cus01/oxid/core/exception/oxexceptionhandler.php on line 179

Warning: Cannot modify header information - headers already sent by (output started at /var/customers/webs/res02cus01/oxid/core/oxbase.php:1016) in /var/customers/webs/res02cus01/oxid/core/exception/oxexceptionhandler.php on line 180

EDIT: wenn ich direkt auf den setup ordner gehe im browser funktioniert alles aber bei mod_rewrite is es rot…

[QUOTE=rkleinert;25483]Ok also der internal server error is jetz weg, lag dran dass option indexes nicht erlaubt war, allerdings kommen jetz noch folgende fehlermeldungen:[/QUOTE]

Prima, dann sind wir schon einen Schritt weiter.
Lad den kompletten Shop bitte noch einmal neu hoch, bitte komplett im binär-Modus.

Davon abgesehen sieht mir die Serverkonfiguration nicht wirklich gesund aus: Wenn ich ein memory_limit von 128MB sehe, sieht das schon ganz schön dick aus…
Lösch bitte auch lieber mal die phpinfo vom Server, die öffnet böswilligen Menschen Tür und Tore.

Gruß

hm jetz sieht die htacces plötzlich so aus:

<IfModule mod_rewrite.c>

Options +FollowSymLinks
Options -Indexes

RewriteEngine On
RewriteBase /oxid/
RewriteCond %{REQUEST_URI} !(/core/|/export/|/modules/|/out/|/setup/|/tmp/|/views/)
RewriteRule admin/test.php$ admin/test.php?mod_rewrite=1

RewriteCond %{REQUEST_URI} !(/admin/|/core/|/export/|/modules/|/out/|/setup/|/tmp/|/views/)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule !(.html|/|.jpg|.css|.pdf|.doc|.gif|.png|.js)$ %{REQUEST_URI}/ [R=301,L]

RewriteCond %{REQUEST_URI} !(/admin/|/core/|/export/|/modules/|/out/|/setup/|/tmp/|/views/)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule (.html|/)$ oxseo.php

</IfModule>

disabling log file access from outside

<FilesMatch “(EXCEPTION_LOG.txt|.log$|.tpl$)”>
order allow,deny
deny from all
</FilesMatch>

#Options -Indexes

also anders als vorher, woran liegt das?

problem dank meines hosters gelöst, fragt mich nicht wie, ich werds dann posten…

[QUOTE=rkleinert;25488]problem dank meines hosters gelöst, fragt mich nicht wie, ich werds dann posten…[/QUOTE]

Na passt doch :slight_smile:

Gruß

[QUOTE=rkleinert;25467]
Options -Indexes[/QUOTE]

Hi - warum diese Zeile 2 Mal?

Die Internal Server Access Fehlern konnte ich immer am schnellsten in die Apache Server log (/var/log/apache/ auf Debian) fangen.

Grüße
Ashant