Kopie des Shops / Shop spiegeln

Hallo,

gibt es eine einfache Möglichkeit, von meinem Shop ein genaue Kopie zu erstellen? Ich brauche quasi einen “Testshop” mit gleichem Inhalt und gleichem Aussehen um Tests (vorallem vom Update) machen zu können. Außerdem könnte ich in Notfällen dann auf den “Testshop” leiten, bis der Originalshop wieder online ist, falls mal was schief geht.

Hauptsächlichst will ich die Kopie jedoch, da ich den Originalshop updaten will und Angst habe, dass danach all meine Templateveränderungen weg sind oder ein Modul oder eingerichteter Ablaufweg nicht mehr richtig funktioniert.

Ich arbeite mit OXID eShop CE 4.5.0 und dem Theme Azure.

Habe auch bereits einen “Zweitshop” erstellt und versucht die Artikel aus dem Originalshop zu importieren, nur schaffe ich das irgendwie nicht, daher die Frage nach anderen Wegen.

Danke und Gruß
Daniel

Das Umzugstutorial hier: http://wiki.oxidforge.org/Tutorials/Einen_Oxid-Shop_umziehen_lassen geht auch um eine Kopie zu erstellen.

Du kannst ja beispielsweise mit XAMPP oder Server2Go etc. einen lokalen Server erstellen.
Wenn du dann dort z.B. am Design etwas änderst und es dir gefällt, einfach die geänderten Dateien auf den öffentlichen Server laden.

Hallo und danke für die Hilfe, nur scheitere ich im Moment an 2 Dingen.

  1. Wo finde ich eine Installation für diese (meine aktuelle) ShopVersion OXID eShop CE 4.5.0_34568?

  2. Mit dem mySqlDumper konnte ich die Datenbank sichern (laut Anleitung) und bis 99% mit den Daten der “alten” DB füllen, doch dann bricht der Dumper ab und sagt folgendes:

MySQL meldet:
Table ‘oxvendor’ already exists

Fehler bei der Anfrage:
CREATE TABLE oxvendor ( OXID char(32) character set latin1 collate latin1_general_ci NOT NULL, OXSHOPID char(32) character set latin1 collate latin1_general_ci NOT NULL default ‘’, OXACTIVE tinyint(1) NOT NULL default ‘1’, OXICON varchar(128) NOT NULL default ‘’, OXTITLE varchar(255) NOT NULL default ‘’, OXSHORTDESC varchar(255) NOT NULL default ‘’, OXTITLE_1 varchar(255) NOT NULL default ‘’, OXSHORTDESC_1 varchar(255) NOT NULL default ‘’, OXTITLE_2 varchar(255) NOT NULL default ‘’, OXSHORTDESC_2 varchar(255) NOT NULL default ‘’, OXTITLE_3 varchar(255) NOT NULL default ‘’, OXSHORTDESC_3 varchar(255) NOT NULL default ‘’, OXSHOWSUFFIX tinyint(1) NOT NULL default ‘1’, PRIMARY KEY (OXID), KEY OXACTIVE (OXACTIVE) ) ENGINE=MyISAM DEFAULT CHARSET=utf8;

Bin langsam echt am verzweifeln :frowning:

Die Fehlermeldung kommt bei mir auch immer.
Warum weiß ich nicht, aber es waren dennoch alle Daten importiert.

Ah, gut zu wissen, dann werde ich das gleich mal ausprobieren :slight_smile:

Jetzt brauch ich nur noch ne Installationsdatei vom “alten” Shopsystem und dann kann ich testen. Jemand ne Idee oder einen Tipp, woher ich diese Version bekommen kann (CE 4.5.0_34568)?

Danke und Gruß
Daniel

hier:

Vielen Dank für die Hilfe! :slight_smile:

Hallo nochmal,

habe jetzt alles wie im Umzugstutorial beschrieben gemacht und der neu erstellte Testshop läuft “teilweise”. Was nicht zu gehen scheint ist Paypal (wobei hier sicher der Connector und efire neu eingerichtet werden müssen, oder?) und es werden keine Bilder angezeigt. Habe aber alles laut Beschreibung rüber kopiert … woran kann das liegen?

Danke und Gruß
Daniel

Ein Efire-Account funktioniert nur mit einer einzigen Shop-Installation auf einer einzigen Domain. Für einen zweiten Shop wäre ein zweiter eFire-Account erforderlich. Somit kann natürlich auch PayPal nicht mit deinem “Testshop” funktionieren.

Danke für die Info, bleibt nur noch die Frage, warum mir keine Artikelbilder angezeigt werden?

Wo kann ich denn die Grund-URL für die Artikelbilder hinterlegen … vielleicht hat das System noch die alte URL drin?