Login Weiterleitung beim Newsletter Modul

Guten Tag,

ich verzweifle langsam an dem Newsletter-Modul. Seit dem Update meines Shops von 4.1.5 auf 4.4.8 funktioniert das Newsletter-Modul nicht mehr. Wenn ich auf den Link im Backend klicke, werde ich auf die Loginmaske weitergeleitet (Die URL sieht wie folgt aus: …/admin/index.php?stoken=…&?cl=newsletter_list&oxid=-1). Nach dem Login lande ich dann wieder auf der Startseite des Backends. Ich habe mich in den Foren schon schlau gemacht, aber bis jetzt habe ich nichts gefunden. Das Problem tritt einzig und allein bei dem Newsletter-Modul auf.

Vielen Dank im Voraus!

Liebe Grüße

vielleicht kann das Newsletter Modul mit der neueren OXID Version nicht mithalten. Modul-Entwickler fragen

Das Newsletter-Modul ist von Anfang in Oxid integriert. Beim Update habe ich sogar die betroffenen Dateien mit den Neuen ersetzt. In der beigelegten README sind einige Anmerkungen zum Newsletter-Modul zu finden. Es scheint also grundsätzlich kompatibel zu sein.

Hat niemand einen Rat für mich?

Hallo,

offenbar wirst Du aus der Admin-Session geworfen, wenn Du auf den Newsletter-Link klickst. Es besteht also die Vermutung, dass beim Update etwas nicht richtig gelaufen ist oder ggf. eine Anpassung vergessen wurde. Bitte prüf die Konsistenz der Dateien mal mit einer oxchkversion.

Gruß

Ich hab das oxchkversion Script auf dem Server laufen lassen. Das Ergebnis ist folgendes:

Edition	CE
Version	4.4.8
Revision	34028
 	 
Summary

OK	989
Modified	9
Version mismatch	155
Unknown	5
Number of investigated files in total:	1158
 	 
This OXID eShop does not fit 100% CE_4.4.8_34028.

core/oxdebuginfo.php	Version mismatch (details)
core/oxdynimggenerator.php	Version mismatch (details)
core/oxmodulelist.php	Version mismatch (details)
core/oxpdf.php	Version mismatch (details)
core/oxpricelist.php	Version mismatch (details)
core/oxselection.php	Version mismatch (details)
core/oxstr.php	Version mismatch (details)
core/oxtheme.php	Version mismatch (details)
core/oxvariantselectlist.php	Version mismatch (details)
admin/adminlinks_main.php	Version mismatch (details)
admin/theme.php	Version mismatch (details)
admin/theme_config.php	Version mismatch (details)
admin/theme_list.php	Version mismatch (details)
admin/user_extend.php	Version mismatch (details)
views/exceptionerror.php	Version mismatch (details)
...
...
...
...
...

Der HTTP Request von “/oxid/admin/index.php?stoken=F251F55F&?cl=newsletter_list&oxid=-1” gibt folgendes wieder:

HTTP/1.1 200 OK
Date: Sun, 13 Jan 2013 21:01:22 GMT
Server: Apache/2.2.16 (Debian) DAV/2 SVN/1.6.12 PHP/5.2.17 mod_ssl/2.2.16 OpenSSL/0.9.8o
X-Powered-By: PHP/5.2.17
Set-Cookie: admin_sid=a83463196660ffc2ef62507b470b7256; path=/; httponly
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Pragma: no-cache
Set-Cookie: language=0; path=/; httponly
Set-Cookie: [B]oxid_oxbaseshop=deleted[/B]; expires=Sat, 14-Jan-2012 21:01:22 GMT; path=/; httponly
Content-Length: 3273
Keep-Alive: timeout=15, max=98
Connection: Keep-Alive
Content-Type: text/html; charset=UTF-8

Liegt es vielleicht an dem rotmarkierten Cookie?

Woher kommen denn die ganzen “Version mismatch” - Dateien? Mir scheint, dass da ein Update nicht sauber durchgelaufen ist.