Mobile Template: Das Sicherheitszertifikat der Website ist nicht vertrauenswürdig

Hallo Community,

ich benutze die CE 4.8.4 und habe SSL aktiv. Im Desktopbereich funktioniert alles probemlos. Beim Mobilen Template kommt aber eben genau diese Fehlermeldung:

[B]Das Sicherheitszertifikat der Website ist nicht vertrauenswürdig![/B]

Wie kann ich das Problem lösen?

Vielen Dank schon mal.

fang z.B: mit einem Link zum Shop an

www.padaja.de

ich vermute mal, dass ssl falsch konfiguriert wurde.
da fehlt ein intermediate certificate, quasi die Info, dass der Herausgeber von deinem Zertifikat ebenso vertrauenswürdig ist.
Ich vermute mal, dass es in der Installationsanleitung des Zertifikats mehr info darüber geben sollte.
Bzw hier ist die commodo knowledge base:
Installation: https://support.comodo.com/index.php?/Default/Knowledgebase/List/Index/37
intermediate info: https://support.comodo.com/index.php?/Default/Knowledgebase/Article/View/620/1/which-is-root-which-is-intermediate

Hallo Vanilla,

das SSL wird von all-inkl bereit gestellt. Ich habe eben mit dem Support telefoniert. Die meinten das wohl auf Inhalte zugegriffen wird, die nicht verschlüsselt sind, also kein https haben. Daraus würde ein “Mix” entstehen der die Seite dann nicht mehr vertrauenswürdig macht.

Also ich kann an der SSL Konfiguration selber gar nichts machen.

google font wird ohne https geladen, aber das stört nicht, weil es einfach nicht geladen wird.
Die Fehlermeldung sagt eindeutig etwas anderes, als der Support.

ich würde jetzt einfach google font auch von https laden lassen und dann haben sie keine Ausreden mehr

Hi Vanilla,

ich habe jetzt nochmal recherchiert. Die Sache ist die das einige Bilder und Links teilweise als HTTP und nicht als HTTPS angegeben werden. Es müssen wohl alle HTTP Request verschlüsselt sein, also sprich Bilder und Links.

Logischerweise benutze ich keine abosluten Pfade, sondern nur relative:
Die Bilder werden so eingebunden: [B][{$oViewConf->getImageUrl(‘logo.svg’)}][/B]

In der Config ist die SSL url auch eingetragen:

$this->sShopURL = ‘http://padaja.de’;
$this->sSSLShopURL = ‘https://padaja.de/’;

Wie gesagt es betrifft nur die Mobile Variante. Ich weiß hier leider nicht weiter und die Pfade mit absoluten Pfaden zu vergeben ist ja auch nicht im Sinne des erfinders.

Es gibt dazu auch einige Forenbeiträge, allerdings bringt mich keiner davon wirklich weiter.

Hallo Padaya,

offenbar hast du das Problem gelöst. Magst du erzählen, was die Lösung war?

Ich habe jetzt mal den Oxid-Demoshop aufm Handy geladen. Der bekommt fürs Mobile-Theme auch kein grünes SSL-Schloss. Nur eins mit Einschränkung für “nicht sichere Ressourcen”.

https://bugs.oxid-esales.com/view.php?id=5946

Wenn man in der base.tmp (mobile) das http: vor //fonts.googleapis.com einfach wegnimmt, dann kommt die grüne Lampe.:slight_smile:

Noch ein Hinweis:
Auf der Registerseite im Mobile-Theme wird mit Sternchen für die Pflichtfelder gearbeitet. Trotzdem steht da, man soll die “fett beschrifteten Felder ausfüllen”, so ist es halt in der Desktop-Version. Muss aber heißen: “Bitte alle mit Sternchen beschrifteten Pflichtfeder ausfüllen”:slight_smile:

Lässt sich aber einfach in der lang-datei und userbilling.tpl mit ner zweiten COMPLETE_MARKED_FIELDS ändern.

Guter Hinweis. Das sollte in die lang-Datei für den view. Kannst Du das als Pull Request schicken?

Danke und Gruß,

[QUOTE=oxid_on_mac;152253]Noch ein Hinweis:
Auf der Registerseite im Mobile-Theme wird mit Sternchen für die Pflichtfelder gearbeitet. Trotzdem steht da, man soll die “fett beschrifteten Felder ausfüllen”, so ist es halt in der Desktop-Version. Muss aber heißen: “Bitte alle mit Sternchen beschrifteten Pflichtfeder ausfüllen”:slight_smile:

Lässt sich aber einfach in der lang-datei und userbilling.tpl mit ner zweiten COMPLETE_MARKED_FIELDS ändern.[/QUOTE]

Das ist übrigens schon im Bugtracker eingetragen worden: https://bugs.oxid-esales.com/view.php?id=5653
Kannste dann einfach in deinem Pull-Request referenzieren.

[QUOTE=Marco Steinhaeuser;152257] Kannst Du das als Pull Request schicken?

Danke und Gruß,[/QUOTE]
Lieber nicht, die Leute verstehen mich ja manchmal noch nicht mal, wenn ich was auf Deutsch schreibe:)

hi oxid_on_mac

so dann komme ich jetzt mal hierher, hast mir ja den Verweis hierhin gegeben , )

also auch bei mir das Problem:

hier meine Ausführungen.

ich habe hier folgendes Problem mit dem mobile Template.

System:

Oxid PE 4.9.1
mobile Template 1.3
PHP 5.4.24

Für den Shop ist SSL aktiviert.

Sobald man auf den 2. Bestellschritt im mobile Template (auch bei der Original-Template Version) geht
erhält man ein Warnhinweis das das SSL Zertifikat unsicher ist.

Wenn ich im Quellcode nachsehe (mit FireFox Plugin mobile Tester)
sehe ich auch das z.B. die Links für “Mein konto” etc. (also die Links in der Services.tpl)
auf http:// verweisen anstelle von https://

Ich habe testweise alle Links einmal in der Bestellschritt 2 Seite fest vorgegeben, und
alle Verweisungen und Links haben dann auch https://, dennoch erscheint der Warnhinweis.

Eigenartig ist auch, dass bei iOs Geräten und auch
mit FireFox Plugin mobile Tester alles ok ist, und kein Warnhinweis erfolgt.
Bei allen anderen Smartphone Geräten (Android, Win), wird die css-Datei nicht sauber geladen, d.h. überhaupt nicht.

Support ist kontaktet, Antwort bisher, dass die Links nicht korrekt im Basis Desktop Shop sind.
Frage stellt sich mir hier:

  1. Warum gibt es Extra-Templates für den mobilen Bereich (diese werden ja auch geladen)?
  2. Warum generiert der Platzhalter im mobilen wie im Desktop-Shop bei uns unterschiedliche Links (einmal http: einmal https://)?

Als weiteren Test habe ich in der config-Datei auch beim Parameter für die Standard-URL https:// eingesetzt, dann
setzt Oxid auch in allen Seiten die Links korrekt auf https://, nur dann erfolgt immer
noch der Warnhinweis bei den nicht iOS Geräten.
: (

Ich hoffe jemand kann helfen
Gruss
Brian Heyse

[QUOTE=bheyse;153284]hi oxid_on_mac

so dann komme ich jetzt mal hierher, hast mir ja den Verweis hierhin gegeben , )

[/QUOTE]

Ja aber zum durchlesen:D . Wie schon geschrieben, iOS-Geräte sind ebenfalls von dem Problem betroffen. Einfach #11 durchführen!

[QUOTE=oxid_on_mac;153285]Ja aber zum durchlesen:D . Wie schon geschrieben, iOS-Geräte sind ebenfalls von dem Problem betroffen. Einfach #11 durchführen![/QUOTE]

#11 hatte ich schon gemacht.
nur mit dem feinen unterschied mit ios kann ein kunde den bestellvorgang abschliessen , )

info:

selbst wenn ich alle Links fest codiere also anstelle Platzhalter eher mit /
und dann mir den quellcode anschaue der dann null http// links hat
geht es nicht!

war eben auf demoshop auch dort weiterhin dasselbe Problem !

:mad:

Bei mir ist ebenfalls noch das Problem, auch wenn ich beim Webfont das http(s) davor wegnehme

Also nochmal:

Ich habe nun das Template sogar in einer Responsive Umsetzung, sprich gar kein Mobile Template mehr und es kommt trotzdem diese Fehlermeldung. Das ist eine absolute Katastrophe. Ich habe sogar eine Seite komplett händisch, jeden Link auf https gesetzt. Im Quellcode kann man auch nachschauen das es keine reine http:// Verlinkung mehr gibt und trotzdem kommt die Fehlermeldung.

Bin einfach nur verzweifelt. Von meinem Anbieter all-inkl.com bekomme ich lapidar die Aussage das Sie keine Smartphones zum testen haben und somit den Fehler nicht beheben können … Der Fehler würde bei mir liegen. Aber was kann ich noch mehr machen als alle Links auf https zu setzen.

Im Chrome Desktop gibts ein grünes Schloss, die selbe Seite auf dem Smartphone/Tablet mit dem Chrome gibts ein rotes Schloss mit der Fehlermeldung …

Ihr könnt es gerne hier testen: www.padaja.de