Mod_rewrite rote farbe nach einem äußeren Server gebracht wurde

hallo, nach dem ich Oxid nach äußere Server gebrach habe, habe die Apache mod_rewrite Modul in rote Farbe, alle anderen sind mit Grün Farbe… .

Bei OXID Diagnose bekomme dieses Fenster,

ich habe in Forum vielen Artikel, die über dies Theme sprecht gelesen, aber die Lösungen die auf sie wurde geschrieben, Beispiel der tmp Verzeichnis Leer machen, aber habe mich nicht geholfe…

Meine Root Verzeichnis habe so geschrieben,

Options +FollowSymLinks
RewriteEngine On
RewriteBase /kalamulur/source
AddHandler application/x-httpd-php74 .php

<Directory >
    Options Indexes FollowSymLinks
    AllowOverride All
    Require all granted
</Directory>

Als ich in meine Rechner oxid installiert und diese Probleme kamme, ich habe mit diesen schritten die probleme gelöst…

1 - In der Root .htaccess schreibt

      RewriteEngine on

2 - in /etc/apache2/sites-available in der Datei 000-default.conf habe geschrieben,

      <Directory /var/www/html>
          Options Indexes FollowSymLinks
          AllowOverride All
          Require all granted
      </Directory>

3 - dann auf der Terminal schreibt,

      sudo a2enmod rewrite 

      sudo a2enmod actions 

      sudo systemctl restart apache2

und die probleme wurde gelöst…die probleme ist das kann nicht mache auf der Webserver…, ich habe eine E-mail an dem Webserber geschrieben wo sage gleiche wie hier geschrieben habe…Vielleicht sie können eine Vorschlag mir geben…

Gelösen! :grinning:

Ich hatte zwei Probleme, eine war meine Erste Frage, die Zweite war, das auf der Start Seite die Links nicht funktioniert…

Die Lösung von Beiden,

In der Datei /source/.htaccess, verändert die Zeile von RewriteBase /oxid/source nach RewriteBase / kalamulur mit leer Platz…

1 Like