Nach Umzug Probleme ,mit Zend

Aloha,

ich hab gerade versucht den 4.4.8 auf einen anderen root zu ziehen um dort in gesicherter Umgebung das Update auf 5.6 durchzuführen. nach der trockenen Installation läuft alles, sobald ich die Daten vom existierenden Shop drüber schiebe bekomme ich beim aufrufen des Warenkorbes “Zend Optimizer not installed”. Ich hab die Daten binär gezogen und auch drauf kopiert. Ein test mit ´xampp auf meinem Rechner führte zum selben Ergebnis. im alten Shop läufts allerdings… wo ist mein Fehler?

da: Zend Optimizer not installed

diesen Fehler weis ich wohl zu deuten, ABER bei der Installation hat er den noch als gegeben angesehen und vor dem kopieren der alten Shopdaten funktioniert ja auch alles. Wie also deinstalliert sich Zend?

ich nehme an, es haldelt sich um eine CE.
CE braucht kein Zend, nur PE/EE und einige Module. So hast Du vermutlich ein gekauftes Modul, welches Zend erfordert.
Zend ist so etwas wie ein Zusatzmodul für deb Webserver und muss im 99% der Fälle manuell nachinstalliert werden. Außer man ist bei einem profi-Hoster, was bei lokalen XAMPP ja nicht der Fall ist.

das einzige Modul wäre PayPal, aber auch wenn ich dies deaktiviere komme ich zum selben Problem… Kann ich sämtliche in Frage kommenden Module irgend wo zentral ersehen und ggf abschalten?

unterschiedliche php-versionen?

bis php 5.[B]2[/B].x -> Zend Optimizer
ab php 5.[B]3[/B].x -> IonCube Loader

Entsprechende Module funktionieren nur für die jeweilige Version.

ja, der alte hat 5.2 der neue 5.3…

[QUOTE=oldmanatwork;88328]ja, der alte hat 5.2 der neue 5.3…[/QUOTE]

Jo - und da haben wir’s schon. Du brauchst alle von Dir installierten Module in einer Version, die statt für PHP5.2 nun für PHP5.3 verschlüsselt wurde. Bitte wende Dich für Paypal an den Helpdesk per Skype oder schick eine Nachricht über eFire rein. Für andere Module, die ggf. installiert sind, solltest Du die Hersteller ansprechen.

Gruß

paypal rausgeworfen, nun klappt das so weit schon mal… [B][U]VIELEN DANK! [/U][/B]dann werd ich mich mal an das update zum 4.6 auf dem testroot wagen…

[QUOTE=updown;88327]

bis php 5.[B]2[/B].x -> Zend Optimizer
ab php 5.[B]3[/B].x -> IonCube Loader
[/QUOTE]

bis php 5.[B]2[/B].x -> Zend Optimizer
ab php 5.[B]3[/B].x -> [B]ZendGuard Loader[/B]

IonCube ist eine andere Verschlüsselungsart, hat zwar den ähnlichen Effekt, ist aber mit Zend weder verwandt noch verschwägert.

[QUOTE=Hebsacker;88477]bis php 5.[B]2[/B].x -> Zend Optimizer
ab php 5.[B]3[/B].x -> [B]ZendGuard Loader[/B]

IonCube ist eine andere Verschlüsselungsart, hat zwar den ähnlichen Effekt, ist aber mit Zend weder verwandt noch verschwägert.[/QUOTE]

Absolut korrekt, Danke für die Korrektur!