Neue Boxen in Avengers Powertemplate einbinden?

Hallo,

ich experimentiere gerade mit dem tollen Powertemplate von Avenger herum. Im Moment schaffe ich es einfach nicht neue Boxen einzubinden. Meine Vorstellung von den Konzept des Templates ist, dass ich mich bloß an die Namenskonvention halten muß und es sollte funktionieren.
Ich habe jetzt zwei Boxen erstellt und dafür jeweils eine tpl-Datei angelegt und im Ordner boxes abgespeichert: box_main_navi.tpl und box_shipping_info.tpl. Jetzt versuche ich jetzt die Boxen in der _index.tpl mit [{$box_MAIN_NAVI}] und [{$box_SHIPPING_INFO}] einzubinden … und erhalte keine Ausgabe.
Liege ich mit meiner Annahme der Funktionsweise völlig daneben oder was läuft hier falsch?
Den tmp-Ordner hab ich auch sicherheitshalber geleert … ohne Erfolg.

[QUOTE=SvenA;26913]Hallo,

ich experimentiere gerade mit dem tollen Powertemplate von Avenger herum. Im Moment schaffe ich es einfach nicht neue Boxen einzubinden. Meine Vorstellung von den Konzept des Templates ist, dass ich mich bloß an die Namenskonvention halten muß und es sollte funktionieren.
Ich habe jetzt zwei Boxen erstellt und dafür jeweils eine tpl-Datei angelegt und im Ordner boxes abgespeichert: box_main_navi.tpl und box_shipping_info.tpl. Jetzt versuche ich jetzt die Boxen in der _index.tpl mit [{$box_MAIN_NAVI}] und [{$box_SHIPPING_INFO}] einzubinden … und erhalte keine Ausgabe.
Liege ich mit meiner Annahme der Funktionsweise völlig daneben oder was läuft hier falsch?
Den tmp-Ordner hab ich auch sicherheitshalber geleert … ohne Erfolg.[/QUOTE]
Nun, da fehlt noch ein wichtiger Schritt: man muss Smarty mitteilen, dass es das HTML-Ergebnis eines Templates unter einem bestimmtem Namen zur Verfügung stellen soll…

Diese Mitteilung geschieht in “[B]tpl/boxes/_boxes.php[/B]”.

Dort musst Du

  box_define($this,'main_navi');
  box_define($this,'shipping_info');

hinzufügen, dann sollte das funktionieren.

Ah, da hab ich die Feinheiten übersehen.
Jetzt funktioniert es.
Vielen Dank!
Eine tolle Geschichte ist das. :slight_smile: