Neue PHP Version & "D3 Google Analytics Modul"

Hallo

ich verwende

  • PHP Version 5.4.4-14+deb7u11
  • Zend Guard Loader

von D3 installiert

  • Modul-Connector
  • d3skrill 3.0.6.1 CE

und das funktioniert auch fehlerfrei.

Jetzt wollte ich Das D3 Google Analytics Modul installieren und bekomme beim precheck folgenden Fehler:

(ROT) Server verwendet PHP Version zwischen 5.2.0 und 5.4.200
(ROT) Zend Optimizer (PHP 5.2) oder Zend Guard Loader (PHP 5.3, 5.4) installiert

Wenn ich das Modul trotzdem aktiviere erhalte ich im Shop am ende der Seite folgenden Fehler:

Fatal error: Call to a member function getValue() on a non-object in /var/www/oxid-shop/tmp/smarty/65a82c1404a9bfe804d1363485ec4361^%%C6^C62^C62ACC74%%d3ga_universal_adwordscode.tpl.php on line 5

Kann das Modul über den Admin wieder deaktivieren alles ok.
Kennt jemand den Fehler oder hat jemand eine Version ab 5.4.200 ???

Gruß der Chris

[QUOTE=Happy-Chris;147671]Hallo

ich verwende

  • PHP Version 5.4.4-14+deb7u11
  • Zend Guard Loader

von D3 installiert

  • Modul-Connector
  • d3skrill 3.0.6.1 CE

und das funktioniert auch fehlerfrei.

Jetzt wollte ich Das D3 Google Analytics Modul installieren und bekomme beim precheck folgenden Fehler:

(ROT) Server verwendet PHP Version zwischen 5.2.0 und 5.4.200
(ROT) Zend Optimizer (PHP 5.2) oder Zend Guard Loader (PHP 5.3, 5.4) installiert

Wenn ich das Modul trotzdem aktiviere erhalte ich im Shop am ende der Seite folgenden Fehler:

Fatal error: Call to a member function getValue() on a non-object in /var/www/oxid-shop/tmp/smarty/65a82c1404a9bfe804d1363485ec4361^%%C6^C62^C62ACC74%%d3ga_universal_adwordscode.tpl.php on line 5

Kann das Modul über den Admin wieder deaktivieren alles ok.
Kennt jemand den Fehler oder hat jemand eine Version ab 5.4.200 ???

Gruß der Chris[/QUOTE]

Hallo Chris,

hast Du vom Google Analytics-Modul schon die aktuelle Fassung vom Montag (Version 3.1.0.2)? Darin ist der Smarty-Fehler behoben.

Fehler in der Systemprüfung sind mir nicht bekannt. Evtl. kannst Du uns ja mal direkt kontaktieren, dass wir uns das auf Deinem Server ansehen können.
Wenn Du Dir sicher bist, dass die Systemanforderungen erfüllt sind, steht dennoch Nichts gegen eine Installation.

Nachtrag:

die Version “5.4.200” gibt es aktuell nicht :slight_smile:
Wir haben dort nur eine sehr hohe Zahl (200) eingetragen, um sicher zu stellen das alle künftigen PHP 5.4-Versionen von der precheck akzeptiert werden. Mit der vorliegenden Version auf deinem Server (5.4.4) sollte also eigentlich alles in Ordnung sein.
Eventuell kann unsere precheck die PHP-Version nicht richtig auslesen und zeigt darum diese (Falsch)meldung.
Uns sind bisher jedoch noch keine andere Fälle bekannt, in denen die Prüfung fehlschlägt

Vielen Dank nochmal.
Habe die neue Version installiert und es geht daten werden perfekt zu Google übertragen. Sehe auch schon die ergebnisse. :slight_smile:

Der Precheck geht immer noch nicht, aber das ist nicht das Probelm.
Ich danke euch …