Newsletteranmeldung im Mail Footer doppelt

Hallo,

Benutze CE Azure 4.5.2
In dem e-mail, wo man den link zur Newsletter-Registrierung anklicken kann, steht die Adresse usw. gleich 2x übereinander.
Einmal im normalen Textformat, und nochmal drunter im neuen Stil (schön eingerahmt).
Vermute, dass es sich um den e-mail-footer handelt.

Wie und wo kann ich die obere Kennzeichnung entfernen?

Bitte um Hilfe,
Alex :confused:

Die Templates für den email-body finden sich im admin unter
Kundeninformationen -> CMS-Seiten

Achtung, es gibt diese Seiten jeweils einmal als Nur-Text (Plain) und einmal als HTML-Vorlage, also beide ändern. Und danach /tmp leeren nicht vergessen.

Danke, aber dort steht alles richtig drinnen.
Habe überall unsere Bezeichnung einmal angegeben.
Bei den anderen mails, wie z.B. Bestellungen usw. ist überall ein footer am Schluss.
Nur beim Newsletter-mail doppelt.

in dem Ordner out/azure/tpl/email/html/
gibts ein Template für Newsletter Opt-In: [B]newsletteroptin.tpl[/B], das sieht so aus:

[{ assign var="shop"      value=$oEmailView->getShop() }]
[{ assign var="oViewConf" value=$oEmailView->getViewConfig() }]
[{ assign var="user"      value=$oEmailView->getUser() }]

[{include file="email/html/header.tpl" title=$shop->oxshops__oxname->value}]

    <p style="font-family: Arial, Helvetica, sans-serif; font-size: 12px;">
        [{ oxcontent ident="oxnewsletteremail" }]
        <br><br>
        [{ oxcontent ident="oxemailfooter" }]
    </p>

[{include file="email/html/footer.tpl"}]

D.h. da wird ein mal die CMS Seite oxemailfooter geladen und danach footer.tpl “included”, welche die CMS Seite oxemailfooter nochmal (!) lädt:


        <div style="border: 1px solid #3799B1; margin: 30px 0 15px 0; padding: 12px 20px; background-color: #eee; border-radius: 4px 4px 4px 4px; linear-gradient(center top , #FFFFFF, #D1D8DB) repeat scroll 0 0 transparent;">
            <p style="font-family: Arial, Helvetica, sans-serif; font-size: 12px; margin: 0; padding: 0;">
                [{ oxcontent ident="oxemailfooter" }]
            </p>
        </div>

    </div>

  </body>
</html>

Und der Rahmen etc kommt von dem <div style="…"> drum rum in der footer.tpl

Ich würde sagen, ein mal das [{ oxcontent ident=“oxemailfooter” }] aus [B]newsletteroptin.tpl[/B] löschen und das Problem wäre dann geklärt :slight_smile:

viele Grüße

Macht das Sinn? Ist für mich ein Bug…

Eintragen?