Ordner für CMS-Seiten festlegen? Sortierung Menü?


#1

Hallo Leute,
auch wenn ich wohl wie ein Anfänger wirken werde,
ich brauche mal Nachhilfe im aktuellen Oxid-Shop.

Bei der Neuinstallation des 6er-Shop habe ich bisher 2 Kategorien für die CMS-Seiten erstellt und kann diese Zugehörigkeit je nach CMS-Seite festlegen…
Soweit so gut,… Kann mir aber mal jemand sagen wo ich die “Ordner” festgelegt habe?
Ich bin Hobby-Admin, finde daher dieses Menü einfach nicht wieder…

Zweitens,
wie sortiere ich die Einträge im oberen Menü (neben “Startseite” im Flow-Theme)?
Wenn ich eine CMS-Seite als Kategorie festlege,
wird diese als Eintrag in dem Menü hinzugefügt,
doch wie kann ich diese Reihenfolge selbst festlegen?
Das Menü ist dann eine Mischung aus Kategorien und CMS-Seiten.
Wie sortiere ich diese?

Den Punkt “einfügen vor…” (bei CMS-Seiten) hab ich durchaus gefunden,
doch wie sortiere ich, wenn die CMS-Seite ganz rechts stehen soll?

Ich hoffe ihr könnt mir helfen :slight_smile:


#2

Die “Ordner” sind fix, kann man nicht ändern. Die CMS-Seiten lassen sich besser sortieren wenn man nicht den Punkt “Kategorie” auswählt sondern “Snippet” und die CMS-Seite direkt in den Langtext einer Kategorie einfügt:

    [{oxifcontent ident="oxorderinfo" object="oCont"}]
        <div>[{$oCont->oxcontents__oxcontent->value}]</div>
    [{/oxifcontent}]

Alternativ könnte man den Inhalt auch gleich in den Langtext schreiben. “Leere Kategorien nicht anzeigen” sollte deaktiviert werden damit die Kategorie keine Artikel braucht.


#3

Hallo!
Leider sind dann aber unterhalb die Felder mit “Produkte anzeigen” …
G
Michael


#4

Welche Felder?


#5

Hallo!
Vielleicht habe ich auch etwas falsch verstanden … Ich habe in den Langtext der Kategorie “Information (nur zu Testzwecken vorhanden, selber Inhalt wie Wissenswertes)” mit HTML die Bilder als Links eingegeben (sonst steht halt immer “Produkte ansehen” darunter obwohl es sich ja um Infos handelt) und die 4 Unterkategorien definiert.
Bei mir sieht es dann halt so aus:


(Die rot eingerahmten Felder habe ich gemeint …)
Ich bin dann wieder zurückgerudert und habe alles bei CMS-Seiten belassen. Hat den einzigen Nachteil, dass eben kein Dropdown-Menü im Kategorie-Reiter ist … ( hier der Link zur Website Die Kategorie "Information ist versteckt. )

LG
Michael


#6

Versuchst du zufällig eine Kategorien-ähnliche Struktur aus CMS Seiten aufzubauen? Rein als info seiten und komplett ohne Artikel?


#7

Hallo!
Genau das war meine Idee…
LG
Michael


#8

Probiere mal dieses Modul aus:


#9

Hallo!
Danke vanilla_thunder! Das hätte ich vorher schon brauchen können…
Leider wird dadurch aber kein Dropdown Menü wie in den “echten” Kategorien erzeugt …
Ist das so bekannt, oder habe ich was falsch gemacht?
LG
Michael


#10

Dropdown wird erst dann erzeugt, wenn man [{block name="cmsmenu_dropdown"}] ...[{/block}] wie im Abschnitt “TPL Anpassung” beschrieben, einfügt und tmp/smarty/ leert.
Es müssen natürlich auch entsprechende parent/child Beziehungen bei den CMS Seiten eingestellt werden.
Sollte am Ende dann wie das Menü “Informationen” hier aussehen


#11

Danke nochmal!
Funktioniert super. Es gibt jetzt nur irgendwie ein Problem auf einigen mobilen Endgeräten. Wenn auf die Parent-Kategorie getippt wird, dann wird hinter die aktuelle Seite nur ein “…/#” angehängt, statt auf diese CMS-Kategorie weiter zu leiten.
G
Michael


#12

Hallo!
Ich habe mir mal den Quelltext anzeigen lassen und da sind zwischen echter Kategorie und CMS-Kategorie unterschiede (keine Ahnung ob das dafür verantwortlich ist):

view-source:https://www.weingut-wiesinger.at/

Hier steht bei Zeile 271 (CMS Kategorie):
a href="#" class=“dropdown-toggle visible-xs” data-toggle=“dropdown” role=“button” aria-haspopup=“true” aria-expanded=“false”

Im Vergleich bei Zeile 292 (Echte Kategorie):
a href=“http://www.weingut-wiesinger.at/Unser-Sortiment/?force_sid=22ervj6v1g3ft0bk72k8ua3mo2” class=“dropdown-toggle” data-toggle=“dropdown”

Ist aber interessant, dass es auf PCs funktioniert…

G
Michael


#13

Hallo!
Ich befürchte, dass ich in
/application/views/flow/tpl/widget/header/categorylist.tpl
hier


noch etwas ändern muss …
Leider kenne ich mich damit nicht aus.
G
Michael


#14

Du hast da zwei andere Probleme:


und

Es liegt nicht zwangsweise genau daran, aber diese Probleme müssen wir als erstes ausschließen.
Und ich teste derweil das Modul mal in einem aktuellen Flow Theme.


#15

Danke für deine Mühe!
Für den ersten Punkt habe ich jetzt das gemacht:


ändert aber nicht wirklich was.

Den zweiten Punkt kann ich irgendwie nicht nachvollziehen, da es bei mir einwandfrei funktioniert.

Soll ich vielleicht mal irgendwelche Dateien durch die Originale ersetzen, denn außer das im Modul Beschriebene und ein paar Phrasen in den lang-Dateien habe ich eigentlich, mangels nötiger Kenntnis, sicherheitshalber nichts angerührt.

G
Michael