OXID 492 von xampp umziehen auf onlineserver

Hallo,

ich habe jetzt viele Anleitungen gelesen, wie ich den Shop von xampp auf online umziehe. Aber irgendwie läuft das nicht. Puh.

Ich hatte das auch schon mal hinbekommen in der Testphase, jetzt will ich das mit der Version 492 machen.

Gibt es da Änderungen oder ein Kurzanleitung?

Hallo Stickmaus,

das funktioniert genau noch so wie früher.
Mit “geht nicht” können wir hier im Forum immer nicht so viel anfangen. Kannst Du den Satz größer machen?

Gruß

Hallo Marco,

ich habe es nach dieser Empfehlung gemacht

Hoch und runter, Immer wieder kommen beim Einspielen des Dump Fehlermeldungen.
Leider nicht aufgeschrieben, da ich den ganzen Tag schon rumprobiert habe und ich einfach den Rechner ausgemacht habe. Jetzt muss ich erstmal was anderes machen.

Ich melde mich später.

Meine Empfehlung: Kochen hilft immer in solche Fällen :wink:

Hallo Marco,
so jetzt scheint es zu funktionieren, obwohl es bei der Datenbankeinspielung Fehlermeldungen gab. Jetzt werde ich erstmal ein wenig rumspielen mit den online-Einstellungen. Und dann noch mal eine saubere Installation testen.

Ich habe mir gerad das OXID-Buch bestellt


Ich denke, da werden sich viele Fragen von allein lösen und gehe Euch nicht so sehr auf den Zeiger.

LG Torsten

Hallo
Ich habe nach der Anleitung (http://wiki.oxidforge.org/Tutorials/Einen_Oxid-Shop_umziehen_lassen) den Umzug vorgenommen. SQL Dump mit phpMyAdmin erstellt wo alle einträge mit oxv_ abgehagt waren, erstellt und benutzt. Config.inc.php mit der neuen Datenbank angepasst. Jetzt bekomme ich immer nur shop offline angezeigt. temp sind gelöscht und an die views komme ich ja nicht ran da der admin ja nicht funktioniert.

Die andere Richtung eines anderen funktionierenden Shops vom Server ins Xampp funktioniert einwandfrei. Was mache ich falsch oder hab ich übersehen?

Xampp Version 5.6.3
Gehostet wird bei 1und1
Shopversion CE 4.9.2

lg

Was steht im Exception-Log?

Hallo, also jetzt hab ich die Exception-Log endlich gefunden. Sorry bin Neuling und muß immer erstmal nach lesen worum es geht.

Connection Adress -->
Connection Error -->

oxConnectionException-oxException (time: 2015-01-19 17:15:08): [1146]: mysql error: [1146: Table ‘dbxxxxxxxxx.oxv_oxcountry_en’ doesn’t exist] in EXECUTE (select oxtitle from oxv_oxcountry_en where oxisoalpha2 = ‘de’, ) with user dboxxxxxxxxx

Stack Trace: #0 /ics_de/core/adodblite/adodbSQL_drivers/mysql/mysql_driver.inc(369): adodb_throw(‘mysql’, ‘EXECUTE’, 1146, ‘Table ‘dbxxxxxx…’, ‘select oxtitle …’, false, Object(object_ADOConnection))
#1 /ics_de/core/adodblite/generic_modules/pear_module.inc(70): mysql_driver_ADOConnection->do_query(‘select oxtitle …’, -1, -1, false)
#2 /ics_de/core/adodblite/generic_modules/pear_module.inc(56): pear_ADOConnection->GetRow(‘select oxtitle …’, false, true)
#3 /ics_de/core/oxlegacydb.php(83): pear_ADOConnection->GetOne(‘select oxtitle …’, false)
#4 /ics_de/application/controllers/admin/oxadminview.php(519): oxLegacyDb->getOne(‘select oxtitle …’, false, false)
#5 /ics_de/application/controllers/admin/oxadminview.php(247): oxAdminView->_getCountryByCode(‘de’)
#6 /ics_de/application/controllers/admin/oxadminview.php(204): oxAdminView->getServiceUrl()
#7 /ics_de/core/oxview.php(195): oxAdminView->addGlobalParams()
#8 /ics_de/application/controllers/admin/oxadminview.php(173): oxView->init()
#9 /ics_de/core/oxshopcontrol.php(407): oxAdminView->init()
#10 /ics_de/core/oxshopcontrol.php(338): oxShopControl->_initializeViewObject(‘login’, NULL, NULL, NULL)
#11 /ics_de/core/oxshopcontrol.php(126): oxShopControl->_process(‘login’, NULL, NULL, NULL)
#12 /ics_de/core/oxid.php(40): oxShopControl->start()
#13 /ics_de/index.php(26): Oxid::run()
#14 /ics_de/admin/index.php(27): require_once(’/homepages/13/d…’)
#15 {main}

Das zieht sich durchs log mit einigen oxv_ einträgen. Hab jetzt mal nur den eintrag kopiert da die anderen eigentlich identisch sind von der Fehlermeldung.

Mein Gott wegen einem blöden Haken beim Datenbank Dump 6 Tage verloren!
Fehler behoben hier mit!

http://forum.oxid-esales.com/showthread.php?t=2512