Oxid 6.1 Paypal checkout crasht fcgid prozess

Habe die letzten Tage mühselig nen 4.9er Shop nach dem Update von Debian 8 zu Debian 10 wieder versucht zum laufen zu bringen aber hatte keinen Erfolg ne funktionierende PHP 5 version zu bauen, mit dem der Shop wieder laufen würde. Weder Shop noch Backend hat geladen und nur 500er ausgespuckt.

Also habe ich ne neue 6.1er installation gemacht, die Daten per MySQL vom 4.9er shop importiert, die Versions upgrades gemacht. Läuft soweit, Bilder und alle Daten sind noch vorhanden, aber wenn ich per Paypal zahlen will crasht mir der FCGID prozess ohne nützlichen Fehler weg.
Hier den Error den ich sehe:

[Thu Jan 23 23:24:43.402888 2020] [fcgid:warn] [pid 2759] (104)Connection reset by peer: [client 82.136.89.84:59136] mod_fcgid: error reading data from FastCGI server, referer: https://store51.ch/index.php?force_sid=e4b30ecf580df7cc4775902232e67f3f&cl=payment
[Thu Jan 23 23:24:43.402928 2020] [core:error] [pid 2759] [client 82.136.89.84:59136] End of script output before headers: index.php, referer: https://store51.ch/index.php?force_sid=e4b30ecf580df7cc4775902232e67f3f&cl=payment
[Thu Jan 23 23:25:49.619872 2020] [fcgid:warn] [pid 2757] (104)Connection reset by peer: [client 82.136.89.84:59153] mod_fcgid: error reading data from FastCGI server, referer: https://store51.ch/index.php?cl=payment&force_sid=e4b30ecf580df7cc4775902232e67f3f
[Thu Jan 23 23:25:49.619910 2020] [core:error] [pid 2757] [client 82.136.89.84:59153] End of script output before headers: index.php, referer: https://store51.ch/index.php?cl=payment&force_sid=e4b30ecf580df7cc4775902232e67f3f

Ich habe als einzige Währung CHF eingestellt. Lustigerweise loggt mir der Shop überhaupt nichts ins oxideshop.log file :frowning:

Jemand ne Idee?

Hat php fcgid eventuell noch einen eigenen Fehler Log?
Oder kannst du eine andere PHP Runtime auswählen? FPM oder CGI oder sowas.
Ich hatte schon mal Probleme mit PHP FCGI, aber nicht direkt im Zusammenhang mit Paypal

Habe das Problem schlussendlich in syslog gefunden. Dort wurde ein seg fault geloggt dass php-cgi ein Fehler in libssl.1.1.0 verursacht hat. Habe PHP neu kompiliert mit den System OpenSSL libraries und das hat geklappt.

Mein phpbrew Kommando, welches funktioniert hat:
phpbrew install -j $(nproc) 7.1.33 +default +mysql +fpm +iconv +gd +openssl=/usr – --with-jpeg-dir=/usr

1 Like