OXID CE 4.9.0 Modul Entwicklung

Hallo :slight_smile:

teste gerade ein älteres Modul was vor der OXID Version 4.9.0 reibungslos funktionierte.

Leider funktioniert das Modul in der neusten OXID Version nicht mehr. Ich suche eine Dokumentation oder Erläuterung wie die OXID 4.9.0 für Module die Verzeichnisstruktur erwartet z.B. für Sprachkonstanten und Admin Templates?

Unter http://www.oxidforge.org/documentation oder im Forum bin ich leider zu diesem Thema nicht fündig geworden :frowning:

Vielleicht weiß jemand von euch mehr.

Viele Grüße
indianer3c

unter “Newbies”? wirklich?

Seitdem ich Anfangs im Forum (August 2013) von Marco ein bisschen eingenordet wurde, traue ich mich nicht mehr in anderen Threads zu posten. Passt dieses Thema woanders besser z.B. “'Entwickler” oder “Module”?
Kann jemand helfen?

Konnte jetzt http://forum.oxid-esales.com/showthread.php?p=149655#post149652 finden, dass sich der Pfad für die Admin Sprachkonstanten geändert hat /modules/modulname/views/admin/ aber so richtig klappen will es bei mir nicht.

Hi,
hast du im Modul zufällig einen applications-Ordner?

[QUOTE=indianer3c;150892]Seitdem ich Anfangs im Forum (August 2013) von Marco ein bisschen eingenordet wurde,[/QUOTE]

Hey, sag das nicht so! :slight_smile:
Schau mal, hilft Dir das hier weiter? Der Support für die älteren Module wurde mit der 4.9/5.2 eingestellt:

Gruß

@Martin

Danke! Musste meine Sprachkonstanten ins Verzeichnis /modules/Modulname/application/views/admin/de/module_options.php legen damit im Admin die Sprachkonstanten angezeigt werden. Oder worauf wolltest du hinaus?

Jetzt suche ich noch kleinere Fehler.

@Marco
danke dir!

[QUOTE=indianer3c;150937]Oder worauf wolltest du hinaus?
[/QUOTE]

Im Grunde schon darauf, wobei im Modul m.E. kein application-Ordner sein müsste/sollte. So zB. wäre es m.E. korrekt: modulname/views oder modulname/controllers.