"oxid-esales/oxideshop-metapackage-ce": "^v6.1.0",


#1

Wo trage ich das ein in der composer.json?

{
    "name": "oxid-esales/oxideshop-ce",
    "description": "This package contains OXID eShop CE source code.",
    "type": "oxideshop",
    "keywords": ["oxid", "modules", "eShop"],
    "homepage": "https://www.oxid-esales.com/en/home.html",
    "license": [
        "GPL-3.0-only",
        "proprietary"
    ],
    "require": {
        "php": "^7.0",
        "phpmailer/phpmailer": "^v5.2.27",
        "smarty/smarty": "^v2.6.31",
        "doctrine/dbal": "^v2.5.13",
        "doctrine/collections": "^1.4.0",
        "monolog/monolog": "^v1.23.0",
        "psr/container": "1.0.*",
        "symfony/config": "~2.8|~3.0",
        "symfony/dependency-injection": "^3.1"
    },
    "require-dev": {
        "oxid-esales/flow-theme": "^v3.0.2",
        "oxid-esales/oxideshop-doctrine-migration-wrapper": "^v2.1.2",
        "oxid-esales/oxideshop-db-views-generator": "^v1.2.0",
        "oxid-esales/oxideshop-demodata-installer": "^v1.1.2",
        "oxid-esales/oxideshop-composer-plugin": "^v2.0.3",
        "oxid-esales/oxideshop-unified-namespace-generator": "^2.0.0",
        "oxid-esales/testing-library": "v5.0.3",
        "oxid-esales/coding-standards": "^v3.0.5",
        "oxid-esales/coding-standards-wrapper": "^v1.0.0",
        "incenteev/composer-parameter-handler": "~v2.0",
        "oxid-esales/oxideshop-ide-helper": "^3.0",
        "oxid-esales/azure-theme": "^v1.4.1"
    },
    "autoload": {
        "psr-4": {
            "OxidEsales\\EshopCommunity\\": "./source"
        }
    },
    "autoload-dev": {
        "psr-4": {
            "OxidEsales\\EshopCommunity\\Tests\\": "./tests"
        }
    },
    "minimum-stability": "dev",
    "prefer-stable": true,
    "scripts": {
        "post-install-cmd": [
            "Incenteev\\ParameterHandler\\ScriptHandler::buildParameters",
            "@oe:ide-helper:generate"
        ],
        "post-update-cmd": [
            "Incenteev\\ParameterHandler\\ScriptHandler::buildParameters",
            "@oe:ide-helper:generate"
        ],
        "oe:ide-helper:generate": [
            "if [ -f ./vendor/bin/oe-eshop-ide_helper ]; then oe-eshop-ide_helper; fi"
        ]
    },
    "extra": {
        "oxideshop": {
            "blacklist-filter": [
                "Application/Component/**/*",
                "Application/Controller/**/*",
                "Application/Model/**/*",
                "Core/**/*",
                "Internal/**/*"
            ]
        },
        "incenteev-parameters": {
            "file": "test_config.yml",
            "dist-file": "vendor/oxid-esales/testing-library/test_config.yml.dist",
            "parameter-key": "mandatory_parameters",
            "env-map": {
                "shop_path": "SHOP_PATH",
                "shop_tests_path": "SHOP_TESTS_PATH",
                "partial_module_paths": "PARTIAL_MODULE_PATHS"
            }
        }
    }
}

#2

“oxideshop-ce” ist eine Komponente von “oxideshop_metapackage_ce”. Was willst du denn genau machen, installieren oder updaten oder was anderes?


#3

gerne auf die neueste Version updaten. im BE steht Community Edition 6.0.2

Die neueste ist die 6.1.2 oder?


#5

Dafür musst die composer.json im Rootverzeichnis (da wo source und vendor liegen) editieren: https://docs.oxid-esales.com/developer/en/6.1/update/eshop_from_6x_to_6y/update_default.html


#6

Danke für die Hilfe.

Ich habe mich jedoch anders entschieden. Ich habe nun ein anderes deutsches Shopsystem installiert.