OXID Virtual Machine + ionCube with OXID PE


#1

Hello!
I have some problem with install ionCube. OXID throws me info that it need ionCube.

this is my personal.yml file:

it won’t work. PHP info shows there is no installed ionCube. I tried to add
’ioncube’ key to ‘php’ block like it is in ‘default.yml’ file but it won’t work to.
ZendGuard Loader is installed correct.

Any suggestions?
Thanks!


#2

Looks like you need to point to the correct pkg_url:

Also, ioncube as well as zend an the other stuff has to be within the php section of your personal.yml file, right? No clue why the other stuff is working correctly…

Listen, wouldn’t it be a better option to copy default.yml into personal.yml and to remove what you don’t need in personal.yml file? Just an idea :wink:


#3

Hmmmmm…
I thought that i know how provision works heh.

When in peronal.yml was in the same time:
zendguard:
install: true
and
ioncube:
install true

It throws me an error for ionCube:
TASK [ioncube : Stop execution of ansible and show how to proceed]
*************
default: fatal: [localhost]: FAILED! => {“changed”: false, “msg”: “Current ioncube integration does not support zendguard integration at the same time. Please disable support of ioncube (php.ioncube.install: false) or disable support of zendguard (php.zendguard.install: false).\n”}

I thought that default.yml and personal.yml are mergeing while proccess where personal.yml data override default.yml data.

Solution was to wrote in personal.yml only:
zendguard:
install: true
and after installation zendguard, remove it from personal.yml and add:
ioncube:
install true

and it’s works now.

My ‘default.yml’ file is without any changes. It’s like original.


#4

make sure ioncube is loaded before zendguard in php.ini