PayPal Modul Version 3.2.1-4.5.x-1 - Kein Abschluss möglich - Nur Fehlermeldung "URL to call is not valid."

Hallo zusammen,
ich hoffe Ihr könnt mir weiterhelfen.
Ich hab schon im PayPal Umstellung Thread geschrieben

Folgendes Problem:
Neues PayPal Modul installiert. Version 3.2.1-4.5.x-1
Läuft soweit alles, bis zu dem punkt wo ich PayPal als Zahlung auswähle.
Nach “Weiter zum nächsten Schritt” komme ich wieder bei Schritt 1 raus.
Roter Balken mit der Meldung: [I]URL to call is not valid.[/I]

Hat jemand eine Idee wie ich da weiterkomme, OHNE die PHP Version upzugraden?

Grüße
Artur

ecomponents hat für alle versionen eine lösung alles inkl.

…ganz so platt müsst ihr aber auch nicht für Eure Module werben…

Gibts denn irgendwo in einem Log eine genauere Fehlermeldung?

Gelöst!
Unglaublich aber wahr - ich war schon auf der richtigen Spur - allerdings hab ich den Fehler mit der Übergabe von Dashes in der URL nur für die PHP Version 5.3.2 gefunden nicht aber für die PHP Version 5.2.13
Hoster angerufen, der hat alle 5.2.x Möglichkeiten durchprobiert bis 5.2.5 - und siehe da - alles geht!
Trotzdem - danke an alle die sich die Mühe gemacht haben zu helfen.
Gruß Artur