Probleme mit Versandeinstellungen

Guten Morgen zusammen,

ich habe in einem aktuellen Shop die Versandarten neu eingerichtet:

Versandkostenregeln:

  • DHL Normal mit 4,90 Gebühr, Nur für DE, ab Menge 0 - 999999, einmal pro Warenkorb, 5,5 abs Preisaufschlag und Keine weiteren regeln berechnen,
  • DHL Normal mit frei, Nur für DE, ab Preis 20 - 999999, einmal pro Warenkorb, kein Preisaufschlag und Keine weiteren regeln berechnen,
  • DHL Express mit 9,90 Gebühr, Nur für DE, ab Menge 0 - 999999, einmal pro Warenkorb und Keine weiteren regeln berechnen

Bei allen drei Regeln keine Beschränkung bei Artikeln, Kategorie oder Benutzer und die Reihenfolge ist: DHL Normal frei, DHL Express, DHL Normal

Dann die Versandarten:

  • Normalversand mit DHL mit den Regeln DHL normal frei und DHL normal, keine Länder- und Benutzereinschränkung und die Zahlungsarten sind Rechnung und Nachnahme
  • Expressversand mit DHL mit den Regeln DHL Express, keine Länder- und Benutzereinschränkung und die Zahlungsarten sind Rechnung und Nachnahme

Hier ist die Reihenfolge Normalversand mit DHL, Expressversand mit DHL

Zu guter letzt die Zahlungsart Nachnahme:
Aufschlag sind 10 Euro, alle Benutzer (außer Blocked und Blacklist), Bei Basis für Preisaufschlag sind 1 bis 4 gesetzt, ab Bonitt 0, Einlkaufswert 0 - 10000 und Länderbeschränkung auf DE

Das Problem ist nun folgendes:
Auf dem 3. Warenkorbschritt erhalte ich (je nach Warenkorb) DHL Normalversand (kostenfrei oder mit 4,90 €) und DHL Expressversand. Jeweils mit den Zahlungsarten Rechnung und Nachnahme.
Die Nachnahmegebühren von 10 € bekomme ich aber nur bei Express und nicht Normalversand (hier in beiden Fällen, also frei und 4,90) .
Ich habe mir einmal das payment objekt ausgeben lassen, dieses hat bei Normalversand wirklich oxaddsum = 0 drinnen stehen.

Ich hoffe jemand weiß einen Rat oder einen tipp, Danke schon mal im Vorraus

viele Grüße
Sebastian