Product Export Stop Working

hi in the admin panel of oxid, the product export under service has stopped working.
First When I go to that page, select categories and other parameters, and click on start export button it shows above the number of products being exported during process and after exported it gave me a link. When I click on that click I am having exported products in my browser. But now suddenly it has stopped working. I am working on some related issue and I am sure that I have not edit any of the file related to it.

Even then I have replaced all files but couldn’t get it. When I press start export button, I cannot see any thing (which shows exported products and link). When I go to export directory, I can see the file but with 0 KB size.

What is wrong and how can I fix this,

Awais Qarni

check the file / folder permissions and set to 777 for evaluating

[QUOTE=Hebsacker;82611]check the file / folder permissions and set to 777 for evaluating[/QUOTE]

Hi Hebsacker thanks for your reply. But I am working on localhost. I am astonished by the behaviour of the system. Today I have set up another project on local host because previous one is still not working due to above mentioned problem.

Now In newly generated project the product export was working. I want to understand the flow of the product export so I put a die() e 448 in the dynexportbase class (prepareExport function) to check the $heaptable variable. I checked that, then I removed the die() from the file. But after that when I run the productexport it again stopped working.

I have deleted all files in temp folder, clear cookies and sessions of browsers but nothing happen? What is this behaviour? What should I do? Is this some kind of bug? Or I have to delete some file or any thing else to get rid off this problem?


Awais Qanri

did you refresh VIEWS after the change as well?

Backend -> Service -> Tools

OO Solved. This was due to the wrong entry in adminpanel->core settings->system->moduel for module entry. I was doing entry like


which is wrong.
I have written this because I saw the oxid module that was related to articles. On left side the oxarticle means it will find the oxarticle class in admin folder. So here put your own class name. I changed to above to


Due to above wrong entry my product listing and product export section went to off. This answer if for others who face the same problem