Serverfehler 500 noch bevor ich die Installation starten kann

Hallo zusammen,

vorweg erstmal, ich bin völlig neu, was OXID angeht, und habe versucht die eShop Community Edition auf meinem webserver zu installieren um mir die Software mal anzuschauen. Leider bin ich von vornherein schon auf einen “Serverfehler 500” gestoßen, der wohl irgendwie mit der .htaccess zu tun haben muss. Denn wenn cih die .htaccess vom Server lösche, bekomme ich den Anfangsbildschirm des Setups gezeigt, leider sind dann aber die Dateizugriffsrechte und der Apache mod_rewrite rot markiert.

Allerdings sagt mir meine phpinfo dass mod_rewrite geladen ist und die Dateirechte, habe ich so vergeben wie in der Anleitung steht.

Ich hoffe ihr könnt mir da helfen. :confused:

Gruß
m4ddy

Die Dateirechte haben nichts mit der htaccess zu tuen. Wahrscheinlich fehlen Schreibgrecht für die config.inc.php , out oder tmp Ordner.

Wegen htaccess:
500 ist ein sehr allgemeiner Fehler.
Da hilft nur Zeile (nicht die Spitzen Klammern <…>) für Zeile auskommentieren und testen, ob es dann geht.
ZB: +followSymLinks ist auf manchen Servern voreingestellt und es fehlen die Rechte dies per htaccess zu ändern.

GGf. auch die spitzen Klammern weg. Dann aber offene und geschlossene Anweisung.

Hallo MBa,

danke für die schnelle Antwort. Die Zugriffsrechte für die jweiligen Ordner hatte ich so vergeben wie hier beschrieben: http://wiki.oxidforge.org/Installation#Files_.26_Folder_Permission_Setup

In einem akuten Anfall von Verzewiflung habe ich auch schon mal sämtliche Dateien im Ordner auf chmod 777 gesetzt. :wink: Hat aber leider nicht geholfen.

Habe jetzt auch die Zeilen gefunden, die dei Probleme verursachen:


<IfModule mod_rewrite.c>

# Options +FollowSymLinks
# RewriteEngine On
RewriteBase /

RewriteCond %{REQUEST_URI} oxseo\.php$
RewriteCond %{QUERY_STRING} mod_rewrite_module_is=off
RewriteRule oxseo\.php$ oxseo.php?mod_rewrite_module_is=on [L]

RewriteCond %{REQUEST_URI} !(\/admin\/|\/core\/|\/export\/|\/modules\/|\/out\/|\/setup\/|\/tmp\/|\/views\/)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule !(\.html|\/|\.jpg|\.css|\.pdf|\.doc|\.gif|\.png|\.js)$ %{REQUEST_URI}/ [R=301,L]

RewriteCond %{REQUEST_URI} !(\/admin\/|\/core\/|\/export\/|\/modules\/|\/out\/|\/setup\/|\/tmp\/|\/views\/)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule (\.html|\/)$ oxseo.php


</IfModule>

# disabling log file access from outside
<FilesMatch "(EXCEPTION_LOG\.txt|\.log$|\.tpl$)">
order allow,deny
deny from all
</FilesMatch>

# Options -Indexes

Allerdings bleibt die Markierung für “Apache mod_rewrite” rot, obwohl phpinfo das Modul als geladen auflistet. Muss ich das noch irgendwie aktivieren?

Also von den Versionsnumern her sollte alles passen:
Apache/2.2.8 (Linux/SUSE)
MySQL Server Version: 5.0.51a
PHP Version 5.2.12

Ich hab keine Ahnung was da falsch laufen könnte. :confused:

Tja, RewriteEngine On muss auf Jedenfall gesetzt sein.

GGf. hast Du per htacces keine Rechte die einzuschalten.
Dann kann man noch in der apache.conf oder wie auch immer, eine Directory-Directive mit diesen Wert geben.

Hallo,

sieht aus, als würde der Hosting Provider die Ausführung der eigenen .htaccess oder bestimmter Direktiven unterbinden.

Gruß

Vielen Dank für eure Hinweise, ich habe meinen Provider schon angeschrieben, da ich da selber keine Einstellmöglichkeiten habe. Ich hoffe mal, der stellt sich da nicht quer. :rolleyes:

Gruß
m4ddy

Meine Datei muss so aussehen:


RewriteEngine On
RewriteBase /

RewriteCond %{REQUEST_URI} oxseo\.php$
RewriteCond %{QUERY_STRING} mod_rewrite_module_is=off
RewriteRule oxseo\.php$ oxseo.php?mod_rewrite_module_is=on [L]

RewriteCond %{REQUEST_URI} !(\/admin\/|\/core\/|\/export\/|\/modules\/|\/out\/|\/setup\/|\/tmp\/|\/views\/)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule !(\.html|\/|\.jpg|\.css|\.pdf|\.doc|\.gif|\.png|\.js)$ %{REQUEST_URI}/ [R=301,L]

RewriteCond %{REQUEST_URI} !(\/admin\/|\/core\/|\/export\/|\/modules\/|\/out\/|\/setup\/|\/tmp\/|\/views\/)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule (\.html|\/)$ oxseo.php

DirectoryIndex index.php index.html

mfg
Amok