Shop hochladen Anleitung

Hallo ihr Lieben,

ich bin mir nicht sicher, ob ich den Shop den ich lokal erstellt habe einfach per FTP hochladen kann oder was es da zu beachten gibt.

Hat jemand von euch einen Tipp, wo ich eine Anleitung zum Hosten finde?

Vielen Dank und liebe Grüße :slight_smile:

Rayco

Hallo Rayco,

im Prinzip ist es nichts anders, als einen Shop umzuziehen. Im Großen und Ganzen sollte dieses Tutorial helfen: http://wiki.oxidforge.org/Tutorials/Einen_Oxid-Shop_umziehen_lassen.

Gruß,
Jürgen

Hallo Jürgen,

vielen Dank für deine Antwort und den Link. Der hilft mir sehr weiter.

Liebe Grüße :slight_smile:

Rayco

Hallo ihr Lieben,

so, ich hab das jetzt alles so gemacht wie es in der Anleitung steht. Klappt auch erst mal super, nur nach dem DB Import werden weder die Artikelnamen, Kategorienamen, noch die Langtexte angezeigt.

Mache ich vllt etwas beim DB Export falsch?

Liebe Grüße :slight_smile:

Rayco

edit: In der importierten DB sind alle Langtexte in der Tabelle “ocatrextend” und alle Kategorien in der Tabelle “oxcategories” vorhanden aber diese Daten tauchen weder im Backend, noch im Fronten auf.

Hast Du die Views mit ex- und importiert? Es sollten nur die Tabellen umgezogen werden.

Wenn Du Zugriff auf den Adminbereich hast kannst Du auch schauen, ob die Kategorien aktiv sind und eventuell die Views neu generieren.

Aber im Prinzip funktioniert der Umzug exakt wie dort beschrieben.

Hallo MeisterYoda,

nein, die Views hab ich nicht mit importiert. Trotz dem hab ich in der neuen DB wieder Views. Und die hab ich jetzt gelöscht und jetzt ist der Shop und das Backend offline. Und den Link mit der Anleitung da oben kann ich auch nicht mehr öffnen.

Liebe Grüße :slight_smile:

Rayco

  1. In der config.inc.php folgendes einfügen: $this->blSkipViewUsage = 1;
  2. Im Backend einloggen und Views neu generieren
  3. $this->blSkipViewUsage = 1; wieder aus der config.inc.php entfernen
  4. Prüfen, ob die Artikel im Backend angezeigt werden.

Hallo Kai,

vielen Dank für deine Antwort.

Das hat super geklappt. Einziger Wermutstropfen sind die Umlaute, die jetzt im ganzen Shop mit einem ? angezeigt werden. Sowohl in den Texten als auch in den Artikelnamen.

Wie kann ich das noch ändern?

Vielen Dank und liebe Grüße :slight_smile:

Rayco

Da ist dann wohl beim irgendwas mit den Zeichensätzen schief gelaufen. Am besten man gibt das beim Im- oder Export explizit an. Je nachdem, welches Programm man dafür verwendet, wird das automatisch gemacht. In deinem Fall wurde es entweder nicht oder falsch gemacht. Kannst du denn noch die Konfiguration unter Stammdaten -> Grundeinstellungen im Reiter Performance verändern?

Hallo Martin,

ich habe jetzt die komplette Datenbank noch mal als UTF8 exportiert und importiert und nun sind auch alle Umlaute da, wo sie hin sollen.

Vielen Dank und liebe Grüße :slight_smile:

Rayco