Shop im Unterordner - oxSeoDecoder

Ich möchte meinen Shop in einen Unterordner auf meinem Webspace bringen. Die config.inc.php ist angepaßt, aber beim Aufruf von www.meineDomäin/Ordner/index.php wird folgende Meldung generiert:

Parse error: syntax error, unexpected T_OBJECT_OPERATOR in /hp/ax/ae/mx/www/shop/index.php on line 95

[U]Das bezieht sich auf folgenden Quelltext[/U]:

//Invoked over search engine URLs
if (isSearchEngineUrl()) {
oxNew(‘oxSeoDecoder’)->processSeoCall();
}

Was ist wo noch anzupassen ?

Danke dadsen

Hallo dadsen,

den TMP-Ordner hast Du geleert?

Gruß

Ja - aber erst nachdem Du mir den Anstoß gegeben hast. Bringt aber trotzdem nichts ???
dadsen

Hall Marco
ich habe folgendes geändert:
$this->dbHost = ‘xxxxxx’
$this->dbName = ‘xxxxx’
$this->dbUser = ’ xxxxx’
$this->dbPwd = ’ xxxxx’
$this->dbType = ‘mysql’
$this->sShopURL = 'http://www.meineURL/shop /'
okay oder ?

Nö,

        $this->sShopURL = 'http://192.168.152.128/CE_4.4.0/eshop'; // eShop base url, required
        $this->sSSLShopURL  = null;            // eShop SSL url, optional
        $this->sAdminSSLURL = null;            // eShop Admin SSL url, optional
        $this->sShopDir = '/var/www/CE_4.4.0/eshop';
        $this->sCompileDir = '/var/www/CE_4.4.0/eshop/tmp';

Gruß

[QUOTE=dadsen;39885]
Parse error: syntax error, unexpected T_OBJECT_OPERATOR[/QUOTE]
das sieht nach falscher PHP-Version aus.

php 5 ist eingestellt. richtig ?
gruß und danke

Hi Marco und alle
Bitte hilf mir doch noch mal. Ich habe jetzt die config.inc.php geändert in:

    $this->sShopURL = 'http://www.schriftgeniesser.de/shop/'; // eShop base url, required
    $this->sSSLShopURL  = null;         // eShop SSL url, optional
    $this->sAdminSSLURL = null;            // eShop Admin SSL url, optional
    $this->sShopDir = '/var/www/shop';
    $this->sCompileDir = '/var/www/shop/tmp';

aber es funzt nicht. Wo ist mein Hänger ? Muss die htaccess mit in dieses Unterverzeichnis ? Ist sie auch irgendwie zu verändern ?
Danke und Gruß dadsen

[QUOTE=dadsen;39956]php 5 ist eingestellt. richtig ?
gruß und danke[/QUOTE]
Sicher? Hast du das auch nachgeprüft (phpinfo im Unterverzeichnis)?

Hi,

mach auch mal den trailing Slash weg.

Gruß