SSL Problem Administration ja frontend nur nach Login

Hallo zusammen,

ich habe nun soweit das gesamte SSL wie in den FAQs eingrichtet und es funktioniert im Adminbereich auch sofort nach dem Login. Jedoch im Frontend weder ab dem Warenkorb noch beim Registrieren eines Kunden. Hierbei ist im Browser nie das SSL aktiviert. Erst nach dem der Kunde sich eingelogt hat in den Shop, wird das SSL Aktiviert. Iist es möglich das SSL bei der Registrierung des Kunden schon aktiv ist also kann ich dies irgendwo im Shop steuern und kommt jetzt nicht mit ja das kannst du machen in dem du Module dem Shop hinzufügst.

Sorry, ich versteh nicht ganz: Was ist das mit den Modulen???

Die SSL-URLs, die Du von Deinem Provider bekommst, trägst Du ganz normal an genau zwei Stellen in der config.inc.php ein.

Mehr isses nich, alles andere soll der Shop allein tun. Falls nicht, bitte Info.

Gruß


Marco Steinhäuser
Community Operator
OXID eSales AG

Die beiden haben ich eingetragen in die config. Im Adminbereich nimmt der Shop sofort nach dem Login die SSL verbindung auf das auch soweit okay ist. Aber im Frontend nicht, dort wird SSL erst aktiviert nach dem Login des Kunden und nicht schon vorher bei der Registrierung.

Ich habe es schon versucht lokal nach zu bilden dieses problem hier kommt aber das gleiche. Im Administrations Menue greift SSL Sofort nach dem Login als Administrator. Im Frontend greift es nicht weder ab bestellungs beginn noch bei der Registrierung des Kunden sondern erst nach dem Login des Kunden. Ich versuche morgen dir mal eine test Domain zu schalten wo du dir das ansehen kannst mit den Demo Artikeln


Theorie ist, wenn man alles weiß und nichts klappt.
Praxis ist, wenn alles funktioniert und keiner weiß warum.
Beim Computer sind Theorie und Praxis vereint, nichts funktioniert und keiner weiß warum.

Ich versuche morgen dir mal eine test Domain zu schalte
Prima.

Gruß


Marco Steinhäuser
Community Operator
OXID eSales AG

Sorry Marco hatte was länger gedauert mit dem Schalten des Shops.

www.videowelten.de ist der Shop dort gibt es aktuell noch euren Admin user account als testkunden welcher nicht mehr in die Admin Oberfläche sich einloggen kann. Das Passwort ist admin, ich hoffe du kannst mir hierbei helfen. Denn die SSL weiterleitung ist über http://ps-ssl.de/videowelten.de aufgebaut was auch in der config.inc.php so eingetragen wurden. Ich habe nun noch mal mit dem Firefox dies überprüft also die SSL verbindung wird aufgebaut aber halt werden die Daten aus dem Basis Template immer mit der Standart Domain www.videowelten.de geladen statt über die SSL Domain. Ich weiß aktuell leider nicht mehr weiter erst reicht weil das SSL Ohne probleme in der Administrativen Oberfläche funktioniert.


Theorie ist, wenn man alles weiß und nichts klappt.
Praxis ist, wenn alles funktioniert und keiner weiß warum.
Beim Computer sind Theorie und Praxis vereint, nichts funktioniert und keiner weiß warum.

Hallo,

auf der Domain finde ich eine Wartungsseite. Ausserdem habe ich noch immer Probleme, den Sachverhalt richtig zu verstehen. Im Frontend greift die SSL-Verschlüsselung natürlich erst dort, wo Daten eingegeben werden müssen. Der Katalogbereich an sich ist nicht SSL-verschlüsselt.

Gruß


Marco Steinhäuser
Community Operator
OXID eSales AG

Sorry wegen der Wartungsseite du must auf folgende seite gehen www.videowelten.de/index.php dann kommst du auch auf den Shop an sich selber. Es exisiteren noch keine wirklichen artikel nur ein Test artikel ist vorhanden der auch Test heißt. Ich merke es mit dem SSL zum beispiel beim Registrieren eines Kundes das es dort nicht aktiviert wird, beim laden der Seite sondern erst wenn der Kunde daraufhin eingeloggt ist im System. Im normalen Shop bereich soll es auch kein SSL geben das ja auch richtig sondern nur dort wo auch sichere Datenkommunikation erforderlich ist also beim Anlegen eines Kunden accounts sowie beim bezahl vorgang.


Theorie ist, wenn man alles weiß und nichts klappt.
Praxis ist, wenn alles funktioniert und keiner weiß warum.
Beim Computer sind Theorie und Praxis vereint, nichts funktioniert und keiner weiß warum.

Hi,

wenn ich mir als nicht angemeldeter Kunde etwas in den Warenkorb lege, mir den Warenkorb anzeigen lasse und weiter zum Checkout will, lande ich auf der Startseite des Shops und bekomme folgende URL:
https://ps-ssl.de/www.videowelten.de//index.php?

In erster Instanz sieht es für mich wie ein Trailing Slash zu viel aus. Poste doch mal bitte Deine config.inc.php “demilitarisiert”.

Und Du weißt schon, dass der SSL-Proxy Deines Providers maximal zu Testzwecken herhalten kann und für den Produktiveinsatz ungeeignet ist?

Gruß


Marco Steinhäuser
Community Operator
OXID eSales AG

Ja das mit schon bekannt der ist ja auch nur für die Testzwecke da ich das neue SSL Zertifikat momentan erst beantragt habe da ich den Provider erst gewechselt habe.

Hier mal die Config.inc Datei:

$this->dbType = ‘mysql’;
$this->sShopURL = ‘http://www.videowelten.de’;
$this->sSSLShopURL = ‘http://ps-ssl.de/www.videowelten.de’;
$this->sAdminSSLURL = null; //auskommentiert
$this->sShopDir = ‘/home/www/kunden/ita2005.de/videowelten’;
$this->sCompileDir = ‘/home/www/kunden/ita2005.de/videowelten/tmp’;

$this->sTheme = 'basic';

//File type whitelist for file upload
$this->aAllowedUploadTypes = array('jpg', 'gif', 'png', 'pdf', 'mp3', 'avi', 'mpg', 'mpeg', 'doc', 'xls', 'ppt');

// timezone information
date_default_timezone_set('Europe/Berlin');

// Search engine friendly URL processor
// After changing this value, you should rename oxid.php file as well
// Always leave .php extension here unless you know what you are doing
$this->sOXIDPHP = "oxid.php";

//  enable debug mode for template development or bugfixing
// -1 = Logger Messages internal use only
//  0 = off
//  1 = smarty
//  2 = SQL
//  3 = SQL + smarty
//  4 = SQL + smarty + shoptemplate data
//  5 = Delivery Cost calculation info
//  6 = SMTP Debug Messages
//  7 = oxDbDebug SQL parser
$this->iDebug = 0;

// Log all modifications performed in Admin
$this->blLogChangesInAdmin = 1;

$this->sAdminEmail = '[email protected]';

// Use browser cookies to store session id (no sid parameter in URL)
$this->blSessionUseCookies = 1;
// Force user to use cookies (no checkout without cookie support)
$this->blSessionEnforceCookies = 1;

// uncomment the following line if you want euro sign leave unchanged in output
// the default is to convert euro sign symbol to html entity
// $this->blSkipEuroReplace = true;


// List of all Search-Engine Robots
$this->aRobots = array(
                    'googlebot',
                    'ultraseek',
                    'crawl',
                    'spider',
                    'fireball',
                    'robot',
                    'spider',
                    'robot',
                    'slurp',
                    'fast',
                    'altavista',
                    'teoma',
                    );

// Deactivate Static URL's for these Robots
$this->aRobotsExcept = array();

// Only for former templates: Fixed Shop Width
$this->blFixedWidthLayout = 1;

Theorie ist, wenn man alles weiß und nichts klappt.
Praxis ist, wenn alles funktioniert und keiner weiß warum.
Beim Computer sind Theorie und Praxis vereint, nichts funktioniert und keiner weiß warum.

Hallo power2010,

versuch es mal so:

$this->sSSLShopURL = ‘http://ps-ssl.de/www.videowelten.de’;

ersetzen durch

$this->sSSLShopURL = ‘https://ps-ssl.de/www.videowelten.de’;

Bin mir nicht sicher, ob das so funktioniert aber einen Versuch ist es allemal wert. Ansonsten wäre es vielleicht sinnvoll, auch nochmal mit dem Provider zu sprechen, wie genau der SSL-Proxy eingebunden werden muss.

Gruß


Marco Steinhäuser
Community Operator
OXID eSales AG

Hallo Marco,

ich habe noch einmal mit dem Provider gesprochen der wird sich dies nun mal ansehen wo das Problem liegt. Denn der SSL Proxy muss über https angesprochen werden andern falls reagiert dieser nicht, denn wenn ich per http kommen würde, dann käme der SSL Proxy wie folgt mit einer http://no.ps-ssl.de. Ich hab es bisher soweit ja eingrenzen können mit dem SSL das er nur die Grafiken sowie die css Datei nicht über den Proxy läd sondern diese noch von der Domain ausgeladen werden, denn sonst würde das SSL funktionieren. Ich gebe dir jedenfalls sofort neue Informationen wenn ich eine Antwort vom Support bekommen habe bezüglich dieses problems.

Theorie ist, wenn man alles weiß und nichts klappt.
Praxis ist, wenn alles funktioniert und keiner weiß warum.
Beim Computer sind Theorie und Praxis vereint, nichts funktioniert und keiner weiß warum.

Habe das gleiche Problem!

PROXY SSL scheint nicht zu funktionieren!

Der Link zum registrieren ist ohne SSL - großer Warenkorb dann mit SSL, aber es werden “unsichere Elemente” gemeldet! Wenn man sich nun diese NICHT anzeigen läßt, ist die Seitenansicht VOLLKOMMEN IM EIMER!!!

Des weiteren habe ich einen “/” ZUVIEL in der Browserzeile - die Einrichtung wurde aber vollständig und ohne Slash gemacht!

Jemand eine Idee, wo es klemmt???


Gruß Foxi

Hallo Foxi,

Du hast offensichtlich einen trailing slash zu viel in die config.inc.php geschrieben. Das betrifft auch Deinen anderen Thread mit den Header-Bildern. Wenn Du dann im _header.tpl anpassungen vornimmst, ist es kein Wunder, wenn unsichere Elemente vom Browser angemeckert werden.

Gruß


Marco Steinhäuser
Community Operator
OXID eSales AG

Hallo,

nun so einfach ist das NICHT!

Die Entfernung vom Slash/s in der _header.tpl hat damit NICHTS zu tun. Die kommen an Stellen, wo die Datei gar kein Zugriff hat bzw. Einstellmöglichkeiten gewährt, sondern werden in der Datei irgenwie doppeltgemoppelt erzeugt.

www.videowelten.de/out/basic/img//lang/en.gif und der ist nicht von mir und das mach ich sicherlich bei jedem Test!!!

Interassant ist ja die Begegnung mit dem IE - wenn der beim Aufruf “warnt” und man die “unsicheren” Elemente unterdrückt, hat man NULL Bilder, da die Einbindung nicht PROXY-Besonderheiten berücksichtigt!

sage mal nur - da fehlt der hier irgendwo:

$request_type = ($_SERVER['HTTP_X_FORWARDED_HOST'] == 'mysslsitesdomain.de') ? 'SSL' : 'NONSSL';

und bestimmt nicht in der config.inc.php

Und dann gleich noch mal zu diesen “/” - die sind zuviel bzw. vielleicht “htaccess”???

PS: SSL ist auch irgendwie - nun ja - bei mir funzt nur ein Link via SSL (OK der Adminlink auch macht also 2) und zwar der aus dem großen Warenkorb - alles andere ist TOT - Mein Konto -> Wunschzettel -> Registrieren -> Passwort …!!!


Gruß Foxi

Hi,

bei mir gibts auch ein Problem mit dem SSL Proxy vieleicht könnt ihr mir behilflich sein.

Im Frontend Bereich bekomm ich nur SSL hin wenn ich dies in meine Conf eingebe: $this->sSSLShopURL = ‘https://ssl.webpack.de/elektronik-shop.org/’; <-- ohne / am Ende kann ich nicht Login / Konto / zugreifen da kommt dann ein warn Hinweiß im Browser:

Für diese Aktion werden Cookies benötigt. Bitte aktivieren sie Cookies oder nützen sie einen anderen Browser.

Ich habs mit IE 7, 6 und Firefox probiert bei allen kommt die selbe Meldung beim IE 7 hab ich cookies von dieser Seite akzeptiert.

Zweite Problem da das erste ja mehr oder weniger schon gelöst ist.

Ich kann mich nicht in Admin Bereich ein logen Config sieht so aus :

$this->sAdminSSLURL = ‘https://ssl.webpack.de/elektronik-shop.org/admin’; wie oben mit / am ende probiert geht nicht.

Eventuell hilft das zur Lösung gebe die Daten zum einlogen ein werde immer wieder zu der selben Seite geleitet.

http://www.elektronik-shop.org/admin/index.php?redirected=1

Wie mein Redner davor ist mir das mit den zwei // aufgefallen und ebenso den Text aus dem header erinnert mich stark an xt commerce shop mußte das beim vorherigen shop zwecks ssl ändern.

Yep,

so ist es bei mir auch - rein geht es in den Admin so nicht - aber der Aufruf klappt (ohne Warnmeldung) und das wars!!!

Ja - diese Einträge gehören so in xt:C bzw. dessen Varianten für Proxy und auch der Nachfolger kam mit genau diesem “BUG”, was aber seit V4.0.0.7 gelöst ist und dort nun EINWANDFREI funktioniert!

Die “//” stehen NICHT im Zusammenhang mit der CONFIG Datei, sondern sind ein Schönheitsfehler!


Gruß Foxi

Hat schon wer eine Lösung ?

  1. Wenn man den ganzen Shop über den SSL Proxy laufen lassen würde geht es komischer weiße mit dem Admin Login ohne wieder auf login Seite zurück zu fallen.

$this->sShopURL = ‘https://ssl.webpack.de/elektronik-shop.org’;
$this->sSSLShopURL = ‘https://ssl.webpack.de/elektronik-shop.org’;
$this->sAdminSSLURL = ‘https://ssl.webpack.de/elektronik-shop.org/admin’;

  1. wenn man diese config nimmt wie es eigentlich richtig sein sollte !

$this->sShopURL = ‘http://www.elektronik-shop.org’;
$this->sSSLShopURL = ‘https://ssl.webpack.de/elektronik-shop.org’;
$this->sAdminSSLURL = ‘https://ssl.webpack.de/elektronik-shop.org/admin’;

wenn man nun wie ich im vorherigen Beitrag oben schon mal beschrieben habe in den Admin Bereich einlogen möchte erscheint im Browser Adressfeld http://www.elektronik-shop.org/admin/index.php?redirected=1 und wird wieder auf die Admin Login Seite geleitet. Einlogen nicht möglich.

gibt man nun keine Daten in den Admin Log in ein sprich ohne Daten versuchen einzulogen erfolgt der richtige Aufruf im Adressfeld des Browsers: https://ssl.webpack.de/elektronik-shop.org/admin//index.php

Wie auch oben schon beschrieben im Frontent klapt das mit dem SSL Proxy Problem los.

Wo liegt der Fehler? wo muß ich etwas ändern damit es klaptt wäre nett wenn wer ne Lösung Parat hätte.

Ich habe nun über mein Provider für meine Domain ein SSL Zertifikat bestellt und eingerichtet nun klappt es denn Admin Bereich SSL zu verschlüsseln.

Wenn nun ein Registrierter Kunde sich mit seinen Daten einlogen möchte kommt diese Fehler Meldung:

Für diese Aktion werden Cookies benötigt. Bitte aktivieren Sie Cookies oder nutzen Sie einen anderen Browser.

Nach dem man nochmals die selben Daten eingibt klappt es Problemlos woran könnte das liegen ? Ich würde das gerne beheben.

Hallo Silver-Electronics,

auch die SSL-Verschlüsselung im Frontend scheint zu klappen :slight_smile: Fragt sich nur, warum das mit einem Proxy nicht funktionieren soll :frowning:

Ich bekomme übrigens keine Cookie-Fehlermeldung in Deinem Shop. Vielleicht probierst Du es mal auf einer anderen Maschine oder mit einem anderen Browser…

Gruß


Marco Steinhäuser
Community Guide
OXID eSales AG

Hi,<br>

und danke für die Antwort. Ich kann es mir leider nicht erklären mit Internet Explorer 6-8 kommt bei mir diese Warnmeldung oberhalb der Angebote in rot :wink: Meldung auf dem Laptop sowie Destop PC … eventuell zwei mal eingelogt? Wie schon gesagt nach dem zweiten login kommt diese Meldung nicht mehr.<br>

Grüße