Unable to install oxid v6

I get the following error when running the command provided on the install instructions:
composer create-project --no-dev oxid-esales/oxideshop-project oxid6-new dev-b-6.0-ce

Installing oxid-esales/oxideshop-project (dev-b-6.0-ce 09c5d486762d05e027dc250ab2524bea1db0c7f5)

  • Installing oxid-esales/oxideshop-project (dev-b-6.0-ce b-6.0-ce)
    Cloning b-6.0-ce

Created project in oxid6-new
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

Problem 1
- oxid-esales/oxideshop-unified-namespace-generator v1.0.0 requires composer-plugin-api ^1.1.0 -> no matching package found.
- oxid-esales/oxideshop-metapackage-ce v6.0.0 requires oxid-esales/oxideshop-unified-namespace-generator v1.0.0 -> satisfiable by oxid-esales/oxideshop-unified-namespace-generator[v1.0.0].
- Installation request for oxid-esales/oxideshop-metapackage-ce ^v6.0.0 -> satisfiable by oxid-esales/oxideshop-metapackage-ce[v6.0.0].

Potential causes:

Read https://getcomposer.org/doc/articles/troubleshooting.md for further common problems.

please advise on the possible solution to the problem running on Ubuntu 16.04.2 LTS.

Are you install oxid 6 on windows? try on linux like virtualmachine. I don’t know is it reason but when i tried to install on Windows i had the same problem.

thank you for your response, but the problem is on ubuntu 14.04.2 LTS.

I think that is composer version problem. Check withch oxid vm have version of composer and intsall the same and check again.

I’m using VM: https://github.com/OXID-eSales/oxvm_base

Or just update composer to the latest version.

it seems like that fixed the problem. Thank you for your help guys! I tried updating the composer with self-update first, but that also produced an error, so i ended up uninstalling it with apt-get remove composer and then reinstalling it like stated in the official documentation and with 1.5.5 it seems to work (it is downloading the dependencies now).
Thanks again!

1 Like

Right: composer in the official repositories are usually outdated and cannot be self-updated when installing them with apt. Good luck!