Update auf 4.3: Systemvoraussetzungen auf einmal nicht mehr gegeben

Ich habe soeben das Update auf die 4.3 durchgeführt, da wir unseren Shop erst gelauncht haben und die Datenbank noch recht klein ist.
Zuerst einmal: Das Update funktioniert auf den ersten Blick schonmal so, wie es sollte. :slight_smile:

Im Admin erhalte ich aber jetzt eine Warnmeldung:

Ihr System erfüllt die Systemvoraussetzungen nicht. Weitere Informationen finden Sie im Systemvoraussetzungs-Check.

Beim Klick auf den “Systemvoraussetzungs-Check” werden zwei Punkte bemängelt, die vor dem Update noch OK waren:

Server-Konfiguration
* Apache mod_rewrite Modul
* Dateizugriffsrechte

phpinfo(); sagt jedoch:

apache2handler
Loaded Modules: … mod_rewrite …

Aktuell würde ich sagen: Schönheitsfehler. Aber vielleicht wird’s ja noch ein richtiger Bug :wink:

Falls jemand was näheres dazu weiß, würde ich mich über ein Reply hier freuen.

Des weiteren wäre es allgemein bei dem Check ganz gut, wenn es zu “Dateizugriffsrechte” auch eine Erklärung gäbe, welche Datei(en) dies betrifft.

Update: Was auf jeden Fall zum Thema “Dateizugriffsrechte” fehlt, ist ein Hinweis in der Anleitung:

Die neuen Bildpfade in der 4.3.0 müssen alle noch nachträglich mit CHMOD auf 777 gestellt werden.
Die betrifft /out/pictures/ und dort “master” sowie alle neuen “z-Ordner” (also z5, z6 … z12).
Ansonsten können keine Bilder mehr zu Artikeln hochgeladen werden.

[QUOTE=mkammerer;28543]
Server-Konfiguration

  • Apache mod_rewrite Modul

[/QUOTE]

Hatte ich auch, nach dem ich die .htaccess dann doch :stuck_out_tongue: hochgeladen habe war der Fehler weg


<IfModule mod_rewrite.c>

Options +FollowSymLinks
RewriteEngine On
RewriteBase /

RewriteCond %{REQUEST_URI} oxseo\.php$
RewriteCond %{QUERY_STRING} mod_rewrite_module_is=off
RewriteRule oxseo\.php$ oxseo.php?mod_rewrite_module_is=on [L]

RewriteCond %{REQUEST_URI} !(\/admin\/|\/core\/|\/export\/|\/modules\/|\/out\/|\/setup\/|\/tmp\/|\/views\/)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule !(\.html|\/|\.jpg|\.css|\.pdf|\.doc|\.gif|\.png|\.js)$ %{REQUEST_URI}/ [R=301,L]

RewriteCond %{REQUEST_URI} !(\/admin\/|\/core\/|\/export\/|\/modules\/|\/out\/|\/setup\/|\/tmp\/|\/views\/)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule (\.html|\/)$ oxseo.php


</IfModule>

# disabling log file access from outside
<FilesMatch "(EXCEPTION_LOG\.txt|\.log$|\.tpl$)">
order allow,deny
deny from all
</FilesMatch>

Options -Indexes

Stimmt, sobald man’s richtig macht, funktioniert’s auch :smiley:

Der mod_rewrite-Fehler ist bei mir jetzt auch weg. Jetzt muß ich mal noch die Verzeichnisrechte durchgehen, was ihm da noch fehlt.

Wobei man die Zeile

RewriteBase /

noch anpassen muß, wenn der Shop nicht im Hauptverzeichnis der Domain liegt.
Bei Shop auf www.meinedomain.com/shop muß in diese Zeile dann entsprechend auch

RewriteBase /shop/

rein. Ansonsten Artikel anklicken --> Fehler 404

Habe auch das Problem, dieser Tip hat aber leider nicht geholfen - ist immer noch rot!

Gehostet bei “AllInkl.”!

Bei der Installation war noch alles OK - jetzt nicht mehr, merkwürdig=?!

Gem. PHPInfo ist aber ModRewrite aktiv!

Hat sich nach einer Neuinstallation erledigt!

Sp das mit dem Modrewrite habsch hinbkommen, aber das mit den Dateizugriffsrechte ist immer noch da…

habe alle threads hier gelesen und anweisungen befolgt.

Desweiteren stellt es das adminmenü unvollständi dar

siehe anhang.

bitte um hilfe :slight_smile:

config.inc.php auf rechte 444 setzen

[QUOTE=nolegend;29321]config.inc.php auf rechte 444 setzen[/QUOTE]

leider keine veränderung :frowning:

Die Rechte musst du auf 755 oder 777 setzen.

[QUOTE=roland76;29328]Die Rechte musst du auf 755 oder 777 setzen.[/QUOTE]

Blos nicht!
Das lößt das Problem nicht, erzeugt aber eine weiter Warnmeldung:

[B]WICHTIG: Aus Sicherheitsgründen setzen Sie Ihre config.inc.php Datei auf read-only-Modus![/B]

Hallo!!!

http://wiki.oxidforge.org/Tutorials/filesystem_permissions#Files_.26_Folder_Permission_Setup

Grüße

Cutty

Na logisch. Nach abgeschlosserer Installation musst du die Dateirechte der config.inc.php wieder auf 644 zurücksetzen.

[QUOTE=rubbercut;29330]Hallo!!!

http://wiki.oxidforge.org/Tutorials/filesystem_permissions#Files_.26_Folder_Permission_Setup

Grüße

Cutty[/QUOTE]

Schon durchgeführt, der Fehler bleibt. Wobei da halt die Frage ist, ob das Wiki schon auf die Verhältnisse der 4.3 angepaßt ist.

da im admin bereich auch ein haufen schief ging dachte ih installier ich alles neu…mh aber wieeder dateirechte gehen nicht, wobei alle ordner korrekt sind…was ist denn los mit oxis eh :frowning:

Schau mal hier:
http://www.oxid-esales.com/forum/showthread.php?t=4835&highlight=systemvoraussetzungen
<edit>
sorry, war hier:
http://www.oxid-esales.com/forum/showthread.php?t=4807&highlight=oxsysrequirements.php
und
https://bugs.oxid-esales.com/view.php?id=1742
</edit>

Ansonsten in der core/oxsysrequirements.php
Zeile 235ff mal $sFullPath ausgeben lassen. Da sieht man dann, wo’s hängt

            if ( !is_readable( $sFullPath ) || !is_writable( $sFullPath ) ) {
              echo $sFullPath.'<br/>';
                $iModStat = 0;
                break;
            }

Gruß
Helmut

Genau das war’s, was auch geholfen hat :slight_smile:
In meinem Fall war einmal 755 statt 777 gesetzt, kleiner aber feiner Unterschied.
Schade, daß die Fehler-Ausgabe nicht standardmäßig im Shop drinnen ist, das hätte mir viel Sucherei erspart.
Wo kann ich Wünsche für die nächste Version abgeben? :smiley:

hat jemand hier eine Ahnung, warum bei meinem Live-Server die linke Navigation im Admin-Bereich nicht vollständig angezeigt wird. ich erhalte eine Frameset-Fehler:

The requested URL /CE/4.3.0/deutschland/de/banners/navigation.html was not found on this server.

Apache Server at admin.oxid-esales.com Port 80

Gruß
Frank

hi !

ich komm nicht klar:

ich habe alles upgedatet auf 4.3.1
problem ist das wenn ich auf das wort Systemvoraussetzungs-Check klicke ich im admin zusätzlich das frontend angezeigt bekomme.

jemand einen rat?

gruß
michael