Vagrant/Composer update PHP von 5.6.32 auf 7.1


#1

Hallo,
im Moment häge ich beim Update meiner lokalen Installation unter Windows.
Wie Installiere/update ich (mit Composer ?) die installierte PHP Version?
Ich möchte von Oxid von 6.0.3 auf 6.1.1 Updaten und bekomme folgende Fehlermeldung:

Your requirements could not be resolved to an installable set of packages.

Problem 1
- doctrine/inflector v1.2.0 requires php ^7.0 -> your PHP version (5.6.32) does not satisfy that requirement.
- oxid-esales/oxideshop-metapackage-ce v6.1.1 requires doctrine/inflector v1.2.0 -> satisfiable by doctrine/inflector[v1.2.0].
- Installation request for oxid-esales/oxideshop-metapackage-ce ^v6.1.1 -> satisfiable by oxid-esales/oxideshop-metapackage-ce[v6.1.1].


#2

Die installierte PHP-Version kann Composer nicht ändern. Du musst dich bei deinem Provider informieren, wie du auf 7.1 umstellen kannst.


#3

welche Webserver Software hast du unter Windows installiert? Ggf kann man es dort einfach umschalten oder man muss einfach eine andere/neuere Version mit PHP 7 installieren


#4

@m431342 Ist meine lokale Testumgebung auf dem Laptop, also kein Provider

@vanilla_thunder ich nutze die Oxid VM
Eben habe ich nach Sunden die Lösung gefunden.
In der composer.json habe ich folgendes eingefügt:

Blockquote “config”: {
"platform": {
"php": "7.1"
},
“preferred-install”: {
“*”: “dist”
}

Danach aktualisiert mit:
-> composer update

Aktualisierung
Das Update hat doch nicht funktioniert.
Jetzt läuft auch der Shop nicht mehr. :frowning:


#6

Hallo vanilla_thunder,
das ist ja gerade mein Problem. Ich weiss nicht wie ich die OxidVM auf PHP 7 updaten kann.


#7

das steht in der Anleitung: