Versandkostenregeln einfach?

Ich hätte nicht gedacht, dass mich die Versandkostenregeln derart beschäftigen. Irgendwie bekomme ich es nicht hin, obwohl es relativ einfach scheint.

Vielleicht kann mir jemand helfen.

Ich versende “nur” mit DHL und habe ausschliesslich Inlandskunden. Mindestbestellwert 30EUR ist in den Grundeinstellungen vorhanden.

Die Regeln sollten sein:
-ab 60EUR Warenwert - Paket Versandkostenfrei
-bis 60EUR Warenwert - Paket 5,90EUR
-bis 1,8kg Warenkorbgewicht - Päckchen 3,90EUR

Versandart:
-DHL

Es sind auch mehrere Versandarten (Frachtfrei, Paket, Päckchen) denkbar. Wobei aber für den noch nicht angemeldeten Kunden die günstigste und auch mögliche Versandart im Warenkorb voreingestellt sein sollte.

Der Knackpunkt ist auch irgendwie, dass ein Päckchen bis 1,8kg mit einem Warenkorbwert über 60EUR Versandkostenfrei sein soll.

Vielleicht hats schon jemand so und kann mir seine Einstellungen geben.

Danke

evtl. so: >(ungechecked!)

1.) -ab 60EUR Warenwert - Paket Versandkostenfrei - keine weitere regel
2.) -bis 1,8kg Warenkorbgewicht - Päckchen 3,90EUR - weitere regel (Gewichte müssen eingegeben sein)
3.) -bis 60EUR Warenwert - Paket 5,90EUR - keine weitere regel

geht aber noch einfacher. du mußt ja sowieso alle artikel mit nem gewicht hinterlegen, dann nimm doch einfach > 1,8kg = Paket und fertig. regel 1. passt ja nach wie vor. und 2. ist dann auch -keine weitere-…

Danke Domino,

will aber nicht so gelingen.

1.) -ab 60EUR Warenwert - Paket Versandkostenfrei - keine weitere regel
2.) -bis 1,8kg Warenkorbgewicht - Päckchen 3,90EUR - weitere regel (Gewichte müssen eingegeben sein)
3.) -bis 60EUR Warenwert - Paket 5,90EUR - keine weitere regel

Hier bekomme ich beim Warenkorbgewicht unter 1,8kg, Versandkosten von 9,80EUR. Er rechnet also 2.) und 3.) zusammen weil ja beides, Gewicht und Preis passen.

geht aber noch einfacher. du mußt ja sowieso alle artikel mit nem gewicht hinterlegen, dann nimm doch einfach > 1,8kg = Paket und fertig. regel 1. passt ja nach wie vor. und 2. ist dann auch -keine weitere-…

Hier fehlt mir dann der Päckchenpreis von 3,90EUR.

Gewichte sind natürlich sorgfältig hinterlegt. Im Warenkorb lasse ich mir testweise das Warenkorbgewicht mit [{$oxcmp_basket->getWeight()}] ausgeben.

Oxid-Version ist 4.8.6

Kann doch nicht sein, dass sich so was einfaches nicht einstellen lässt, oder?

nein,nein. das muß stimmen.

  1. ab60,- frei
  2. 0 bis 1,8kg 3,95
  3. ab 1,8 xy,-

Aaaahja,

mit Gewicht gehts. Leuchtet auch ein.

Nur für den Fall dass jemand ein ähnliches Problem hat, hier meine Einstellungen:

Versandkostenregeln
1.) -ab 60EUR Warenwert - Paket Versandkostenfrei - keine weitere regel
2.) -von 0kg bis 1,8kg Warenkorbgewicht - Päckchen 3,90EUR - weitere regel
3.) -von 1,8kg bis 199kg Warenkorbgewicht - Paket 5,90EUR - keine weitere regel

Versandart
1.) DHL - (ich habe sonst keine weiteren) - hier alle 3 Versandkostenregeln einsetzen

Danke Domino, hast mir sehr geholfen.

Manfred

Schön langsam krieg ich echt einen Kropf:eek:

Die Einstellungen von vorhin funktionieren wunderbar im Warenkorb. Sobald ich dann die Adresse eingegeben habe findet oxid dann keine Versandarten mehr.

Naja, dachte ich, füge ich halt Länder der Versandart hinzu. Hab ja nur eines, wobei: sollte auch ohne gehen.
Geht aber nicht, auch wenn ich den Regeln noch das Land zuordne.

Also irgendwie kot… mich das jetzt schon an.

Alles wieder zurück, ohne Land Zuordnung und nur noch eine Versandkostenregel Versandkostenfrei. Trotzdem findet er keine Versandart.
Alles komplett gelöscht und neu angelegt - “Keine Versandart gefunden”

Er findet keine Versandart auch wenn ich nur eine einzige, gültige Regel einsetze.

Ich hab ja nix gemacht, ausser an den Regeln und Versandarten rumzuspielen. Vorher ging wenigstens nur eine ganz einfache Einstellung.

Kann ich da was grundsätzliches gelöscht haben?

Hallo

Probier mal folgendes Modul :http://forum.oxid-esales.com/showthread.php?t=2149&page=2

LG Pasquale

schon mal gelesen? https://www.oxid-esales.com/de/support-services/dokumentation-und-hilfe/oxid-eshop/einrichtung/versandkostenregeln.html

Hallo Domino,

die Doku mit den Versandkostenregeln kenne ich schon. Anscheinend hab ich ihn aber nicht richtig kapiert:rolleyes:
Es war keine gültige Zahlungsart zugewiesen. Die hatte ich beim probieren vermutlich nicht immer geprüft.

Mit dem Modul von leofonic (Danke Pasquale) war das dann auch gleich klar.

Bei mir lag es zum Schluß an den Zahlungsarten, dass die Versandart nicht angezeigt wurde.

Ende: jetzt geht es. Danke für die Hilfe.

na also. aber: leofonic ≠ vendingtechnik :slight_smile: