Versandkostenregeln gehen nicht

#1

Hallo,

ich habe ein Problem mit den Versandkostenregeln.
Eingesetzte Version: CE 4.6.5_49955

Ich habe folgende Kategorien:

Wein
-Rotwein

  • Weißwein und Rosé
    Präsente

Der Kunde hat folgenden Wunsch:

[ul]
[li]Ab 12 Flaschen Wein Versandkostenfrei
[/li][li]4 - 11 Weine 5,90 Euro Versandkosten
[/li][li]1 - 3 Weine 4,90 Euro Versandkosten
[/li][li]kein Wein, nur Präsente 2,90 Euro Versandkosten
[/li][/ul]

Dies habe ich auch in dieser Reihenfolge / Sortierung eingebaut und jeweils das Häkchen “Keine weiteren Regeln nach dieser berechnen” gesetzt. Bei den Weinen habe ich entsprechend die Weine als Kategorien und bei den Präsenten die Präsente als Kategorie zugeordnet.

Jetzt das Merkwürdige:

Nehme ich nur Weine, klappt alles. Sobald ich ein Präsent mit im Warenkorb lege, werden die Weine für die Versandkostenberechnung doppelt gezählt.

Also:
Habe ich 6 Weine und ein Präsentartikel, ist die Lieferung plötzlich versandkostenfrei. Stelle ich die Versandkostenfreiheit testweise auf 30 Flaschen, ist die Lieferung bei 15 Weinen und einem Präsent versandkostenfrei.

Kann mir das jemand erklären bzw. mir jemand helfen?

Gruß
c4y

#2

Wir hatten ähnliche Versandkostenregeln, bei uns war aktiv:

  • Einmal pro Warenkorb
  • Keine weiteren Regeln nach dieser berechnen

Im Forum gibt es Beiträge die dieses Problem im Zusammenhang mit Modulen z.B. Billsafe beschreiben.

#3

Einmal pro Warenkorb habe ich auch genommen.
Geht aber trotzdem nicht. Obwohl es ja im Prinzip gehen müsste.

#4

Manchmal auch eine Falle: nicht immer “Menge” ausgewählt, sonder vielleicht mal “Gewicht” oder “Länge”.

Module installiert?

#5

Steht auf Menge.
Module: InvoicePDF, Concardis PayEngine, tinymce, VTUtils Clear TMP

PayEngine deaktiviert, Problem bleibt.

#6

Ich würde dann mal alle Moduleinträge ausser invoicePDF rausnehmen. Weil solche Probleme schon durch Module verursacht wurden.

#7

[QUOTE=c4y;108757]
[ul]
[li]Ab 12 Flaschen Wein Versandkostenfrei
[/li][li]4 - 11 Weine 5,90 Euro Versandkosten
[/li][li]1 - 3 Weine 4,90 Euro Versandkosten
[/li][li]kein Wein, nur Präsente 2,90 Euro Versandkosten
[/li][/ul][/QUOTE]

wenn das Deine ganzen Regeln sind, sind die nicht eindeutig.
Hast Du schon versucht als letzte Regel für einen gemischten Warenkorb z.B. von 1.- bis 999999.- Versandkosten X einzutragen.
Ich kann mir vorstellen, dass vielleicht Mist rauskommt, wenn Oxid keine passende Regel für den Warenkorb findet.

Versandkostenregeln sind ein bisschen wie Prolog programmieren. Keiner blickts, aber am Ende funktionierts dann doch irgendwie :slight_smile:

#8

Alle Module deaktiviert. Kurzzeitig scheint es zu gehen. Aber nach ein paar Tests kommt der gleiche Fehler wieder. Das ist wie am Anfang. Da schien auch alles zu klappen. Plötzlich ging nix mehr. Alles sehr merkmürdig…

Wenn ich die letzte Regel für einen gemischten Warenkorb (1-99999) setze, kommt der gleiche Fehler.

#9

Noch ein letzter hilfloser Versuch :wink:

Kehre die Auswahl der Kategorie mal um. Also die Kategorie(n) die von der Regel betroffen sind nach links und alles andere nach rechts.

#10

und die Reihenfolge umdrehen, also vom spezifischeren zum allgemeineren und jeweils “keine weitere Regeln…” aktivieren?

#11

Kategorien umdrehen war erfolglos.
Und mit der Reihenfolge umdrehen tue ich mich schwer, weil dann die Versandkosten ja addiert werden. Da komme ich nie so hin, wie ich das brauche bzw. der Kunde es sich wünscht.

Gibt es hier vielleicht bezahlte Hilfe, den Kundenwunsch umzusetzen? Ich bin etwas unter Druck :slight_smile:

#12

Wenn Du mir die Zugangsdaten zum Admin einrichtest, schaue ich es mir gerne an. Wenn ich erfolgreich bin 50 Euro, wenn nicht kostenlos.

  • bei Erfolg richte ich es in Deinem Shop ein und sende Dir die Problemlösung per Mail.
#13

[QUOTE=c4y;108757]
Nehme ich nur Weine, klappt alles. Sobald ich ein Präsent mit im Warenkorb lege, werden die Weine für die Versandkostenberechnung doppelt gezählt.
[/QUOTE]
Hab das im Demoshop ausprobiert, da ist das genauso, ist also wohl ein Bug.