Versandkostenregeln Preis Untergrenze fehlerhaft

Hallo,

ich habe ein komischen Phänomen. Wir versenden wenig mit der Post, deshalb ist das nie aufgefallen.

Wenn ich bei den Versandkostenregeln eingebe: Preis > 0 bis <=50
und eine 2.Regel Preis von >50 bis <= 1000

Dann wird die 2. Regel schon bei 25€ angezogen. Ich habe es ein paar Mal mit anderen Werten ausprobiert, es ist immer die Untergrenze/2

Hat das schon jemand gesehen?

Ich benutze 4.8.7

Danke
Peter

Nachtrag: Nur bei Varianten Produkten.
Bei normalen Produkten funktioniert es richtig.

was erwartest Du?

Preis > 0 bis <=50
und eine 2.Regel Preis von >50 bis <= 1000

Die Regeln überschneiden sich

Korrekt wäre z.B.
>= 0 bis <= 50
>= 50.01 <= 1000

Damit sind die Regeln sauber abgetrennt.

tun sie nicht! (überschneiden)

tun sie doch.

OXID definiert die Regeln mit >= / <=

[QUOTE=wiedeking;153537]Nachtrag: Nur bei Varianten Produkten.
Bei normalen Produkten funktioniert es richtig.[/QUOTE]
Das liegt wahrscheinlich daran, weil in den Varianten kein Preis eingetragen ist.

[QUOTE=wiedeking;153537]Wenn ich bei den Versandkostenregeln eingebe: Preis > 0 bis <=50
und eine 2.Regel Preis von >50 bis <= 1000[/QUOTE]

Hier ist erstmal keine Überschneidung zu sehen. Laut Bild muss es aber anders.

https://bugs.oxid-esales.com/view.php?id=5650

Danke. ich habe es ausprobiert. Es liegt wirklich daran, das der ARtikel in mehreren Kategorien ist.
Wäre ich nie draufgekommen. Danke.

Das Problem besteht immer nocht. :frowning:

Irgendjemand eine Lösung? Der Bug 5650 ist schon seit monaten nicht gefixt!